aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-05 22:29:24 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-05 22:29:24 +0800
commitb0c564e46f12aedbe36e19961a5f8ba3ed25c728 (patch)
treec609aff93c5aebe8495297291f0723fc94b89f83 /games
parent7466d5363d97289bac872d84edbe308fc77fedef (diff)
downloadfreebsd-ports-gnome-b0c564e46f12aedbe36e19961a5f8ba3ed25c728.tar.gz
freebsd-ports-gnome-b0c564e46f12aedbe36e19961a5f8ba3ed25c728.tar.zst
freebsd-ports-gnome-b0c564e46f12aedbe36e19961a5f8ba3ed25c728.zip
- Add USES=gl
- Add missing USE_GL=gl - Convert USE_SDL=yes to USE_SDL=sdl - Silence patching - Switch to options helpers
Diffstat (limited to 'games')
-rw-r--r--games/tenebrae/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index e2b9b1a48e6b..e80b51418988 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -14,10 +14,10 @@ COMMENT= Quake engine with lighting similar to that in Doom III
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake dos2unix zip
-USE_GL= glu
-USE_SDL= yes
-USE_XORG= xxf86dga
+USES= gl gmake dos2unix zip
+USE_GL= gl glu
+USE_SDL= sdl
+USE_XORG= x11 xext xxf86vm xxf86dga
WRKSRC= ${WRKDIR}/${PORTNAME}_0
BUILD_WRKSRC= ${WRKSRC}/linux
@@ -31,7 +31,7 @@ OPTIONS_DEFAULT_amd64= ASM
ASM_MAKE_ENV= USE_ASM=1
post-patch:
- ${REINPLACE_CMD} -e 's|gray_1_2_4_to_8|expand_&|' \
+ @${REINPLACE_CMD} -e 's|gray_1_2_4_to_8|expand_&|' \
${WRKSRC}/gl_warp.c
pre-build:
@@ -42,6 +42,8 @@ do-install:
${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${Q1DIR}/${PORTNAME}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${STAGEDIR}${Q1DIR}/${PORTNAME}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${TR} -d '\r' < ${WRKDIR}/Tenebrae_Readme.txt \
> ${STAGEDIR}${DOCSDIR}/Tenebrae_Readme.txt