aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-27 03:40:59 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-27 03:40:59 +0800
commitba4c60131ca3b073588608699146353ee7d34fb7 (patch)
tree1cdb46df8f54360d452c999d7647ef3ce599cab3 /games
parent057d9e9a400de3ef406da54d4562585c51aa3ea8 (diff)
downloadfreebsd-ports-gnome-ba4c60131ca3b073588608699146353ee7d34fb7.tar.gz
freebsd-ports-gnome-ba4c60131ca3b073588608699146353ee7d34fb7.tar.zst
freebsd-ports-gnome-ba4c60131ca3b073588608699146353ee7d34fb7.zip
Add linux-goodway.
GoodWay is a powerful flight planner for the X-Plane flight simulator. WWW: http://www.xpgoodway.com/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-goodway/Makefile87
-rw-r--r--games/linux-goodway/distinfo3
-rw-r--r--games/linux-goodway/files/goodway.in23
-rw-r--r--games/linux-goodway/pkg-descr3
5 files changed, 117 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index f243a40760c2..ee5ebd9f51f0 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -334,6 +334,7 @@
SUBDIR += linux-enemyterritory
SUBDIR += linux-enemyterritory-fortress
SUBDIR += linux-enemyterritory-tce
+ SUBDIR += linux-goodway
SUBDIR += linux-nwnclient
SUBDIR += linux-nwserver
SUBDIR += linux-quake3-demo
diff --git a/games/linux-goodway/Makefile b/games/linux-goodway/Makefile
new file mode 100644
index 000000000000..f1d7cb7a44cd
--- /dev/null
+++ b/games/linux-goodway/Makefile
@@ -0,0 +1,87 @@
+# New ports collection makefile for: linux-goodway
+# Date created: 25 Nov 2005
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-goodway
+PORTVERSION= 3.2.0
+CATEGORIES= games linux
+MASTER_SITES= http://www.xpgoodwayteam.org/dwn_goodway/
+DISTNAME= goodwayv${GWVERSION}_free
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A flight planner for the X-Plane flight simulator
+
+BUILD_DEPENDS= icoconvert:${PORTSDIR}/graphics/icoconvert
+RUN_DEPENDS= X-Plane:${PORTSDIR}/games/linux-x-plane
+
+WRKSRC= ${WRKDIR}/GoodWay${GWVERSION}F
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+RESTRICTED= "Redistribution prohibited"
+ONLY_FOR_ARCHS= i386
+
+GWVERSION= ${PORTVERSION:S|.||g}
+
+XDIR= ${X11BASE}/lib/x-plane
+GWDIR= ${PREFIX}/lib/goodway
+GWDIR_REL= ${GWDIR:S,^${PREFIX}/,,}
+
+PLIST= ${WRKDIR}/pkg-plist
+PLIST_FILES= bin/goodway share/pixmaps/goodway.png
+PLIST_DIRS= ${GWDIR_REL}
+
+SUB_FILES= goodway
+SUB_LIST= GWDIR="${GWDIR}" PORTVERSION="${PORTVERSION}"
+
+DESKTOP_ENTRIES="GoodWay" \
+ "Manage flight plans" \
+ "goodway.png" \
+ "goodway" \
+ "Application;Game;" \
+ false
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/.scripts
+ @${MV} ${WRKSRC}/goodway ${WRKSRC}/.scripts
+ @${MKDIR} ${WRKSRC}/.scripts/JRE/bin
+ @${MV} ${WRKSRC}/JRE/bin/ControlPanel ${WRKSRC}/.scripts/JRE/bin
+ @${MKDIR} ${WRKSRC}/.scripts/JRE/javaws
+ @${MV} ${WRKSRC}/JRE/javaws/javaws ${WRKSRC}/.scripts/JRE/javaws
+ @${MKDIR} ${WRKSRC}/.programs/JRE/bin
+ @${MV} ${WRKSRC}/JRE/bin/* ${WRKSRC}/.programs/JRE/bin
+ @${MKDIR} ${WRKSRC}/.programs/JRE/javaws
+ @${MV} ${WRKSRC}/JRE/javaws/javawsbin ${WRKSRC}/.programs/JRE/javaws
+
+do-build:
+ @${ECHO_CMD} 'GNL_XPlaneEXE=${X11BASE}/bin/X-Plane' > ${WRKSRC}/Properties3.prf
+ @${ECHO_CMD} 'GNL_XPlaneDir=${X11BASE}/lib/x-plane' >> ${WRKSRC}/Properties3.prf
+ @icoconvert ${WRKSRC}/ICON1.ICO
+ @${MKDIR} ${WRKSRC}/.icons
+ @${MV} ${WRKSRC}/ICON1_*.png ${WRKSRC}/.icons
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${RM} -f ${PLIST}.dirs
+.for d in "" .programs .scripts
+ @cd ${WRKSRC}/${d} && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|${GWDIR_REL}/|' >> ${PLIST} && \
+ ${FIND} * -type d >> ${PLIST}.dirs
+.endfor
+ @${SORT} -ru ${PLIST}.dirs | ${SED} -e 's|^|@dirrm ${GWDIR_REL}/|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/goodway ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/.icons/ICON1_48X48_32bpp.png ${PREFIX}/share/pixmaps/goodway.png
+.for d in "" .programs .scripts
+ cd ${WRKSRC}/${d} && ${FIND} * -type d -exec ${MKDIR} "${GWDIR}/{}" \;
+.endfor
+ cd ${WRKSRC} && ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${GWDIR}/{}" \;
+ cd ${WRKSRC}/.programs && ${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${GWDIR}/{}" \;
+ cd ${WRKSRC}/.scripts && ${FIND} * -type f -exec ${INSTALL_SCRIPT} "{}" "${GWDIR}/{}" \;
+
+.include <bsd.port.mk>
diff --git a/games/linux-goodway/distinfo b/games/linux-goodway/distinfo
new file mode 100644
index 000000000000..42b41f9208b1
--- /dev/null
+++ b/games/linux-goodway/distinfo
@@ -0,0 +1,3 @@
+MD5 (goodwayv320_free.zip) = ffe10017dcb27c0475a68d44debe8d2c
+SHA256 (goodwayv320_free.zip) = 4ce04e4b84c57870ce93fbed56056c6ddf550adb8ee40991ccdbe790a57bbe7e
+SIZE (goodwayv320_free.zip) = 90856274
diff --git a/games/linux-goodway/files/goodway.in b/games/linux-goodway/files/goodway.in
new file mode 100644
index 000000000000..52fba6d79546
--- /dev/null
+++ b/games/linux-goodway/files/goodway.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+gwdir="%%GWDIR%%"
+userdir="$HOME/.goodway"
+portversion="%%PORTVERSION%%"
+
+# The executables need to be run from the data directory, and need to
+# write files in it. We therefore mirror the data directory hierarchy
+# in $userdir, and create symlinks to the data files.
+
+if [ "x`cat $userdir/version 2>/dev/null`" != "x$portversion" ]; then
+ echo "Updating hierarchy in $userdir"
+ cd $gwdir || exit 1
+ find * -type d -exec mkdir -p "$userdir/{}" \; || exit 1
+ find * -type f ! -name '*.prf' -exec ln -sf "$gwdir/{}" "$userdir/{}" \; || exit 1
+ if ! [ -e $userdir/Properties3.prf ]; then
+ install -m 644 $gwdir/Properties3.prf $userdir
+ fi
+ echo "$portversion" > $userdir/version || exit 1
+fi
+
+cd $userdir || exit 1
+exec /bin/sh ./goodway "$@"
diff --git a/games/linux-goodway/pkg-descr b/games/linux-goodway/pkg-descr
new file mode 100644
index 000000000000..8c7ed6a02f56
--- /dev/null
+++ b/games/linux-goodway/pkg-descr
@@ -0,0 +1,3 @@
+GoodWay is a powerful flight planner for the X-Plane flight simulator.
+
+WWW: http://www.xpgoodway.com/