aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-01 21:49:16 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-01 21:49:16 +0800
commitc19bbe6ccc3db1a5822e8d7cd80aa7fe751f02c5 (patch)
treee6f34aa61f303b64ec87584558f6cc6e1243b9f1 /games
parent74e33e2a907dc6ad8f1dca3f310c73ce051985f1 (diff)
downloadfreebsd-ports-gnome-c19bbe6ccc3db1a5822e8d7cd80aa7fe751f02c5.tar.gz
freebsd-ports-gnome-c19bbe6ccc3db1a5822e8d7cd80aa7fe751f02c5.tar.zst
freebsd-ports-gnome-c19bbe6ccc3db1a5822e8d7cd80aa7fe751f02c5.zip
- Add stage support
- Convert USE_GMAKE to USES - Convert LIB_DEPENDS to new syntax
Diffstat (limited to 'games')
-rw-r--r--games/fargoal/Makefile24
1 files changed, 8 insertions, 16 deletions
diff --git a/games/fargoal/Makefile b/games/fargoal/Makefile
index a1d44267f1bc..999ae88c85ac 100644
--- a/games/fargoal/Makefile
+++ b/games/fargoal/Makefile
@@ -11,35 +11,27 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Remake of classic roguelike game "Sword of Fargoal"
-LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
+LIB_DEPENDS= liballeg.so:${PORTSDIR}/devel/allegro
WRKSRC= ${WRKDIR}/${PORTNAME}/src
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake
SUB_FILES= ${PORTNAME}-sh
-NO_STAGE= yes
do-install:
-# Script
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
-
-# Program
- @${INSTALL_PROGRAM} ${WRKSRC}/../sword ${PREFIX}/libexec/${PORTNAME}
-
-# Data
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/../sword ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.for f in agreement.txt data gfx sfx
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/../${f} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} -R ${WRKSRC}/../${f} ${STAGEDIR}${DATADIR}
.endfor
post-install:
-# Fix permissions
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
- @${FIND} ${DATADIR} -type f -print0 | \
+ @${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
- @${FIND} ${DATADIR} -type d -print0 | \
+ @${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | \
${XARGS} -0 ${CHMOD} ${BINMODE}
.include <bsd.port.mk>