aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-03-16 15:03:44 +0800
committerkoobs <koobs@FreeBSD.org>2014-03-16 15:03:44 +0800
commitc587bc52e57df42821642479ee76c86ef6e5e086 (patch)
tree959593b038772866826274a41af1d0405016fa55 /games
parentb1019b25043dc4c4d38f308480ddcd646b3b0a29 (diff)
downloadfreebsd-ports-gnome-c587bc52e57df42821642479ee76c86ef6e5e086.tar.gz
freebsd-ports-gnome-c587bc52e57df42821642479ee76c86ef6e5e086.tar.zst
freebsd-ports-gnome-c587bc52e57df42821642479ee76c86ef6e5e086.zip
games/live-f1: Backport fix for missing sector times and weather
- Backport revision 114 [1] for issue 1292481 [2] that fixes "M-b~" characters in the sector time fields and removes the weather section who's data is no longer provided on the free FOM feed. - Use new LIB_DEPENDS convention [1] http://bazaar.launchpad.net/~davepusey/live-f1/live-f1/revision/114 [2] https://bugs.launchpad.net/live-f1/+bug/1292481
Diffstat (limited to 'games')
-rw-r--r--games/live-f1/Makefile3
-rw-r--r--games/live-f1/files/patch-issue-129248172
2 files changed, 74 insertions, 1 deletions
diff --git a/games/live-f1/Makefile b/games/live-f1/Makefile
index 70240e6c2ea0..6c98c0b13dc8 100644
--- a/games/live-f1/Makefile
+++ b/games/live-f1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= live-f1
PORTVERSION= 0.2.11
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
EXTRACT_SUFX= .tgz
@@ -12,7 +13,7 @@ COMMENT= Native client for the official Formula 1 Live Timing service
LICENSE= GPLv2
-LIB_DEPENDS= neon:${PORTSDIR}/www/neon29
+LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon29
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
diff --git a/games/live-f1/files/patch-issue-1292481 b/games/live-f1/files/patch-issue-1292481
new file mode 100644
index 000000000000..bd5fcca5ae50
--- /dev/null
+++ b/games/live-f1/files/patch-issue-1292481
@@ -0,0 +1,72 @@
+# Backport fix for missing sector time data
+# Issue: https://bugs.launchpad.net/live-f1/+bug/1292481
+# Changeset: http://bazaar.launchpad.net/~davepusey/live-f1/live-f1/revision/114
+
+=== modified file 'src/display.c' (properties changed: -x to +x)
+--- src/display.c 2014-03-15 09:32:53 +0000
++++ src/display.c 2014-03-15 10:39:36 +0000
+@@ -247,10 +247,10 @@
+ int car,
+ int type)
+ {
+- int y, x, sz, align, attr;
+- CarAtom *atom;
+- const char *text;
+- size_t len, pad;
++ int y, x, sz, align, attr;
++ CarAtom *atom;
++ unsigned const char *text;
++ size_t len, pad;
+
+ y = state->car_position[car - 1];
+ if (! y)
+@@ -415,17 +415,17 @@
+ break;
+ case QUALIFYING_SECTOR_1:
+ x = 48;
+- sz = 5;
++ sz = 3;
+ align = 1;
+ break;
+ case QUALIFYING_SECTOR_2:
+ x = 54;
+- sz = 5;
++ sz = 3;
+ align = 1;
+ break;
+ case QUALIFYING_SECTOR_3:
+ x = 60;
+- sz = 5;
++ sz = 3;
+ align = 1;
+ break;
+ case QUALIFYING_LAP:
+@@ -444,6 +444,9 @@
+ atom = &state->car_info[car - 1][type];
+ attr = attrs[atom->data];
+ text = atom->text;
++
++ if (text[0] == 0xE2) text = "*";
++
+ len = strlen ((const char *) text);
+
+ /* Check for over-long atoms */
+@@ -646,7 +649,7 @@
+ }
+
+ /* Display weather */
+-
++/*
+ int wline = 5;
+ wattrset (statwin, attrs[COLOUR_DATA]);
+
+@@ -698,7 +701,7 @@
+ wprintw(statwin, "%-2s%6dmb", "", state->pressure);
+ wmove (statwin, wline, 6);
+ waddch (statwin, '.');
+-
++*/
+ /* Update fastest lap line (race only) */
+
+ if (state->event_type == RACE_EVENT)
+