aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-28 17:06:13 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-28 17:06:13 +0800
commitc7f10f4f10a31c255b680e0f90cac8e66baf2457 (patch)
tree080e57c2ffb6c979a53b80b8de431b2ee3a1c247 /games
parente48b7466dec69335817989ca4010c99aa0838274 (diff)
downloadfreebsd-ports-gnome-c7f10f4f10a31c255b680e0f90cac8e66baf2457.tar.gz
freebsd-ports-gnome-c7f10f4f10a31c255b680e0f90cac8e66baf2457.tar.zst
freebsd-ports-gnome-c7f10f4f10a31c255b680e0f90cac8e66baf2457.zip
- Bump PORTREVISION for dependency change
- Remove dependency for devel/desktop-file-utils - Simplify DOCS installation handling
Diffstat (limited to 'games')
-rw-r--r--games/airstrike/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/games/airstrike/Makefile b/games/airstrike/Makefile
index 2b3fc20973c9..5a1a1647dbc2 100644
--- a/games/airstrike/Makefile
+++ b/games/airstrike/Makefile
@@ -3,6 +3,7 @@
PORTNAME= airstrike
PORTVERSION= c7
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
DISTNAME= ${PORTNAME}-pre6a-src_freebsd_and_v${DISTVERSION}
@@ -14,7 +15,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-pre6a-src
-USES= gmake desktop-file-utils
+USES= gmake
USE_SDL= image mixer sdl
ALL_TARGET=
INSTALLS_ICONS= yes
@@ -29,14 +30,13 @@ DOCSDIR2= ${DOCSDIR}/doc
DOC_FILES2= 1.0-features 33fps.out BUGS TODO WHISHLIST *.txt \
collisions.tm design.dia design.pdf fun.ps
-SUB_FILES= ${PORTNAME} \
- pkg-message
+OPTIONS_DEFINE= DOCS
+
+SUB_FILES= ${PORTNAME} pkg-message
DESKTOP_ENTRIES="Airstrike" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
-OPTIONS_DEFINE= DOCS
-
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS += -DLINUX|#CFLAGS += -DLINUX|' \
${WRKSRC}/src/Makefile
@@ -44,7 +44,7 @@ post-patch:
${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g'
do-build:
- @(cd ${WRKSRC} ; ${GMAKE} airstrike-sound)
+ @(cd ${WRKSRC} && ${GMAKE} airstrike-sound)
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
@@ -58,9 +58,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.6 \
${STAGEDIR}${MAN6PREFIX}/man/man6/
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
.include <bsd.port.mk>