aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2020-06-13 09:58:14 +0800
committerSteven Kreuzer <skreuzer@FreeBSD.org>2020-06-13 09:58:14 +0800
commitca639b45f4bae5f0a9203ed0c44e94579e8c96bd (patch)
treefc7ef2e67e53e34436be9f50fb1eec715cfe8f6e /games
parentf6234839ef5f69827b107638bbefc129937e347e (diff)
downloadfreebsd-ports-gnome-ca639b45f4bae5f0a9203ed0c44e94579e8c96bd.tar.gz
freebsd-ports-gnome-ca639b45f4bae5f0a9203ed0c44e94579e8c96bd.tar.zst
freebsd-ports-gnome-ca639b45f4bae5f0a9203ed0c44e94579e8c96bd.zip
Update to version 2.8284271.702
Diffstat (limited to 'games')
-rw-r--r--games/robotfindskitten/Makefile9
-rw-r--r--games/robotfindskitten/distinfo5
-rw-r--r--games/robotfindskitten/files/extrapatch-megahyperdeath26
-rw-r--r--games/robotfindskitten/files/patch-doc_robotfindskitten.624
-rw-r--r--games/robotfindskitten/files/patch-nki_Makefile.am7
-rw-r--r--games/robotfindskitten/files/patch-src-Makefile.in13
-rw-r--r--games/robotfindskitten/files/patch-src_Makefile.am12
7 files changed, 63 insertions, 33 deletions
diff --git a/games/robotfindskitten/Makefile b/games/robotfindskitten/Makefile
index 64958379ba3d..48ad0c420185 100644
--- a/games/robotfindskitten/Makefile
+++ b/games/robotfindskitten/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= robotfindskitten
-PORTVERSION= 2.7182818.701
-PORTREVISION= 1
+PORTVERSION= 2.8284271.702
PORTEPOCH= 1
CATEGORIES= games
-MASTER_SITES= http://robotfindskitten.org/download/POSIX/
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Yet another zen simulation
@@ -14,9 +12,12 @@ COMMENT= Yet another zen simulation
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= ncurses
+USES= autoreconf libtool ncurses
GNU_CONFIGURE= YES
+USE_GITHUB= yes
+GH_ACCOUNT= robotfindskitten
+
OPTIONS_DEFINE= EXTRANKI MEGAHYPERDEATH
EXTRANKI_DESC= Install additional Non Kitten Items
diff --git a/games/robotfindskitten/distinfo b/games/robotfindskitten/distinfo
index 42a51652fc06..e59cc067a21c 100644
--- a/games/robotfindskitten/distinfo
+++ b/games/robotfindskitten/distinfo
@@ -1,2 +1,3 @@
-SHA256 (robotfindskitten-2.7182818.701.tar.gz) = 7749a370796fd23e3b306b00de5f7fb7997a35fef30e3910ff159448c932d719
-SIZE (robotfindskitten-2.7182818.701.tar.gz) = 437810
+TIMESTAMP = 1591991760
+SHA256 (robotfindskitten-robotfindskitten-2.8284271.702_GH0.tar.gz) = bc199c96a0a2ef79621b548d0f223bd8dce5cff798b7277708e31037e32df9fb
+SIZE (robotfindskitten-robotfindskitten-2.8284271.702_GH0.tar.gz) = 79605
diff --git a/games/robotfindskitten/files/extrapatch-megahyperdeath b/games/robotfindskitten/files/extrapatch-megahyperdeath
index 2d0729863b50..e0464f1c8734 100644
--- a/games/robotfindskitten/files/extrapatch-megahyperdeath
+++ b/games/robotfindskitten/files/extrapatch-megahyperdeath
@@ -1,16 +1,17 @@
---- src/robotfindskitten.c.orig 2012-11-27 07:41:21.000000000 +0000
-+++ src/robotfindskitten.c 2013-02-07 14:44:42.000000000 +0000
-@@ -119,6 +119,9 @@
+--- src/robotfindskitten.c.orig 2020-03-01 17:25:06 UTC
++++ src/robotfindskitten.c
+@@ -119,6 +119,10 @@
#define KITTEN 1
#define BOGUS 2
+/* Finish him! */
+#define FATALITIES (sizeof fatalities / sizeof (char*))
+
++
typedef struct {
int x;
int y;
-@@ -139,6 +142,17 @@
+@@ -139,6 +143,17 @@ typedef struct {
char **messages;
} game_state;
@@ -25,35 +26,32 @@
+ "Your generation has no attention span anymore, so you get bored and leave."
+};
+
- /* global state */
- static game_state state;
+ char *nki_file;
-@@ -547,6 +561,8 @@
+ /* global state */
+@@ -556,6 +571,8 @@ static void instructions(void) {
"Robot must touch items to determine if they are kitten or not. The game\n"\
"ends when robotfindskitten. Alternatively, you may end the game by hitting\n"
"the q key or a good old-fashioned Ctrl-C.\n\n"\
-+"This version contains MegaHyperDeath(TM) technology. Every time you find\n"\
-+"something that is not kitten, you have a 1 in 10 chance of dying.\n\n"\
++"This version contains MegaHyperDeath(TM) technology. Every time you find\n"\
++"a kitten, you have a 1 in 10 chance of dying.\n\n"\
"See the documentation for more information.\n\n"\
"Press any key to start.\n"
);
-@@ -710,8 +726,17 @@
+@@ -719,7 +736,15 @@ static void main_loop(void) {
/* nothing happened */
break;
case BKITTEN:
- play_animation ( fromright );
-- finish ( 0 );
+ if ((rand() % 10) == 0) { /*RFK is boring, let's add explosions!*/
+ move ( 0, 0 );
+ addstr ( fatalities[rand() % FATALITIES] );
+ move ( 1, 0 );
+ addstr("You are dead. Sorry it didn't work out. Please insert $0.25 to continue.");
+ refresh();
-+ finish ( 0 );
+ } else {
+ play_animation ( fromright );
-+ finish ( 0 );
+ }
+ finish ( 0 );
break;
case BBOGUS:
- message ( state.messages[bnum] );
diff --git a/games/robotfindskitten/files/patch-doc_robotfindskitten.6 b/games/robotfindskitten/files/patch-doc_robotfindskitten.6
new file mode 100644
index 000000000000..4c9cfd22fbcc
--- /dev/null
+++ b/games/robotfindskitten/files/patch-doc_robotfindskitten.6
@@ -0,0 +1,24 @@
+--- doc/robotfindskitten.6.orig 2020-06-13 01:48:25 UTC
++++ doc/robotfindskitten.6
+@@ -31,10 +31,10 @@ at any time to quit. A good old-fashioned Ctrl-C quit
+ .\"
+ .SH OPTIONS
+ You can optionally specify the number of Non Kitten Items to use with
+-the -s option. The default is 20.
++the -n option. The default is 20.
+
+ You can set the random-number seed, normally initialized from the
+-system clock, with the -t option. This may be useful for debugging.
++system clock, with the -s option. This may be useful for debugging.
+
+ You can supply an arbitrary file from which to draw NKIs using the -f option.
+ .\"
+@@ -72,7 +72,7 @@ done, when the grey box on wheels was complete and whe
+ I, knew what had to be done, I felt deep sympathy for the machine. For I
+ had not destroyed the phantom, but merely exorcized it into another
+ body. The robot knew not why this task had to be performed, for I could
+-not imbue it with knowledge I did not myself posess. And at the same
++not imbue it with knowledge I did not myself possess. And at the same
+ time, I felt a sweeping sense of relief sweep over me, that somehow, the
+ dream that had driven me for my entire life had come one step closer to
+ fruition.
diff --git a/games/robotfindskitten/files/patch-nki_Makefile.am b/games/robotfindskitten/files/patch-nki_Makefile.am
new file mode 100644
index 000000000000..dc9a8005482a
--- /dev/null
+++ b/games/robotfindskitten/files/patch-nki_Makefile.am
@@ -0,0 +1,7 @@
+--- nki/Makefile.am.orig 2020-06-12 22:14:15 UTC
++++ nki/Makefile.am
+@@ -1,3 +1,3 @@
+-nkidir = $(datadir)/games/robotfindskitten
++nkidir = $(datadir)/robotfindskitten
+ nki_DATA = vanilla.nki
+ EXTRA_DIST=$(nki_DATA)
diff --git a/games/robotfindskitten/files/patch-src-Makefile.in b/games/robotfindskitten/files/patch-src-Makefile.in
deleted file mode 100644
index 36e31df30a7b..000000000000
--- a/games/robotfindskitten/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src.orig/Makefile.in 2012-12-21 14:56:49.000000000 -0500
-+++ src/Makefile.in 2013-01-03 21:15:59.000000000 -0500
-@@ -199,8 +199,8 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--execgamesdir = $(prefix)/games
--AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/games/robotfindskitten\"
-+execgamesdir = $(prefix)/bin
-+AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/robotfindskitten\"
- robotfindskitten_SOURCES = robotfindskitten.c
- SPLINT_SUPPRESSIONS = +charintliteral +charindex
- all: all-am
diff --git a/games/robotfindskitten/files/patch-src_Makefile.am b/games/robotfindskitten/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..7962570ecaa2
--- /dev/null
+++ b/games/robotfindskitten/files/patch-src_Makefile.am
@@ -0,0 +1,12 @@
+--- src/Makefile.am.orig 2020-06-12 22:12:10 UTC
++++ src/Makefile.am
+@@ -1,7 +1,7 @@
+-execgamesdir= $(prefix)/games
++execgamesdir= $(prefix)/bin
+ execgames_PROGRAMS=robotfindskitten
+
+-AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/games/robotfindskitten\"
++AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/robotfindskitten\"
+
+ robotfindskitten_SOURCES= robotfindskitten.c
+ #robotfindskitten_LDADD= -lncurses