aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-10 22:50:52 +0800
committergarga <garga@FreeBSD.org>2005-10-10 22:50:52 +0800
commitcc189dffc648c24a3274a3f6684b3ec7dfc3dfab (patch)
treefd113e68d14a0cc03ae17cc96cbdfb63d7c5ec30 /games
parent9dd4d8b8a3b1498450cba6ba036b2161f04fb3e5 (diff)
downloadfreebsd-ports-gnome-cc189dffc648c24a3274a3f6684b3ec7dfc3dfab.tar.gz
freebsd-ports-gnome-cc189dffc648c24a3274a3f6684b3ec7dfc3dfab.tar.zst
freebsd-ports-gnome-cc189dffc648c24a3274a3f6684b3ec7dfc3dfab.zip
- Use better way to convert CRLF to LF based on Porter's Handbook
Reported by: danfe
Diffstat (limited to 'games')
-rw-r--r--games/galaxyhack/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index 436be52d31b8..e1d78ad2fa03 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -40,9 +40,8 @@ post-extract:
${XARGS} -0 ${RM} -rf
# Convert DOS text files to UNIX
- @${FIND} -E ${WRKSRC} -type f \
- -iregex "(.*Makefile.*|.*\.(cpp|h))" \
- -exec ${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" {} \;
+ @${FIND} -E ${WRKSRC} -type f -iregex "(.*Makefile.*|.*\.(cpp|h))" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
do-install:
# Script