aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-25 01:05:47 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-25 01:05:47 +0800
commitcdbe93b11cf1157b5babb510bc18a4255fdb9511 (patch)
tree73b275d5acea0d662738a223a013bd035a592b17 /games
parentb3f220ed0ef1671e35c0dc0b9cfcd3cbd69c77a0 (diff)
downloadfreebsd-ports-gnome-cdbe93b11cf1157b5babb510bc18a4255fdb9511.tar.gz
freebsd-ports-gnome-cdbe93b11cf1157b5babb510bc18a4255fdb9511.tar.zst
freebsd-ports-gnome-cdbe93b11cf1157b5babb510bc18a4255fdb9511.zip
Does not build with wx 3.0
Use unicode version of 2.8 Use a c++11 enable compiler instead of hardcoding gcc Support stage
Diffstat (limited to 'games')
-rw-r--r--games/openyahtzee/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/openyahtzee/Makefile b/games/openyahtzee/Makefile
index ab58334ea886..98f0344ed9ba 100644
--- a/games/openyahtzee/Makefile
+++ b/games/openyahtzee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openyahtzee
PORTVERSION= 1.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Open%20Yahtzee/Open%20Yahtzee%20${PORTVERSION}
@@ -15,19 +15,18 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/scoped_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USE_BZIP2= yes
-USE_GCC= yes
-USE_WX= 2.8+
+USES= tar:bzip2 compiler:c++11-lang
+USE_WX= 2.8
+WX_UNICODE= yes
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN6= openyahtzee.6
PLIST_FILES= bin/openyahtzee \
share/applications/openyahtzee.desktop \
- share/pixmaps/openyahtzee.png
+ share/pixmaps/openyahtzee.png \
+ man/man6/openyahtzee.6.gz
-NO_STAGE= yes
.include <bsd.port.mk>