aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-07-02 02:08:45 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-07-02 02:08:45 +0800
commitd5f3cf13636d02ce2429c3d5f4dc9561193c73e4 (patch)
tree6ece3efc552b61e3f13c6aa6028c15a423d589dd /games
parent378cbb10327115138c3f30feb5e785d1b43f89df (diff)
downloadfreebsd-ports-gnome-d5f3cf13636d02ce2429c3d5f4dc9561193c73e4.tar.gz
freebsd-ports-gnome-d5f3cf13636d02ce2429c3d5f4dc9561193c73e4.tar.zst
freebsd-ports-gnome-d5f3cf13636d02ce2429c3d5f4dc9561193c73e4.zip
games/tome4: fix build on powerpc64, add USES=gl
There's no luajit for powerpc64. PR: 238598 Approved by: lifanov (maintainer timeout), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D20820
Diffstat (limited to 'games')
-rw-r--r--games/tome4/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index e9d634f429c6..e8ae229f4a88 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -25,7 +25,7 @@ DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
PLIST_SUB= PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/t-engine4-src-${PORTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH="" CC=${CC}
-USES= gmake openal:al tar:bzip2
+USES= gl gmake openal:al tar:bzip2
USE_SDL= image2 sdl2 ttf2
USE_GL= gl glu
USE_CSTD= gnu89
@@ -36,7 +36,7 @@ LLD_UNSAFE= yes
pre-build:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
-.if ${ARCH} == aarch64
+.if ${ARCH} == aarch64 || ${ARCH} == powerpc64
(cd ${WRKSRC} && premake4 --lua=default gmake)
.else
(cd ${WRKSRC} && premake4 gmake)