aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-02 01:27:15 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-02 01:27:15 +0800
commitd9df667ff3761f6ddf9d42ca41a140f18fefc191 (patch)
treebb8dad7f7d84266d2b65ee759222eaf47b60dda8 /games
parentdb17595787d15e4ffbd1a38c3f6640992f3c77a2 (diff)
downloadfreebsd-ports-gnome-d9df667ff3761f6ddf9d42ca41a140f18fefc191.tar.gz
freebsd-ports-gnome-d9df667ff3761f6ddf9d42ca41a140f18fefc191.tar.zst
freebsd-ports-gnome-d9df667ff3761f6ddf9d42ca41a140f18fefc191.zip
- Remove useless libs tampering
- Fix build on DragonFly
Diffstat (limited to 'games')
-rw-r--r--games/passage/Makefile16
-rw-r--r--games/passage/files/patch-gamma256_gameSource_Makefile.all (renamed from games/passage/files/patch-Makefile.all)4
-rw-r--r--games/passage/files/patch-minorGems_system_endian.h11
3 files changed, 20 insertions, 11 deletions
diff --git a/games/passage/Makefile b/games/passage/Makefile
index e68eb9751e26..a3cba9c7c1e6 100644
--- a/games/passage/Makefile
+++ b/games/passage/Makefile
@@ -13,27 +13,25 @@ COMMENT= Experimental video game by Jason Rohrer
USE_SDL= sdl
-WRKSRC= ${WRKDIR}/${DISTNAME}/gamma256/gameSource
+BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/gamma256/gameSource
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
post-patch:
- @${REINPLACE_CMD} -e 's|^\(PLATFORM_LINK_FLAGS =\).*|\1 -pthread|' \
- ${WRKSRC}/Makefile.GnuLinux
@${REINPLACE_CMD} -e 's|"graphics"|"${DATADIR}/graphics"|' \
- ${WRKSRC}/common.cpp
+ ${WRKSRC}/gamma256/gameSource/common.cpp
@${REINPLACE_CMD} -e 's|"music"|"${DATADIR}/music"|' \
- ${WRKSRC}/musicPlayer.cpp
+ ${WRKSRC}/gamma256/gameSource/musicPlayer.cpp
@${REINPLACE_CMD} -e 's|"settings"|"${DATADIR}/settings"|' \
- ${WRKDIR}/${DISTNAME}/minorGems/util/SettingsManager.cpp
+ ${WRKSRC}/minorGems/util/SettingsManager.cpp
do-configure:
- cd ${WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.all > Makefile
+ cd ${BUILD_WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.all > Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Passage ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/Passage ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${MKDIR} ${STAGEDIR}${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music settings" ${STAGEDIR}${DATADIR}/
+ cd ${BUILD_WRKSRC} && ${COPYTREE_SHARE} "graphics music settings" ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>
diff --git a/games/passage/files/patch-Makefile.all b/games/passage/files/patch-gamma256_gameSource_Makefile.all
index 3463a7caf7cb..289472b17fd0 100644
--- a/games/passage/files/patch-Makefile.all
+++ b/games/passage/files/patch-gamma256_gameSource_Makefile.all
@@ -1,5 +1,5 @@
---- Makefile.all.orig 2010-05-24 01:03:11.000000000 +0400
-+++ Makefile.all 2011-08-04 02:06:46.000000000 +0400
+--- gamma256/gameSource/Makefile.all.orig 2010-05-24 01:03:11.000000000 +0400
++++ gamma256/gameSource/Makefile.all 2011-08-04 02:06:46.000000000 +0400
@@ -1,8 +1,8 @@
ROOT_PATH = ../..
diff --git a/games/passage/files/patch-minorGems_system_endian.h b/games/passage/files/patch-minorGems_system_endian.h
new file mode 100644
index 000000000000..c98cdd88b459
--- /dev/null
+++ b/games/passage/files/patch-minorGems_system_endian.h
@@ -0,0 +1,11 @@
+--- minorGems/system/endian.h.orig 2009-04-03 17:39:19.000000000 +0400
++++ minorGems/system/endian.h 2015-03-27 02:42:33.353630000 +0300
+@@ -25,7 +25,7 @@
+
+
+
+-#ifdef __FreeBSD__
++#if defined(__FreeBSD__) || defined(__DragonFly__)
+ #include <machine/endian.h>
+
+