aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-06 20:17:30 +0800
committerKris Kennaway <kris@FreeBSD.org>2004-03-06 20:17:30 +0800
commitde0ab4aa1bd98696f67abca37c5019bc0732ca51 (patch)
tree846c7ba861c614c04204f998d5b89f76e965f9aa /games
parentc010659195e23ea3b0dfb259c50181586cdf2e9e (diff)
downloadfreebsd-ports-gnome-de0ab4aa1bd98696f67abca37c5019bc0732ca51.tar.gz
freebsd-ports-gnome-de0ab4aa1bd98696f67abca37c5019bc0732ca51.tar.zst
freebsd-ports-gnome-de0ab4aa1bd98696f67abca37c5019bc0732ca51.zip
BROKEN on amd64: Does not compile
Diffstat (limited to 'games')
-rw-r--r--games/glasteroids/Makefile8
-rw-r--r--games/kobodeluxe/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index c0dae1f4edb9..87efb65cd33b 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -25,6 +25,12 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@${MKDIR} ${DATADIR}
@@ -39,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 4c9b84ceb54c..69701d504bc8 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -27,7 +27,13 @@ USE_AUTOMAKE_VER= 15
AUTOCONF= autoconf
ACLOCAL= aclocal
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not compile on amd64"
+.endif
+
pre-configure:
cd ${WRKDIR}/${DISTNAME} && ${ACLOCAL} && ${AUTOCONF} && ${AUTOHEADER}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>