aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-10 10:53:42 +0800
committerswills <swills@FreeBSD.org>2012-09-10 10:53:42 +0800
commite0d594619b09a9c766c115dddfc8e12131b17335 (patch)
tree06cb0964d303fbf37092750811209d31edcdf48c /games
parentbdac4d64eb927c5e546a496ceab0191c8b6773ba (diff)
downloadfreebsd-ports-gnome-e0d594619b09a9c766c115dddfc8e12131b17335.tar.gz
freebsd-ports-gnome-e0d594619b09a9c766c115dddfc8e12131b17335.tar.zst
freebsd-ports-gnome-e0d594619b09a9c766c115dddfc8e12131b17335.zip
- Add additional MASTER_SITES entry
- Avoid pkg-plist due to small file list - Convert to OptionsNG - Give maintainership to submitter PR: ports/171264 Submitted by: nemysis <nemysis@gmx.ch>
Diffstat (limited to 'games')
-rw-r--r--games/icbm3d/Makefile38
-rw-r--r--games/icbm3d/distinfo2
-rw-r--r--games/icbm3d/files/patch-aa22
-rw-r--r--games/icbm3d/files/patch-makefile22
-rw-r--r--games/icbm3d/pkg-descr26
-rw-r--r--games/icbm3d/pkg-plist3
6 files changed, 66 insertions, 47 deletions
diff --git a/games/icbm3d/Makefile b/games/icbm3d/Makefile
index ee44b33a3651..2d93d092a216 100644
--- a/games/icbm3d/Makefile
+++ b/games/icbm3d/Makefile
@@ -7,24 +7,42 @@
PORTNAME= icbm3d
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ftp://ftp.billsgames.com/unix/x/icbm3d/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= ftp://ftp.tuxpaint.org/unix/x/icbm3d/ \
+ ftp://ftp.billsgames.com/unix/x/icbm3d/ \
+ http://www.newbreedsoftware.com/images/prodicons/:icons
+DISTFILES= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.gif:icons
+EXTRACT_ONLY= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= "Inter-Continental Ballistic Missiles, 3D" - 3D game of defense
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Inter-Continental Ballistic Missiles, 3D
WRKSRC= ${WRKDIR}/icbm3d
+
USE_XORG= x11
MAKEFILE= makefile
-ALL_TARGET= icbm3d
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.gif
+
+PORTDOCS= README.txt
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/icbm3d ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/icbm3d
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/icbm3d
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Pixmaps
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.gif ${PREFIX}/share/pixmaps/
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/icbm3d/distinfo b/games/icbm3d/distinfo
index fcb92bcd3643..87980476153c 100644
--- a/games/icbm3d/distinfo
+++ b/games/icbm3d/distinfo
@@ -1,2 +1,4 @@
SHA256 (icbm3d.0.4.tar.gz) = 9ad41c154ef47695771a26875d5415bcedcb139352b1e2175f386d206b0038fd
SIZE (icbm3d.0.4.tar.gz) = 31187
+SHA256 (icbm3d.gif) = e5d6d45ee11ff669414ac2e22943a0786b62b72035884a06abd5f12dcd0d5f15
+SIZE (icbm3d.gif) = 1024
diff --git a/games/icbm3d/files/patch-aa b/games/icbm3d/files/patch-aa
index b9f935070eca..e69de29bb2d1 100644
--- a/games/icbm3d/files/patch-aa
+++ b/games/icbm3d/files/patch-aa
@@ -1,22 +0,0 @@
---- makefile Fri Jul 31 04:41:20 1998
-+++ /home/andy/tmp/wrk/makefile Mon Aug 10 18:40:01 1998
-@@ -9,14 +9,16 @@
-
- # Makefile user-definable variables------------------------------------------
-
--CC=gcc
-+CC?=gcc
-+PREFIX?=/usr/X11R6
-+LOCALBASE?=/usr/X11R6
- MATHLIB=-lm
-
- INSTALLROOT=$(PREFIX)
- LANGUAGE=english
-
--XLIB=-L$(PREFIX)/lib -lX11 #-lcompat
--CFLAGS=-I$(PREFIX)/include -O2
-+XLIB=-L$(LOCALBASE)/lib -lX11 #-lcompat
-+CFLAGS+=-I$(LOCALBASE)/include
-
-
- # End of makefile user-definable variables-----------------------------------
diff --git a/games/icbm3d/files/patch-makefile b/games/icbm3d/files/patch-makefile
new file mode 100644
index 000000000000..09919c80adb8
--- /dev/null
+++ b/games/icbm3d/files/patch-makefile
@@ -0,0 +1,22 @@
+--- makefile.orig 1998-07-31 06:41:20.000000000 +0200
++++ makefile 2012-09-02 23:21:36.000000000 +0200
+@@ -9,14 +9,16 @@
+
+ # Makefile user-definable variables------------------------------------------
+
+-CC=gcc
++CC?=g++
++PREFIX?=/usr/local
++LOCALBASE?=/usr/local
+ MATHLIB=-lm
+
+ INSTALLROOT=$(PREFIX)
+ LANGUAGE=english
+
+-XLIB=-L$(PREFIX)/lib -lX11 #-lcompat
+-CFLAGS=-I$(PREFIX)/include -O2
++XLIB=-L$(LOCALBASE)/lib -lX11 #-lcompat
++CFLAGS+=-I$(LOCALBASE)/include
+
+
+ # End of makefile user-definable variables-----------------------------------
diff --git a/games/icbm3d/pkg-descr b/games/icbm3d/pkg-descr
index ff564a544312..d127ec1151ef 100644
--- a/games/icbm3d/pkg-descr
+++ b/games/icbm3d/pkg-descr
@@ -1,14 +1,16 @@
- Like the original "Missile Command" and its clones, this game
-places you in control of Anti-ICBM weapons which you use to
-destroy an onslaught of missiles (and other nasties) which are
-dropping onto your nation.
- The game ends when your cities have all been destroyed. You
-only gain replacement cities by acheiving certain score
-thresholds during each attack (level).
- The main difference between this game and Missile Command is
-that ICBM3D, as the name suggests, provides a 3D perspective.
-You take advantage of X-Window's 3-button mouse to control your
-firing sight ("cross-hair") in 3-dimensions, and change your
-viewpoint.
+ICBM3D ("Inter-Continental Ballistic Missiles, 3D") is a 3D game of defense.
+
+Like the original "Missile Command" and its clones, this game places you in
+control of Anti-ICBM weapons which you use to destroy an onslaught of
+missiles (and other nasties) which are dropping onto your nation.
+
+The game ends when your cities have all been destroyed. You only gain
+replacement cities by acheiving certain score thresholds during each attack
+(level).
+
+The main difference between this game and Missile Command is that ICBM3D,
+as the name suggests, provides a 3D perspective. You take advantage of
+X-Window's 3-button mouse to control your firing sight ("cross-hair")
+in 3-dimensions, and change your viewpoint.
WWW: http://www.newbreedsoftware.com/icbm3d/
diff --git a/games/icbm3d/pkg-plist b/games/icbm3d/pkg-plist
deleted file mode 100644
index 32419baa3a5e..000000000000
--- a/games/icbm3d/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/icbm3d
-%%PORTDOCS%%share/doc/icbm3d/README.txt
-%%PORTDOCS%%@dirrm share/doc/icbm3d