aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 16:21:30 +0800
committerJohn Marino <marino@FreeBSD.org>2016-01-31 16:21:30 +0800
commite360f901a9b651f265ca66853d6967eb09704ff6 (patch)
treea25d3b264113c593e066db4e3e7b708b12d3b946 /games
parentd48088b1f02e15ef5d660d6c073984f524ecd1d5 (diff)
downloadfreebsd-ports-gnome-e360f901a9b651f265ca66853d6967eb09704ff6.tar.gz
freebsd-ports-gnome-e360f901a9b651f265ca66853d6967eb09704ff6.tar.zst
freebsd-ports-gnome-e360f901a9b651f265ca66853d6967eb09704ff6.zip
games/trojka: Respect LDFLAGS, document ncurses requirement
Also specific libncurses rather the libcurses (it's the same thing on FreeBSD so that's a no-op). This port could use some TLC, modern GCC spews easily fixed warnings everywhere.
Diffstat (limited to 'games')
-rw-r--r--games/trojka/Makefile2
-rw-r--r--games/trojka/files/patch-Makefile12
2 files changed, 12 insertions, 2 deletions
diff --git a/games/trojka/Makefile b/games/trojka/Makefile
index 0cde2dddb2b8..994e06149808 100644
--- a/games/trojka/Makefile
+++ b/games/trojka/Makefile
@@ -16,4 +16,6 @@ LICENSE_NAME= Trojka Copyright
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USES= ncurses
+
.include <bsd.port.mk>
diff --git a/games/trojka/files/patch-Makefile b/games/trojka/files/patch-Makefile
index 7ef783233713..bfe18b4308db 100644
--- a/games/trojka/files/patch-Makefile
+++ b/games/trojka/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig 1995-10-20 21:17:43 UTC
+++ Makefile
-@@ -6,14 +6,24 @@
+@@ -6,21 +6,31 @@
#
@@ -27,7 +27,15 @@
clean:
rm -f $(PROGS) *.o core a.out trojka.scores
-@@ -53,3 +63,5 @@ hpux:
+
+ trojka: $(OBJS)
+ # $(CC) $(CFLAGS) $(OBJS) -lcurses -ltermlib -o trojka
+- $(CC) $(CFLAGS) $(OBJS) -lcurses -o trojka
++ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) -lncurses -o trojka
+
+
+ # patch for HP-UX, need 'codelibs'
+@@ -53,3 +63,5 @@ hpux:
linux:
make trojka "CFLAGS=-DLINUX"