aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-30 17:29:00 +0800
committertobik <tobik@FreeBSD.org>2018-07-30 17:29:00 +0800
commite793b87d9ea21bbcf076fa702f2df03e933fc7fd (patch)
treeb1bf1a41fe400c60fcd24ee6a7755a1b37c6d504 /games
parentf16ef310e7bb07fa8ffb7505c1895eb66795b79a (diff)
downloadfreebsd-ports-gnome-e793b87d9ea21bbcf076fa702f2df03e933fc7fd.tar.gz
freebsd-ports-gnome-e793b87d9ea21bbcf076fa702f2df03e933fc7fd.tar.zst
freebsd-ports-gnome-e793b87d9ea21bbcf076fa702f2df03e933fc7fd.zip
games/xminehunter: Fix build with Clang 6
./bitmaps/bomb:5:28: error: constant expression evaluates to 144 which cannot be narrowed to type 'char' [-Wc++11-narrowing] 0x00, 0x00, 0x00, 0x00, 0x90, 0x00, 0x00, 0x00, 0x40, 0x02, 0x00, 0x00, ^~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475478_s336801/logs/errors/xminehunter-0.4_4.log - Actually install the binary as executable (broken 5 years ago in r337083)
Diffstat (limited to 'games')
-rw-r--r--games/xminehunter/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/xminehunter/Makefile b/games/xminehunter/Makefile
index 7fd6bdcdde6f..156741afc4ed 100644
--- a/games/xminehunter/Makefile
+++ b/games/xminehunter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xminehunter
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= XCONTRIB/games
@@ -17,10 +17,12 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= motif
+USES= compiler motif
USE_XORG= xpm
ALL_TARGET= ${PORTNAME}
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -43,13 +45,12 @@ post-patch:
s|$${CFLAGS}|$${CXXFLAGS}| ; \
s| \($${INSTALL_SCORE_PATH}\)| $${DESTDIR}\1| ; \
s|chmod 333|chmod 633| ; \
- s|cp |$${BSD_INSTALL_DATA} | ; \
+ s|cp |$${BSD_INSTALL_PROGRAM} | ; \
s| \($${INSTALL_BIN_PATH}\)| $${DESTDIR}\1|' \
${WRKSRC}/${MAKEFILE}
post-install:
(cd ${WRKSRC}/bitmaps && ${INSTALL_DATA} normal.xpm \
${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.xpm)
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>