aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-12 04:50:18 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-01-12 04:50:18 +0800
commite943a340a6e3c8e87fcd398617ad6b7db6519d07 (patch)
tree6fa5687793be7fae24ded15185cba1a2e177971e /games
parent0ad26a2870b8a6ff6a8b7ebb89218b3449f01877 (diff)
downloadfreebsd-ports-gnome-e943a340a6e3c8e87fcd398617ad6b7db6519d07.tar.gz
freebsd-ports-gnome-e943a340a6e3c8e87fcd398617ad6b7db6519d07.tar.zst
freebsd-ports-gnome-e943a340a6e3c8e87fcd398617ad6b7db6519d07.zip
- Update to 0.1.2
PR: 224482 Submitted by: kevinz5000@gmail.com
Diffstat (limited to 'games')
-rw-r--r--games/openspades/Makefile25
-rw-r--r--games/openspades/distinfo9
-rw-r--r--games/openspades/files/patch-CMakeLists.txt8
-rw-r--r--games/openspades/files/patch-Sources__CMakeLists.txt15
-rw-r--r--games/openspades/files/patch-Sources__Core__ConcurrentDispatch.cpp20
-rw-r--r--games/openspades/files/patch-Sources__Draw__SWFeatureLevel.h10
-rw-r--r--games/openspades/pkg-descr2
7 files changed, 20 insertions, 69 deletions
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index 8f9d5cd37319..b00156727df8 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= openspades
-PORTVERSION= 0.0.12
+PORTVERSION= 0.1.2
DISTVERSIONPREFIX= v
-PORTREVISION= 8
CATEGORIES= games
-MASTER_SITES= http://yvt.jp/files/programs/osppaks/:data
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} DevPaks27.zip:data
+MASTER_SITES= https://github.com/yvt/openspades-paks/releases/download/r33/:data
+DISTFILES= OpenSpadesDevPackage-r33.zip:data
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Compatible client of Ace of Spades
@@ -15,16 +14,17 @@ COMMENT= Compatible client of Ace of Spades
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= convert:graphics/ImageMagick6 # for building icons
-LIB_DEPENDS= libcurl.so:ftp/curl
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= bundles non-portable AngelScript
-BROKEN_aarch64= fails to compile: uses x86 assembly
-BROKEN_powerpc64= fails to compile: uses x86 assembly
+BUILD_DEPENDS= convert:graphics/ImageMagick6 # for building icons
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libopusfile.so:audio/opusfile
USE_GITHUB= yes
GH_ACCOUNT= yvt
-USES= cmake:insource compiler:c++11-lib desktop-file-utils
+USES= cmake:insource compiler:c++11-lib desktop-file-utils gl gnome openal
CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_MAN="man/man6" \
-DOPENSPADES_INSTALL_BINARY="bin" \
@@ -39,10 +39,13 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
post-extract:
- @${MKDIR} ${WRKSRC}/Resources/DevPak
- @${MV} ${WRKDIR}/*.pak ${WRKSRC}/Resources/DevPak/
+ @${MV} ${WRKDIR}/Nonfree/*.pak ${WRKDIR}/OfficialMods/*.pak \
+ ${WRKSRC}/Resources/
post-patch:
@${REINPLACE_CMD} -e 's|Xext|${LOCALBASE}/lib/lib&.so|' ${WRKSRC}/Sources/CMakeLists.txt
+post-install:
+ cd ${WRKSRC}/Resources/ && ${COPYTREE_SHARE} "Gfx Locales Maps Models PackageInfo.json Scripts Shaders Sounds Textures *.pak" ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>
diff --git a/games/openspades/distinfo b/games/openspades/distinfo
index 16019d4b797d..112bb094f694 100644
--- a/games/openspades/distinfo
+++ b/games/openspades/distinfo
@@ -1,4 +1,5 @@
-SHA256 (yvt-openspades-v0.0.12_GH0.tar.gz) = f5778f12cf42c46b14ed8decb0a312998839ea9f7927058fb919a3c9182248a9
-SIZE (yvt-openspades-v0.0.12_GH0.tar.gz) = 1984521
-SHA256 (DevPaks27.zip) = 668b62d3770f407447e6f45df28928f66a7fe3440c541788f66583f31ae5c717
-SIZE (DevPaks27.zip) = 19597524
+TIMESTAMP = 1521997974
+SHA256 (yvt-openspades-v0.1.2_GH0.tar.gz) = f4947232eded073469d07935783786efd70e7d73e615326dbb66676c4e8724a8
+SIZE (yvt-openspades-v0.1.2_GH0.tar.gz) = 7474808
+SHA256 (OpenSpadesDevPackage-r33.zip) = 0927dc323a0b3aba0ee8d1d68d6b544b00fe654740fead6d1faad37aac77a2ad
+SIZE (OpenSpadesDevPackage-r33.zip) = 4036321
diff --git a/games/openspades/files/patch-CMakeLists.txt b/games/openspades/files/patch-CMakeLists.txt
deleted file mode 100644
index 2aae4d58177d..000000000000
--- a/games/openspades/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- CMakeLists.txt.orig 2014-06-23 11:55:03 UTC
-+++ CMakeLists.txt
-@@ -1,5 +1,4 @@
- cmake_minimum_required(VERSION 2.8)
--set(CMAKE_INSTALL_PREFIX "/usr/local")
- project(OpenSpades)
-
- set(OpenSpades_VERSION_MAJOR 0)
diff --git a/games/openspades/files/patch-Sources__CMakeLists.txt b/games/openspades/files/patch-Sources__CMakeLists.txt
deleted file mode 100644
index 24a778f6e074..000000000000
--- a/games/openspades/files/patch-Sources__CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- Sources/CMakeLists.txt.orig 2014-06-23 11:55:03 UTC
-+++ Sources/CMakeLists.txt
-@@ -24,9 +24,9 @@ add_subdirectory(AngelScript/projects/cm
- add_subdirectory(AngelScript/projects/cmake_addons)
- set(ANGELSCRIPT_LIBS Angelscript Angelscript_addons)
-
--include_directories(".")
--include_directories("json/include")
--include_directories("ENet/include")
-+include_directories(BEFORE ".")
-+include_directories(BEFORE "json/include")
-+include_directories(BEFORE "ENet/include")
-
- if(WIN32)
- if(MINGW) # = gcc, can someone confirm that this works?
diff --git a/games/openspades/files/patch-Sources__Core__ConcurrentDispatch.cpp b/games/openspades/files/patch-Sources__Core__ConcurrentDispatch.cpp
deleted file mode 100644
index ac8e7d44cac4..000000000000
--- a/games/openspades/files/patch-Sources__Core__ConcurrentDispatch.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- Sources/Core/ConcurrentDispatch.cpp.orig 2014-06-23 11:55:03 UTC
-+++ Sources/Core/ConcurrentDispatch.cpp
-@@ -38,7 +38,7 @@
- #ifndef _MSC_VER
- #include <unistd.h>
- #endif
--#if defined(__GNUC__)
-+#if defined(__linux__)
- #include <sys/sysinfo.h>
- #endif
- #endif
-@@ -67,7 +67,7 @@ static int GetNumCores() {
- if(count < 1) { count = 1; }
- }
- return count;
--#elif defined(__GNUC__)
-+#elif defined(__linux__)
- return get_nprocs();
- #else
- return sysconf(_SC_NPROCESSORS_ONLN);
diff --git a/games/openspades/files/patch-Sources__Draw__SWFeatureLevel.h b/games/openspades/files/patch-Sources__Draw__SWFeatureLevel.h
deleted file mode 100644
index 246431d67c00..000000000000
--- a/games/openspades/files/patch-Sources__Draw__SWFeatureLevel.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- Sources/Draw/SWFeatureLevel.h.orig 2014-06-23 11:55:03 UTC
-+++ Sources/Draw/SWFeatureLevel.h
-@@ -55,6 +55,7 @@
- #endif
-
- #include <algorithm>
-+#include <cmath>
- #include <Core/ConcurrentDispatch.h>
- #include <Core/Debug.h>
-
diff --git a/games/openspades/pkg-descr b/games/openspades/pkg-descr
index f704e74b2cd7..e232ad381536 100644
--- a/games/openspades/pkg-descr
+++ b/games/openspades/pkg-descr
@@ -4,4 +4,4 @@ OpenSpades is a compatible client of Ace of Spades 0.75.
* Uses OpenGL/AL for better visuals.
* Open source, and cross platform.
-WWW: http://www.openspades.org/
+WWW: http://openspades.yvt.jp/