aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
committereadler <eadler@FreeBSD.org>2012-01-22 01:40:15 +0800
commite9db6e5787c03eac4b5310b1b5abeee5eea88e8c (patch)
tree403e868e6517b550ecdf81ff503e5975785ab7d7 /games
parent0c9cbf4cb27b7ccab5b886919dea648ef53e8a6b (diff)
downloadfreebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.gz
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.tar.zst
freebsd-ports-gnome-e9db6e5787c03eac4b5310b1b5abeee5eea88e8c.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Diffstat (limited to 'games')
-rw-r--r--games/monsterz/Makefile2
-rw-r--r--games/p5-Baseball-Sabermetrics/Makefile2
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile2
-rw-r--r--games/pear-Games_Chess/Makefile2
-rw-r--r--games/poker-engine/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
index 107f420588a5..ab19a1dd33e5 100644
--- a/games/monsterz/Makefile
+++ b/games/monsterz/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
MAKE_ENV= prefix=${PREFIX}
diff --git a/games/p5-Baseball-Sabermetrics/Makefile b/games/p5-Baseball-Sabermetrics/Makefile
index cb5d2de99104..aaacdd0f8d0f 100644
--- a/games/p5-Baseball-Sabermetrics/Makefile
+++ b/games/p5-Baseball-Sabermetrics/Makefile
@@ -17,7 +17,7 @@ COMMENT= A Baseball Statistics Module
BUILD_DEPENDS= p5-Data-Serializer>=0.29:${PORTSDIR}/devel/p5-Data-Serializer \
p5-HTML-TableExtract>=2.08:${PORTSDIR}/www/p5-HTML-TableExtract \
p5-libwww>=5.801:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index 260201ffee42..3ba7d2534963 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= lth@FreeBSD.org
COMMENT= A simple class holding IRC related methods for bingo
BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/games/pear-Games_Chess/Makefile b/games/pear-Games_Chess/Makefile
index 45b419ba928c..7fc484442fda 100644
--- a/games/pear-Games_Chess/Makefile
+++ b/games/pear-Games_Chess/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR methods for constructing and validating chess games in PGN
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
CATEGORY= Games
FILES= Chess/Crazyhouse.php Chess/Losers.php Chess/Standard.php \
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index f4a9ba648eb9..468b331c5a1b 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING