aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-12-12 04:40:47 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2018-12-12 04:40:47 +0800
commited6908d89eb95d5647fe849d3b824862fe84f7e5 (patch)
tree8005913f5badd018460b2ba2ecbad2eb4df4910f /games
parent087b44233d1571440d00c6425bf42d924eb36338 (diff)
downloadfreebsd-ports-gnome-ed6908d89eb95d5647fe849d3b824862fe84f7e5.tar.gz
freebsd-ports-gnome-ed6908d89eb95d5647fe849d3b824862fe84f7e5.tar.zst
freebsd-ports-gnome-ed6908d89eb95d5647fe849d3b824862fe84f7e5.zip
- Mark pokerth broken with OpenSSL 1.1 and newer
- Silence portling warning
Diffstat (limited to 'games')
-rw-r--r--games/pokerth/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index e964bb92e302..aeff6dd6cc42 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -16,6 +16,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2019-03-15
+BROKEN_SSL= openssl111 openssl-devel
+BROKEN_SSL_REASON= Does not build with OpenSSL 1.1, variable has incomplete type 'EVP_CIPHER_CTX'
+
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libmikmod.so:audio/libmikmod \
libgnutls.so:security/gnutls \
@@ -31,6 +34,7 @@ USE_CXXSTD= c++11
USE_QT= gui corelib network sql sql-sqlite3 \
moc_build rcc_build uic_build
USE_SDL= mixer
+
QMAKE_SOURCE_PATH= pokerth.pro
QMAKE_ARGS+= CONFIG+="client"
WRKSRC= ${WRKDIR}/${DISTNAME}-rc
@@ -39,6 +43,12 @@ PORTDOCS= server_setup_howto.txt
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+BROKEN= ${BROKEN_SSL_REASON}
+.endif
+
post-patch:
@${REINPLACE_CMD} -E \
-e 's|/usr([a-z|/]*)|${LOCALBASE}/\1|g' \