aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-19 19:26:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-19 19:26:26 +0800
commitf05a4d3c04bd08ffcc45d6fde1a839d8243571fa (patch)
treea2a5e10b7b98d7ff46cdc32006b0d1d3105c5bec /games
parent8da851960517a093e4a943d5bbd418dbe5a7ce19 (diff)
downloadfreebsd-ports-gnome-f05a4d3c04bd08ffcc45d6fde1a839d8243571fa.tar.gz
freebsd-ports-gnome-f05a4d3c04bd08ffcc45d6fde1a839d8243571fa.tar.zst
freebsd-ports-gnome-f05a4d3c04bd08ffcc45d6fde1a839d8243571fa.zip
OpenTyrian is a port of the DOS shoot-em-up Tyrian. Jason Emery
generously gave the OpenTyrian developers a copy of the Tyrian 2.1 source code, which has since been ported from Turbo Pascal to C. The port uses SDL, making it easily cross-platform. Tyrian is an arcade-style vertical scrolling shooter. The story is set in 20,031 where you play as Trent Hawkins, a skilled fighter-pilot employed to fight Microsol and save the galaxy. WWW: https://bitbucket.org/opentyrian/opentyrian/wiki/Home
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/opentyrian/Makefile52
-rw-r--r--games/opentyrian/distinfo3
-rw-r--r--games/opentyrian/files/patch-Makefile33
-rw-r--r--games/opentyrian/files/pkg-message.in6
-rw-r--r--games/opentyrian/pkg-descr10
-rw-r--r--games/opentyrian/pkg-plist5
7 files changed, 110 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5ae0f873ba8c..9e63ab48bd21 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -687,6 +687,7 @@
SUBDIR += openssn
SUBDIR += opensurge
SUBDIR += openttd
+ SUBDIR += opentyrian
SUBDIR += openxcom
SUBDIR += openyahtzee
SUBDIR += optimax
diff --git a/games/opentyrian/Makefile b/games/opentyrian/Makefile
new file mode 100644
index 000000000000..bb823a0f8ac1
--- /dev/null
+++ b/games/opentyrian/Makefile
@@ -0,0 +1,52 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= opentyrian
+PORTVERSION= 2.1.20130907
+CATEGORIES= games
+MASTER_SITES= https://bitbucket.org/opentyrian/opentyrian/get/ \
+ http://mirror.amdmi3.ru/distfiles/
+DISTNAME= ${PORTVERSION}
+DIST_SUBDIR= opentyrian
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Arcade-style vertical scrolling shooter
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-77a8715634e3
+
+USES= gmake tar:bzip2
+MAKE_ENV= ALL_CFLAGS="${CFLAGS}"
+USE_SDL= sdl
+SUB_FILES= pkg-message
+DATADIR= ${PREFIX}/share/tyrian
+
+PORTDOCS= CREDITS NEWS README
+
+OPTIONS_DEFINE= NETWORK DOCS
+
+NETWORK_DESC= Enable network support
+NETWORK_USE= SDL=net
+NETWORK_MAKE_ON= WITH_NETWORK=true
+NETWORK_MAKE_OFF= WITH_NETWORK=false
+
+post-patch:
+ @${REINPLACE_CMD} -e '/custom_data_dir/ s|"."|"${DATADIR}"|' ${WRKSRC}/src/file.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/linux/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/linux/icons/tyrian-32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_MAN} ${WRKSRC}/linux/man/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${TOUCH} ${STAGEDIR}${DATADIR}/.keepme
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/opentyrian/distinfo b/games/opentyrian/distinfo
new file mode 100644
index 000000000000..9e753c4a4780
--- /dev/null
+++ b/games/opentyrian/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474071784
+SHA256 (opentyrian/2.1.20130907.tar.bz2) = b46b2ad5645f156393a6a79266e40e409a68fd6be2d324960c268e88ee3d1c64
+SIZE (opentyrian/2.1.20130907.tar.bz2) = 249267
diff --git a/games/opentyrian/files/patch-Makefile b/games/opentyrian/files/patch-Makefile
new file mode 100644
index 000000000000..0e02d0dbedf2
--- /dev/null
+++ b/games/opentyrian/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig 2013-09-07 23:56:16 UTC
++++ Makefile
+@@ -8,8 +8,6 @@ endif
+
+ TARGET := opentyrian
+
+-WITH_NETWORK := true
+-
+ ############################################################
+
+ STRIP := strip
+@@ -21,21 +19,11 @@ OBJS := $(SRCS:src/%.c=obj/%.o)
+
+ # FLAGS ####################################################
+
+-ifneq ($(MAKECMDGOALS), release)
+- EXTRA_CFLAGS += -g3 -O0 -Werror
+-else
+- EXTRA_CFLAGS += -g0 -O2 -DNDEBUG
+-endif
+ EXTRA_CFLAGS += -MMD -pedantic -Wall -Wextra -Wno-missing-field-initializers
+ ifeq ($(WITH_NETWORK), true)
+ EXTRA_CFLAGS += -DWITH_NETWORK
+ endif
+
+-HG_REV := $(shell hg id -ib && touch src/hg_revision.h)
+-ifneq ($(HG_REV), )
+- EXTRA_CFLAGS += '-DHG_REV="$(HG_REV)"'
+-endif
+-
+ EXTRA_LDLIBS += -lm
+
+ SDL_CFLAGS := $(shell $(SDL_CONFIG) --cflags)
diff --git a/games/opentyrian/files/pkg-message.in b/games/opentyrian/files/pkg-message.in
new file mode 100644
index 000000000000..bcd2a60d5d5e
--- /dev/null
+++ b/games/opentyrian/files/pkg-message.in
@@ -0,0 +1,6 @@
+In order to play opentyrian, you need to either install games/tyrian-data
+port (not available as package) or install Tyrian data files manually
+into %%DATADIR%%.
+
+See project documentation or website for instructions on how to get
+the data.
diff --git a/games/opentyrian/pkg-descr b/games/opentyrian/pkg-descr
new file mode 100644
index 000000000000..0886065361e2
--- /dev/null
+++ b/games/opentyrian/pkg-descr
@@ -0,0 +1,10 @@
+OpenTyrian is a port of the DOS shoot-em-up Tyrian. Jason Emery
+generously gave the OpenTyrian developers a copy of the Tyrian 2.1
+source code, which has since been ported from Turbo Pascal to C.
+The port uses SDL, making it easily cross-platform.
+
+Tyrian is an arcade-style vertical scrolling shooter. The story is
+set in 20,031 where you play as Trent Hawkins, a skilled fighter-pilot
+employed to fight Microsol and save the galaxy.
+
+WWW: https://bitbucket.org/opentyrian/opentyrian/wiki/Home
diff --git a/games/opentyrian/pkg-plist b/games/opentyrian/pkg-plist
new file mode 100644
index 000000000000..a895391d6c28
--- /dev/null
+++ b/games/opentyrian/pkg-plist
@@ -0,0 +1,5 @@
+bin/opentyrian
+man/man6/opentyrian.6.gz
+share/applications/opentyrian.desktop
+share/pixmaps/opentyrian.png
+%%DATADIR%%/.keepme