aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-03-25 20:36:39 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2013-03-25 20:36:39 +0800
commitf47606ced83711a35a086182ebaa98feb996a27d (patch)
tree3e1926e5421447e6c5acde35fafb26cf5f568fe6 /games
parent704712a903703193c097851da7d32c80589945a3 (diff)
downloadfreebsd-ports-gnome-f47606ced83711a35a086182ebaa98feb996a27d.tar.gz
freebsd-ports-gnome-f47606ced83711a35a086182ebaa98feb996a27d.tar.zst
freebsd-ports-gnome-f47606ced83711a35a086182ebaa98feb996a27d.zip
- Update to version 112.2
- Introduce option to install pak128 game data - Use DESKTOP_ENTRIES - Fix clang build - Update pkg-descr with changes from the new website Approved by: crees
Diffstat (limited to 'games')
-rw-r--r--games/simutrans/Makefile54
-rw-r--r--games/simutrans/distinfo12
-rw-r--r--games/simutrans/files/patch-simtypes.h12
-rw-r--r--games/simutrans/files/simutrans.desktop7
-rw-r--r--games/simutrans/pkg-descr12
5 files changed, 59 insertions, 38 deletions
diff --git a/games/simutrans/Makefile b/games/simutrans/Makefile
index 948bdd9f82bf..5121b5dc515a 100644
--- a/games/simutrans/Makefile
+++ b/games/simutrans/Makefile
@@ -1,25 +1,32 @@
-# Created by: Tijl Coosemans <tijl@ulyssis.org>
# $FreeBSD$
PORTNAME= simutrans
-PORTVERSION= 112.0
+DISTVERSION= 112-2
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${SIMUTRANS_VERSION} \
- SF/${PORTNAME}/pak64/${SIMUTRANS_PAK64}:pak64
-DISTFILES= simutrans-src-${SIMUTRANS_VERSION}.zip \
- simupak64-${SIMUTRANS_PAK64}.zip:pak64
+MASTER_SITES= SF/simutrans/simutrans/${DISTVERSION} \
+ SF/simutrans/pak64/${PAK64_DISTVERSION}:pak64 \
+ SF/simutrans/pak128/pak128%20for%20${PAK128_SUBDIR}:pak128
+DISTFILES= simutrans-src-${DISTVERSION}.zip \
+ simulinux-${DISTVERSION}.zip
MAINTAINER= tijl@coosemans.org
-COMMENT= Transportation simulation game
+COMMENT= Transport Simulator
LICENSE= ART10
LICENSE_FILE= ${WRKSRC}/simutrans/license.txt
-SIMUTRANS_VERSION= ${PORTVERSION:S,.,-,g}
-SIMUTRANS_REVISION= 6000
-SIMUTRANS_PAK64= 112-0
+PAK64_DISTVERSION= ${DISTVERSION}
+PAK128_DISTVERSION= 2.3.0--112.2
+PAK128_SUBDIR= ${DISTVERSION}
+SIMUTRANS_REVISION= 6390
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_MULTI= PAK
+OPTIONS_MULTI_PAK= PAK64 PAK128
+OPTIONS_DEFAULT= PAK64
+PAK64_DESC= Default graphics
+PAK128_DESC= High resolution graphics
-OPTIONS_DEFINE= DOCS
MAKE_ARGS= BACKEND=mixer_sdl \
COLOUR_DEPTH=16 \
OSTYPE=freebsd \
@@ -30,29 +37,38 @@ USE_GMAKE= yes
USE_SDL= sdl mixer
USE_ZIP= yes
-PLIST_DIRSTRY= share/applications
-PLIST_FILES= bin/simutrans \
- bin/simutrans-bin \
- share/applications/simutrans.desktop
+DESKTOP_ENTRIES=Simutrans "" "" simutrans "Game;Simulation;" "false"
+PLIST_FILES= bin/simutrans bin/simutrans-bin
PORTDATA= *
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MPAK64}
+DISTFILES+= simupak64-${PAK64_DISTVERSION}.zip:pak64
+.endif
+
+.if ${PORT_OPTIONS:MPAK128}
+DISTFILES+= pak128-${PAK128_DISTVERSION}.zip:pak128
+.endif
+
post-patch:
@${REINPLACE_CMD} 's/-O[^ ]*//' ${WRKSRC}/Makefile
@${REINPLACE_CMD} 's/simutrans/.simutrans/' ${WRKSRC}/simsys.cc
do-install:
cd ${WRKSRC}/simutrans && ${COPYTREE_SHARE} \
- "config font music pak skin text" ${DATADIR}
+ "config font music script skin text" ${DATADIR}
+.if ${PORT_OPTIONS:MPAK64}
+ cd ${WRKSRC}/simutrans && ${COPYTREE_SHARE} pak ${DATADIR}
+.endif
+.if ${PORT_OPTIONS:MPAK128}
+ cd ${WRKSRC}/simutrans && ${COPYTREE_SHARE} pak128 ${DATADIR}
+.endif
.if ${PORT_OPTIONS:MDOCS}
${INSTALL_DATA} ${WRKSRC}/simutrans/readme.txt ${DATADIR}
.endif
${INSTALL_PROGRAM} ${WRKSRC}/build/default/sim \
${PREFIX}/bin/simutrans-bin
${INSTALL_SCRIPT} ${FILESDIR}/simutrans ${PREFIX}/bin/simutrans
- ${MKDIR} ${PREFIX}/share/applications
- ${INSTALL_SCRIPT} ${FILESDIR}/simutrans.desktop \
- ${PREFIX}/share/applications/simutrans.desktop
.include <bsd.port.mk>
diff --git a/games/simutrans/distinfo b/games/simutrans/distinfo
index e45a23677aa8..7bccc8917409 100644
--- a/games/simutrans/distinfo
+++ b/games/simutrans/distinfo
@@ -1,4 +1,8 @@
-SHA256 (simutrans-src-112-0.zip) = 1f8c067290c7a286ddddbae41ba3cc4997a0e51d1d0dcbe57120a715d904791e
-SIZE (simutrans-src-112-0.zip) = 3425541
-SHA256 (simupak64-112-0.zip) = a58052627e4f4257a8b0abd1622507aa5893ab13ebf38407bf43533b3b228719
-SIZE (simupak64-112-0.zip) = 3742282
+SHA256 (simutrans-src-112-2.zip) = 0064e9183a995e85aae88f45cc3aaf6a644b12edd47ddf9ef477f213614700fe
+SIZE (simutrans-src-112-2.zip) = 1674060
+SHA256 (simulinux-112-2.zip) = 37843bd8dbfb46f26d1fe690661b52231609daeb404dcaaa3a32aac021a45e7b
+SIZE (simulinux-112-2.zip) = 3035463
+SHA256 (simupak64-112-2.zip) = aa9656af42a0f7b00f5026eea8f4253d2dbed266bfbd879c18bb1a2d1cac82f6
+SIZE (simupak64-112-2.zip) = 4020174
+SHA256 (pak128-2.3.0--112.2.zip) = ce3db7421cd717731eb5c30d4c99034b69e3c437cd4b1b60df776ba7aa719149
+SIZE (pak128-2.3.0--112.2.zip) = 87916059
diff --git a/games/simutrans/files/patch-simtypes.h b/games/simutrans/files/patch-simtypes.h
new file mode 100644
index 000000000000..6adabb7d9d5f
--- /dev/null
+++ b/games/simutrans/files/patch-simtypes.h
@@ -0,0 +1,12 @@
+--- simtypes.h.orig
++++ simtypes.h
+@@ -17,6 +17,9 @@
+ # define ALLOCA(type, name, count) type* name = static_cast<type*>(alloca(sizeof(type) * (count)))
+ #
+ # define inline _inline
++#elif defined __clang__
++# include <stdlib.h>
++# define ALLOCA(type, name, count) type* name = static_cast<type*>(alloca(sizeof(type) * (count)))
+ #else
+ # define ALLOCA(type, name, count) type name[count]
+ #endif
diff --git a/games/simutrans/files/simutrans.desktop b/games/simutrans/files/simutrans.desktop
deleted file mode 100644
index f22a58256038..000000000000
--- a/games/simutrans/files/simutrans.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=Simutrans
-GenericName=Transportation Simulation Game
-Exec=simutrans
-Categories=Game;Simulation;
-StartupNotify=false
diff --git a/games/simutrans/pkg-descr b/games/simutrans/pkg-descr
index 0810f8e1b2bd..a3e8b192f971 100644
--- a/games/simutrans/pkg-descr
+++ b/games/simutrans/pkg-descr
@@ -1,10 +1,6 @@
-Your goal is to establish a successful transport company. Transport
-passengers, mail and goods by rail, road, ship and air. Interconnect
-cities, districts, public buildings, industries and tourist attractions
-by buiding a transport network you always dreamed of.
-
-Control and watch your finances and the traffic of your vehicles and
-goods. Start in 1880 and finish in 2050. There will be new vehicles and
-buildings throughout this time.
+Establish a successful transport company. Transport passengers, mail and
+goods by land, air and water. Interconnect cities, districts, public
+buildings, industries and tourist attractions. Control and watch your
+finances and the traffic of your vehicles and goods.
WWW: http://www.simutrans.com/