aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-22 04:55:42 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-22 04:55:42 +0800
commitf842e46d25f87487d1781eb4a5aa392bcc7e2308 (patch)
tree16c1b3ea5785093e6e7d1ae893122ea723961f04 /games
parent8d98df4a372158903d4c6edd5f5329ac34367a08 (diff)
downloadfreebsd-ports-gnome-f842e46d25f87487d1781eb4a5aa392bcc7e2308.tar.gz
freebsd-ports-gnome-f842e46d25f87487d1781eb4a5aa392bcc7e2308.tar.zst
freebsd-ports-gnome-f842e46d25f87487d1781eb4a5aa392bcc7e2308.zip
- Avoid static linking with ode [1]
- Switch to more correct way of avoiding C++11 related build errors - Switch to options helpers PR: 231016 [1] Submitted by: yuri@freebsd.org [1]
Diffstat (limited to 'games')
-rw-r--r--games/stormbaancoureur/Makefile18
-rw-r--r--games/stormbaancoureur/files/patch-src-stormbaancoureur_Makefile (renamed from games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile)11
2 files changed, 15 insertions, 14 deletions
diff --git a/games/stormbaancoureur/Makefile b/games/stormbaancoureur/Makefile
index f7eebc924ac5..28200ea9c83d 100644
--- a/games/stormbaancoureur/Makefile
+++ b/games/stormbaancoureur/Makefile
@@ -3,7 +3,7 @@
PORTNAME= stormbaancoureur
PORTVERSION= 2.1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://www.stolk.org/stormbaancoureur/download/ \
http://mirror.amdmi3.ru/distfiles/
@@ -13,17 +13,15 @@ COMMENT= Simulated obstacle course for automobiles
LICENSE= GPLv3
-BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libode.a:devel/ode
+BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
+LIB_DEPENDS= libode.so:devel/ode
-USES= compiler
+USES= compiler gl pkgconfig
USE_GL= gl glu glut
+USE_CXXSTD= c++98
MAKE_ENV= DATADIR="${DATADIR}"
-CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
-CXXFLAGS_clang= -Wno-c++11-narrowing
-
BUILD_WRKSRC= ${WRKSRC}/src-stormbaancoureur
INSTALL_WRKSRC= ${WRKSRC}/src-stormbaancoureur
@@ -45,8 +43,10 @@ post-patch:
${WRKSRC}/src-stormbaancoureur/main.cxx
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${INSTALL_WRKSRC}/README ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile b/games/stormbaancoureur/files/patch-src-stormbaancoureur_Makefile
index 4e6973eb4b7c..31bd77473b05 100644
--- a/games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile
+++ b/games/stormbaancoureur/files/patch-src-stormbaancoureur_Makefile
@@ -1,6 +1,6 @@
--- src-stormbaancoureur/Makefile.orig 2009-12-01 03:23:51 UTC
+++ src-stormbaancoureur/Makefile
-@@ -5,23 +5,20 @@ VERSION=2.1.6-generic
+@@ -5,23 +5,21 @@ VERSION=2.1.6-generic
GLPREFIX=/usr
PLIBPREFIX=/usr
ODEPREFIX=/usr
@@ -15,9 +15,10 @@
- -I$(ODEPREFIX)/include \
- -I$(PLIBPREFIX)/include \
+CXXFLAGS+=\
-+ -I$(LOCALBASE)/include \
-I../src-common \
-I. \
++ -I$(LOCALBASE)/include \
++ `pkg-config --cflags ode` \
-DGAMEVERSION=$(VERSION) \
- -O2 -g -Wall
+ -g -Wall
@@ -29,12 +30,12 @@
OBJS=\
-@@ -39,15 +36,15 @@ OBJS=\
+@@ -39,15 +37,15 @@ OBJS=\
LIBS=\
- $(ODEPREFIX)/$(LIBDIRNAME)/libode.a \
-+ $(LOCALBASE)/lib/libode.a \
++ `pkg-config --libs ode` \
-lplibssgaux -lplibssg -lplibsg -lplibpu -lplibfnt -lplibul \
- -lglut -lGLU -lGL -lasound
+ -lglut -lGLU -lGL $(ALSA_LIBS)
@@ -48,7 +49,7 @@
$(CXX) -o stormbaancoureur $(OBJS) $(LFLAGS) $(LIBS)
staticworldobject.o: ../src-common/staticworldobject.cxx ../src-common/staticworldobject.h ../src-common/worldobject.h
-@@ -92,16 +89,15 @@ run: stormbaancoureur
+@@ -92,16 +90,15 @@ run: stormbaancoureur
clean:
rm -f *.o stormbaancoureur