aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-21 21:21:04 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-21 21:21:04 +0800
commitfc39409b96e1c49f3424377c42c88367ea1ad016 (patch)
tree8ca265fd86a85ec42e228ea09e9ba5fcee43954d /games
parent239d7fd8c18157a4b20108103d1ebf5d843a2163 (diff)
downloadfreebsd-ports-gnome-fc39409b96e1c49f3424377c42c88367ea1ad016.tar.gz
freebsd-ports-gnome-fc39409b96e1c49f3424377c42c88367ea1ad016.tar.zst
freebsd-ports-gnome-fc39409b96e1c49f3424377c42c88367ea1ad016.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Diffstat (limited to 'games')
-rw-r--r--games/cheech/Makefile4
-rw-r--r--games/ember/Makefile4
-rw-r--r--games/freedoko/Makefile4
-rw-r--r--games/stonesoup/Makefile5
4 files changed, 9 insertions, 8 deletions
diff --git a/games/cheech/Makefile b/games/cheech/Makefile
index 2465face3726..506db1996711 100644
--- a/games/cheech/Makefile
+++ b/games/cheech/Makefile
@@ -13,10 +13,10 @@ COMMENT= Multiplayer Chinese Checkers game
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build
-
LIB_DEPENDS= libgnet-2.0.so:net/gnet2
+BROKEN= fails to compile: ustring.h: expected ';' at end of declaration list
+
OPTIONS_DEFINE= DOCS
USES= gmake pkgconfig tar:tgz
diff --git a/games/ember/Makefile b/games/ember/Makefile
index d775eb774863..04f55d5a2e84 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -15,8 +15,6 @@ COMMENT= Ember is a WorldForge 3D client using the OGRE 3D library
LICENSE= GPLv3
-BROKEN= fails to build
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:graphics/ogre3d
RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:graphics/ogre3d
LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
@@ -27,6 +25,8 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libboost_thread.so:devel/boost-libs \
libCEGUIBase-0.so:graphics/cegui
+BROKEN= fails to compile: ServerService.h: 'sigc++/object_slot.h' file not found
+
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --disable-debug \
--with-boost=${LOCALBASE} --with-toluaxx=${TOLUAXX_CMD}
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 88bf1db7d8fd..3a209258906f 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -14,10 +14,10 @@ COMMENT= Play the card game Doppelkopf
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../doc/GPL
-BROKEN= fails to build
-
LIB_DEPENDS= libgnet-2.0.so:net/gnet2
+BROKEN= fails to compile: refptr.h: expected ';' at end of declaration list
+
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
USES= gmake pkgconfig zip:infozip
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index addfd7ca01e8..391db01f7b4c 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -15,8 +15,9 @@ COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../licence.txt
-BROKEN_armv6= Does not build: error: Missing platform #define or unsupported compiler
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= fails to compile: tool/tile.h: 'nullptr' was not declared in this scope
+NOT_FOR_ARCHS= armv6
+NOT_FOR_ARCHS_REASON= missing platform \#define or unsupported compiler
USES= bison compiler:c++11-lib gmake lua:51 perl5 pkgconfig \
shebangfix sqlite tar:xz