aboutsummaryrefslogtreecommitdiffstats
path: root/german/hunspell
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-11-04 18:49:03 +0800
committerbapt <bapt@FreeBSD.org>2013-11-04 18:49:03 +0800
commit4753c7c222c818ccd9255f9102dcb9fe9356f5e4 (patch)
treeaa0437cd1df1ab46c9dae998c380d8e8ba1d5f37 /german/hunspell
parent0d0b67f2c78045cae99e48bc2d1be1aa1e8d3693 (diff)
downloadfreebsd-ports-gnome-4753c7c222c818ccd9255f9102dcb9fe9356f5e4.tar.gz
freebsd-ports-gnome-4753c7c222c818ccd9255f9102dcb9fe9356f5e4.tar.zst
freebsd-ports-gnome-4753c7c222c818ccd9255f9102dcb9fe9356f5e4.zip
Support stage, use bsdtar to extract
Diffstat (limited to 'german/hunspell')
-rw-r--r--german/hunspell/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/german/hunspell/Makefile b/german/hunspell/Makefile
index 13ec25fadfc6..d85a3384c6fc 100644
--- a/german/hunspell/Makefile
+++ b/german/hunspell/Makefile
@@ -13,10 +13,9 @@ COMMENT= German hunspell dictionaries
BUILD_DEPENDS= buildhash:${PORTSDIR}/textproc/ispell \
hunspell:${PORTSDIR}/textproc/hunspell
-USES= shebangfix perl5
+USES= gmake shebangfix perl5
USE_BZIP2= yes
ALL_TARGET= hunspell-all
-USE_GMAKE= yes
USE_PERL5= build
SHEBANG_FILES= bin/*.pl
@@ -35,19 +34,18 @@ PLIST_FILES+= %%DATADIR%%/${ALIAS}.aff \
%%DATADIR%%/${ALIAS}.dic
.endfor
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/hunspell/de_AT.aff ${WRKSRC}/hunspell/de_AT.dic \
${WRKSRC}/hunspell/de_CH.aff ${WRKSRC}/hunspell/de_CH.dic \
- ${WRKSRC}/hunspell/de_DE.aff ${WRKSRC}/hunspell/de_DE.dic ${DATADIR}/
+ ${WRKSRC}/hunspell/de_DE.aff ${WRKSRC}/hunspell/de_DE.dic ${STAGEDIR}${DATADIR}/
.for ALIAS in ${CHALIASES}
- ${LN} -s de_CH.aff ${DATADIR}/${ALIAS}.aff
- ${LN} -s de_CH.dic ${DATADIR}/${ALIAS}.dic
+ ${LN} -s de_CH.aff ${STAGEDIR}${DATADIR}/${ALIAS}.aff
+ ${LN} -s de_CH.dic ${STAGEDIR}${DATADIR}/${ALIAS}.dic
.endfor
.for ALIAS in ${DEALIASES}
- ${LN} -s de_DE.aff ${DATADIR}/${ALIAS}.aff
- ${LN} -s de_DE.dic ${DATADIR}/${ALIAS}.dic
+ ${LN} -s de_DE.aff ${STAGEDIR}${DATADIR}/${ALIAS}.aff
+ ${LN} -s de_DE.dic ${STAGEDIR}${DATADIR}/${ALIAS}.dic
.endfor
.include <bsd.port.mk>