aboutsummaryrefslogtreecommitdiffstats
path: root/german/unix-connect
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-10-29 05:37:02 +0800
committerdinoex <dinoex@FreeBSD.org>2014-10-29 05:37:02 +0800
commitec2fd8a7b79b64900e69f83ca4149683fb82063e (patch)
tree16e32a8da5a57f9d38bc106db2b086703309751c /german/unix-connect
parent933b9a52dd8bc60577b4e808789951ff99b5d4ef (diff)
downloadfreebsd-ports-gnome-ec2fd8a7b79b64900e69f83ca4149683fb82063e.tar.gz
freebsd-ports-gnome-ec2fd8a7b79b64900e69f83ca4149683fb82063e.tar.zst
freebsd-ports-gnome-ec2fd8a7b79b64900e69f83ca4149683fb82063e.zip
- support INSTALL_AS_USER
- fix stagedir check - restore ownership
Diffstat (limited to 'german/unix-connect')
-rw-r--r--german/unix-connect/Makefile5
-rw-r--r--german/unix-connect/files/patch-Makefile.in8
-rw-r--r--german/unix-connect/pkg-plist7
3 files changed, 16 insertions, 4 deletions
diff --git a/german/unix-connect/Makefile b/german/unix-connect/Makefile
index 8c8c501da5c1..ad82e50501cb 100644
--- a/german/unix-connect/Makefile
+++ b/german/unix-connect/Makefile
@@ -20,8 +20,13 @@ NEED_ROOT= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
+.if !defined(INSTALL_AS_USER)
CONFIGURE_ARGS+=--with-user=news
CONFIGURE_ARGS+=--with-group=dialer
+.else
+CONFIGURE_ARGS+=--with-user=`id -u -n`
+CONFIGURE_ARGS+=--with-group=`id -g -n`
+.endif
CONFIGURE_ARGS+=--with-execdir=${PREFIX}/libexec/uconnect
CONFIGURE_ARGS+=--with-confdir=${PREFIX}/etc/uconnect
CONFIGURE_ARGS+=--with-spooldir=/var/spool/uconnect
diff --git a/german/unix-connect/files/patch-Makefile.in b/german/unix-connect/files/patch-Makefile.in
index ab1de7f19b74..557e779114c7 100644
--- a/german/unix-connect/files/patch-Makefile.in
+++ b/german/unix-connect/files/patch-Makefile.in
@@ -1,10 +1,12 @@
--- Makefile.in.orig 2001-10-01 20:27:36.000000000 +0200
-+++ Makefile.in 2013-11-29 05:39:06.000000000 +0100
-@@ -56,11 +56,11 @@
++++ Makefile.in 2014-10-28 22:21:15.000000000 +0100
+@@ -55,12 +55,12 @@
+
install:
for dir in $(TARGETDIRS); do \
- if test ! -d $$dir; then \
+- if test ! -d $$dir; then \
- mkdir $$dir; chown $(USER):$(GROUP) $$dir; fi \
++ if test ! -d $(DESTDIR)$$dir; then \
+ mkdir $(DESTDIR)$$dir; chown $(USER):$(GROUP) $(DESTDIR)$$dir; fi \
done
if test ! -d $(SPOOLDIR)/netcall; then \
diff --git a/german/unix-connect/pkg-plist b/german/unix-connect/pkg-plist
index 5fed10ad1955..947b04a75d60 100644
--- a/german/unix-connect/pkg-plist
+++ b/german/unix-connect/pkg-plist
@@ -35,15 +35,20 @@ etc/uconnect/myself.zconnect
etc/uconnect/systems.sample
etc/uconnect/xprogs
etc/uconnect/zconnecthosts
+@owner news
+@group dialer
+@dir etc/uconnect
@dir etc/uconnect/systems
@dir /var/spool/uconnect/backin
@dir /var/spool/uconnect/backout
@dir /var/spool/uconnect/error
@dir /var/spool/uconnect/locks
@dir /var/spool/uconnect/logfiles
-@dir /var/spool/uconnect/netcall
@dir /var/spool/uconnect/rsmtp
@dir /var/spool/uconnect
+@group
+@dir /var/spool/uconnect/netcall
+@owner
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.configure
%%PORTDOCS%%%%DOCSDIR%%/INSTALL