aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/EZWGL
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/EZWGL
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadfreebsd-ports-gnome-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
freebsd-ports-gnome-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.zst
freebsd-ports-gnome-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/EZWGL')
-rw-r--r--graphics/EZWGL/Makefile6
-rw-r--r--graphics/EZWGL/files/patch-EZ_Png.c19
2 files changed, 22 insertions, 3 deletions
diff --git a/graphics/EZWGL/Makefile b/graphics/EZWGL/Makefile
index 09251677ef90..629e120facdf 100644
--- a/graphics/EZWGL/Makefile
+++ b/graphics/EZWGL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= EZWGL
PORTVERSION= 1.50
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics devel
MASTER_SITES= ftp://ftp.ma.utexas.edu/pub/mzou/
DISTFILES= ${DISTNAME}-demo.tgz ${DISTNAME}-doc.tgz ${DISTNAME}-src.tgz
@@ -16,13 +16,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The EZ Widget and Graphics Library
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_XORG= x11 xext
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
.include <bsd.port.pre.mk>
diff --git a/graphics/EZWGL/files/patch-EZ_Png.c b/graphics/EZWGL/files/patch-EZ_Png.c
new file mode 100644
index 000000000000..2cbe00f9e1ab
--- /dev/null
+++ b/graphics/EZWGL/files/patch-EZ_Png.c
@@ -0,0 +1,19 @@
+--- lib/EZ_Png.c.orig 1999-12-03 22:49:22.000000000 +0100
++++ lib/EZ_Png.c 2012-04-27 07:56:25.000000000 +0200
+@@ -37,6 +37,7 @@
+ #if defined(HAVE_LIBPNG) && defined(PNG_SUPPORT)
+ #undef EXTERN
+ #include <png.h>
++#include <pngpriv.h>
+
+ static int EZ_ReadPng(fname, w_ret, h_ret, p_ret, rgb_return)
+ char *fname;
+@@ -61,7 +62,7 @@
+ fclose(fp);
+ return(0);
+ }
+- if(setjmp(png_ptr->jmpbuf))
++ if(setjmp(png_jmpbuf(png_ptr)))
+ {
+ fclose(fp);
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);