aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/GIFgraph/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>1998-12-12 23:09:17 +0800
committerkuriyama <kuriyama@FreeBSD.org>1998-12-12 23:09:17 +0800
commit4c1deea2827c09782fc9f658c013074e7bf1a06a (patch)
tree5c790b42e265028d84204e08032b634b3867728b /graphics/GIFgraph/Makefile
parent8e6a2b5405340d9a2e21767479f0beec67d848a6 (diff)
downloadfreebsd-ports-gnome-4c1deea2827c09782fc9f658c013074e7bf1a06a.tar.gz
freebsd-ports-gnome-4c1deea2827c09782fc9f658c013074e7bf1a06a.tar.zst
freebsd-ports-gnome-4c1deea2827c09782fc9f658c013074e7bf1a06a.zip
a Perl package to generate GIF charts
PR: ports/8627 Submitted by: laskavy@gambit.msk.su Modified by: kuriyama o added p5-GD dependency o some portlint fixes This port fails on make test stage in ${WRKDIR}. But this is caused by font difference between developper's and mine. So it can ignore.
Diffstat (limited to 'graphics/GIFgraph/Makefile')
-rw-r--r--graphics/GIFgraph/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/GIFgraph/Makefile b/graphics/GIFgraph/Makefile
new file mode 100644
index 000000000000..78a0f82ac383
--- /dev/null
+++ b/graphics/GIFgraph/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-GIFgraph
+# Version required: 1.01
+# Date created: Nov 9, 1998
+# Whom: laskavy@gambit.msk.su
+#
+# $Id$
+#
+
+DISTNAME= GIFgraph-1.01
+PKGNAME= p5-GIFgraph-1.01
+CATEGORIES= graphics perl5
+MASTER_SITES= http://www.tcp.chem.tue.nl/~tgtcmv/perl/
+
+MAINTAINER= laskavy@gambit.msk.su
+
+RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= GIFgraph.3 GIFgraph::colour.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>