aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/GraphicsMagick12
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-09-26 04:38:03 +0800
committerGreg Larkin <glarkin@FreeBSD.org>2012-09-26 04:38:03 +0800
commita8119b55755271866c3410170b5dea905b3f87ad (patch)
treeb0690a1bb83ea843fcaa2bc301af63c82ced2315 /graphics/GraphicsMagick12
parent80b4ac77d5f4ec941916c4425e345c8ae03fc97a (diff)
downloadfreebsd-ports-gnome-a8119b55755271866c3410170b5dea905b3f87ad.tar.gz
freebsd-ports-gnome-a8119b55755271866c3410170b5dea905b3f87ad.tar.zst
freebsd-ports-gnome-a8119b55755271866c3410170b5dea905b3f87ad.zip
- Fixed X11-conditional dependency injection
- Converted to optionsNG - Bumped PORTREVISION Requested by: Mark Felder <feld@feld.me>
Diffstat (limited to 'graphics/GraphicsMagick12')
-rw-r--r--graphics/GraphicsMagick12/Makefile44
1 files changed, 25 insertions, 19 deletions
diff --git a/graphics/GraphicsMagick12/Makefile b/graphics/GraphicsMagick12/Makefile
index fae3f1e3ccc4..0c956c71c3c4 100644
--- a/graphics/GraphicsMagick12/Makefile
+++ b/graphics/GraphicsMagick12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.2.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.2/
@@ -21,17 +21,20 @@ CONFLICTS= GraphicsMagick-1.[13].*
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
png15:${PORTSDIR}/graphics/png \
jbig:${PORTSDIR}/graphics/jbigkit \
- wmflite:${PORTSDIR}/graphics/libwmf \
xml2:${PORTSDIR}/textproc/libxml2
OTHERGRAPHICS= jasper jpeg lcms tiff
LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
-OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off \
- FPX "Enable FlashPIX support" on \
- DPS "Enable Display Ghostscript support" on \
- OPENMP "Enable OpenMP support" off \
- SSE "Enable SSE opcodes on supported CPUs" off \
- X11 "Enable X11 support" on \
- TESTS "Run bundled self-tests after build" on
+
+OPTIONS_DEFINE= Q8BIT FPX OPENMP SSE TESTS X11 DOCS
+
+Q8BIT_DESC= Use 8-bit pixels (speed) instead of 16 (quality)
+DPS_DESC= Enable Display Ghostscript support
+NODPS_DESC= Disable Display Ghostscript support
+TESTS_DESC= Run bundled self-tests after build
+
+OPTIONS_DEFAULT=FPX DPS OPENMP X11 TESTS DOCS
+OPTIONS_SINGLE= X11
+OPTIONS_SINGLE_X11= DPS NODPS
USE_ICONV= yes
USE_AUTOTOOLS= libtool libltdl
@@ -61,15 +64,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
test check:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS} == ""
# Get rid of the Makefile targets that install the documentation
# and HTML files into DOCSDIR
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
.endif
-.if defined(WITH_SSE)
+.if ${PORT_OPTIONS:MSSE}
.if ${MACHINE_CPU:Msse}
CFLAGS+= -msse
.endif
@@ -81,21 +84,21 @@ CFLAGS+= -msse3
.endif
.endif
-.if defined(WITH_FPX)
+.if ${PORT_OPTIONS:MFPX}
LIB_DEPENDS+= fpx.[2-9]:${PORTSDIR}/graphics/libfpx
CONFIGURE_ARGS+= --with-fpx
.else
CONFIGURE_ARGS+= --without-fpx
.endif
-.if defined(WITH_DPS)
+.if ${PORT_OPTIONS:MDPS}
LIB_DEPENDS+= dps:${PORTSDIR}/x11/dgs
CONFIGURE_ARGS+= --with-dps
.else
CONFIGURE_ARGS+= --without-dps
.endif
-.if defined(WITH_OPENMP)
+.if ${PORT_OPTIONS:MOPENMP}
.if ${OSVERSION} < 700042
IGNORE= does not support OpenMP on FreeBSD version ${OSVERSION}
.endif
@@ -115,12 +118,15 @@ WINDOWS_FONT_DIR=${LOCALBASE}/lib/X11/fonts/webfonts
CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
.endif
-.if !defined(WITH_X11)
+.if ${PORT_OPTIONS:MX11} == ""
PKGNAMESUFFIX+= -nox11
CONFIGURE_ARGS+=--without-x
+LIB_DEPENDS+= wmflite:${PORTSDIR}/graphics/libwmf-nox11
+.else
+LIB_DEPENDS+= wmflite:${PORTSDIR}/graphics/libwmf
.endif
-.if defined(WITH_Q8BIT) || defined(WITHOUT_GRAPHICSMAGICK_16BIT_PIXEL)
+.if ${PORT_OPTIONS:MQ8BIT}
CONFIGURE_ARGS+= --with-quantum-depth=8
PLIST_SUB+= Q=8
.else
@@ -128,7 +134,7 @@ CONFIGURE_ARGS+= --with-quantum-depth=16
PLIST_SUB+= Q=16
.endif
-.if !defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
post-build:: test
.else
post-build::
@@ -138,4 +144,4 @@ post-build::
#
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>