aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ale/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-01-27 11:25:51 +0800
committerijliao <ijliao@FreeBSD.org>2004-01-27 11:25:51 +0800
commit965d6ef42190078381f0b84504960f4759f01f8a (patch)
tree511ef3bf0eff00fed2fbfbb337337cbfe7805058 /graphics/ale/Makefile
parent4ec4824358c8dd81bccb16f63f2263f5188321b7 (diff)
downloadfreebsd-ports-gnome-965d6ef42190078381f0b84504960f4759f01f8a.tar.gz
freebsd-ports-gnome-965d6ef42190078381f0b84504960f4759f01f8a.tar.zst
freebsd-ports-gnome-965d6ef42190078381f0b84504960f4759f01f8a.zip
fix build on -stable
Noted by: bento via kris
Diffstat (limited to 'graphics/ale/Makefile')
-rw-r--r--graphics/ale/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
index 1f7b826abd7f..2e8104ae5093 100644
--- a/graphics/ale/Makefile
+++ b/graphics/ale/Makefile
@@ -17,7 +17,6 @@ PATCH_DIST_ARGS= -p1 -d ${PATCH_WRKSRC}
MAINTAINER= ports@FreeBSD.org
COMMENT= Anti-Lamenessing Engine
-USE_GCC= 3.1
USE_GMAKE= yes
.if !defined(WITHOUT_IMAGEMAGICK)
@@ -25,7 +24,17 @@ LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
MAKE_ARGS= IMAGEMAGICK=1
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+USE_REINPLACE= yes
+USE_GCC= 3.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^ g++| ${CXX}|" ${WRKSRC}/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ale ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>