aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ampasCTL/Makefile
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-09-25 05:28:32 +0800
committernemysis <nemysis@FreeBSD.org>2013-09-25 05:28:32 +0800
commit4ef414956036f6de3651095f300c5ed7d91482c7 (patch)
tree43ab9590026e4961d6953fccc2399f213ca7e7dd /graphics/ampasCTL/Makefile
parent2dec251e994a68c87ec543bdc25111c7d412a597 (diff)
downloadfreebsd-ports-gnome-4ef414956036f6de3651095f300c5ed7d91482c7.tar.gz
freebsd-ports-gnome-4ef414956036f6de3651095f300c5ed7d91482c7.tar.zst
freebsd-ports-gnome-4ef414956036f6de3651095f300c5ed7d91482c7.zip
- Bump portrevision
- Change master sites SF --> GH, recreate tarball - Change maintainer email gmx.ch --> FreeBSD.org - Use the new format for LIB_DEPENDS - USES pathfix pkgconfig - Add dependency for aclocal - Add DOCS Option, change and remove from pkg-plist - Use pathfix and REINPLACE_CMD instead of simple patches - Change WWW Approved by: wg/pawel (mentors)
Diffstat (limited to 'graphics/ampasCTL/Makefile')
-rw-r--r--graphics/ampasCTL/Makefile47
1 files changed, 37 insertions, 10 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index bb854506e3e0..46c445efc467 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -3,29 +3,54 @@
PORTNAME= ampasCTL
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= graphics devel
-MASTER_SITES= SF/${PORTNAME:L}/ctl/ctl-${PORTVERSION}/
DISTNAME= ctl-${DISTVERSION}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Color Transformation Language interpreter
LICENSE= BSD
-LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase
+LIB_DEPENDS= libImath.so:${PORTSDIR}/graphics/ilmbase
-USES= pkgconfig
-USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/ampas-CTL-${GH_COMMIT}/CTL
+
+USE_GITHUB= yes
+GH_ACCOUNT= ampas
+GH_PROJECT= CTL
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= ca179ca
+
+USES= pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
+USE_AUTOTOOLS= aclocal libtool
+USE_LDCONFIG= yes
+
+PORTDOCS= *
-PORTDOCS= AUTHORS ChangeLog NEWS README
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog NEWS README
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= CtlManual.pdf CtlManual.doc
+
+OPTIONS_DEFINE= DOCS
NO_STAGE= yes
.include <bsd.port.options.mk>
+pre-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./bootstrap)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CtlManual.pdf CtlManual.doc||' \
+ ${WRKSRC}/doc/Makefile.am
+
test check: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+ @(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.if defined(PACKAGE_BUILDING)
pre-install: test
@@ -33,8 +58,10 @@ pre-install: test
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
.endif
.include <bsd.port.mk>