aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
commitf5eba1acd02cb57a7650fe6c33b912240f6ab8ab (patch)
tree785d921da1883d2c1df77c5add82a844e2ae090b /graphics/autotrace
parenteb2a7f0a6ba691b8505dc2684f14abff26a76009 (diff)
downloadfreebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.gz
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.zst
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.zip
Conver to new options framework
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index ac3ecc3a0c72..a64b68878eab 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -25,17 +25,19 @@ CPPFLAGS+= -I${LOCALBASE}/include/libpng15
MAN1= autotrace.1
-OPTIONS= MING "Enable swf interface" off \
- PSTOEDIT "Convert postscript to other formats" on
+OPTIONS_DEFINE= MING PSTOEDIT
+OPTIONS_DEFAULT= PSTOEDIT
+MING_DESC= Enable swf interface
+PSTOEDIT_DESC= Convert postscript to other formats
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined (WITHOUT_MING)
+.if ${PORT_OPTIONS:MSETUIDMING}
LIB_DEPENDS+= ming.5:${PORTSDIR}/graphics/ming
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ming
.endif
-.if !defined (WITHOUT_PSTOEDIT)
+.if ${PORT_OPTIONS:MPSTOEDIT}
LIB_DEPENDS+= pstoedit.0:${PORTSDIR}/graphics/pstoedit
.endif
@@ -44,10 +46,10 @@ post-patch:
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
-.if defined (WITH_PSTOEDIT)
+.if ${PORT_OPTIONS:MPSTOEDIT}
@${REINPLACE_CMD} -e '/$$PSTOEDIT_CONFIG/ s|--version|--modversion| ; \
s|$$PSTOEDIT_CONFIG $$pstoedit_args|pkg-config pstoedit| ; \
/^PSTOEDIT_CONFIG=/ s|=.*$$|=pkg-config| ' ${WRKSRC}/configure
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>