aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/bmeps
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-03-03 21:28:05 +0800
committerscheidell <scheidell@FreeBSD.org>2012-03-03 21:28:05 +0800
commita4a143c7a563ff3f0ecb0f34b60dad59a53e981e (patch)
treec58185f6dd51376d95056473b05745bf76e4ac2f /graphics/bmeps
parentf397bcf76f012f724ff288368fc2a957f7769a43 (diff)
downloadfreebsd-ports-gnome-a4a143c7a563ff3f0ecb0f34b60dad59a53e981e.tar.gz
freebsd-ports-gnome-a4a143c7a563ff3f0ecb0f34b60dad59a53e981e.tar.zst
freebsd-ports-gnome-a4a143c7a563ff3f0ecb0f34b60dad59a53e981e.zip
- Unbreak with net-snmp
- Bump PORTREVISION PR: ports/164029 Submitted by: Jan Henrik Sylvester <me@janh.de> Reviewed by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer) Approved by: gabor (mentor, implicit)
Diffstat (limited to 'graphics/bmeps')
-rw-r--r--graphics/bmeps/Makefile1
-rw-r--r--graphics/bmeps/files/patch-configure108
2 files changed, 109 insertions, 0 deletions
diff --git a/graphics/bmeps/Makefile b/graphics/bmeps/Makefile
index 52e03de66a86..cc1c3c518ace 100644
--- a/graphics/bmeps/Makefile
+++ b/graphics/bmeps/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bmeps
PORTVERSION= 2.2.22
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= SF/dktools/dktools/dktools-${PORTVERSION}
DISTNAME= dktools-${PORTVERSION}
diff --git a/graphics/bmeps/files/patch-configure b/graphics/bmeps/files/patch-configure
new file mode 100644
index 000000000000..0ecd8a63598c
--- /dev/null
+++ b/graphics/bmeps/files/patch-configure
@@ -0,0 +1,108 @@
+Index: files/patch-configure
+===================================================================
+RCS file: files/patch-configure
+diff -N files/patch-configure
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ files/patch-configure 14 Jan 2012 02:38:52 -0000
+@@ -0,0 +1,101 @@
++--- ./configure.orig 2011-11-02 10:37:26.000000000 -0700
+++++ ./configure 2012-01-13 18:35:08.000000000 -0800
++@@ -4234,19 +4234,6 @@
++
++
++ GDBMLIB=""
++-ac_fn_c_check_header_mongrel "$LINENO" "gdbm.h" "ac_cv_header_gdbm_h" "$ac_includes_default"
++-if test "x$ac_cv_header_gdbm_h" = x""yes; then :
++- $as_echo "#define HAVE_GDBM_H 1" >>confdefs.h
++-
++-else
++- ac_fn_c_check_header_mongrel "$LINENO" "ndbm.h" "ac_cv_header_ndbm_h" "$ac_includes_default"
++-if test "x$ac_cv_header_ndbm_h" = x""yes; then :
++- ANYDB='ndbm';$as_echo "#define HAVE_NDBM_H 1" >>confdefs.h
++-
++-fi
++-
++-
++-fi
++
++
++
++@@ -6710,74 +6697,16 @@
++ NETSNMP_LIBS=""
++ FSNMP=""
++ SNMPYALC=""
++-NETSNMP_CFLAGS=`net-snmp-config --cflags`
++-NETSNMP_LIBS=`net-snmp-config --libs`
+++NETSNMP_CFLAGS=""
+++NETSNMP_LIBS=""
++ UNAME=''
++ UNAME=`uname -s`
++-if test "X$UNAME" = "XSunOS"
++-then
++- { $as_echo "$as_me:${as_lineno-$LINENO}: checking SunOS Net-SNMP flags" >&5
++-$as_echo_n "checking SunOS Net-SNMP flags... " >&6; }
++- NETSNMP_LIBS=`echo $NETSNMP_LIBS | sed -f modsnmp.sed`
++- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++-$as_echo "yes" >&6; }
++-fi
++-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++-/* end confdefs.h. */
++-
++-#include <net-snmp/net-snmp-config.h>
++-#include <net-snmp/net-snmp-includes.h>
++-#include <net-snmp/utilities.h>
++-
++-int
++-main ()
++-{
++
++-netsnmp_session session, *ss;
++
++- ;
++- return 0;
++-}
++-_ACEOF
++-if ac_fn_c_try_compile "$LINENO"; then :
++- FSNMP='fsnmp';SNMPYALC='snmpyalc klpinfo';$as_echo "#define HAVE_LIBNETSNMP 1" >>confdefs.h
++-
++-fi
++-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for netsnmp_enable_filelog in -lnetsnmp" >&5
++-$as_echo_n "checking for netsnmp_enable_filelog in -lnetsnmp... " >&6; }
++-if test "${ac_cv_lib_netsnmp_netsnmp_enable_filelog+set}" = set; then :
++- $as_echo_n "(cached) " >&6
++-else
++- ac_check_lib_save_LIBS=$LIBS
++-LIBS="-lnetsnmp $LIBS"
++-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++-/* end confdefs.h. */
+++ac_cv_lib_netsnmp_netsnmp_enable_filelog=no
++
++-/* Override any GCC internal prototype to avoid an error.
++- Use char because int might match the return type of a GCC
++- builtin and then its argument prototype would still apply. */
++-#ifdef __cplusplus
++-extern "C"
++-#endif
++-char netsnmp_enable_filelog ();
++-int
++-main ()
++-{
++-return netsnmp_enable_filelog ();
++- ;
++- return 0;
++-}
++-_ACEOF
++-if ac_fn_c_try_link "$LINENO"; then :
++- ac_cv_lib_netsnmp_netsnmp_enable_filelog=yes
++-else
++- ac_cv_lib_netsnmp_netsnmp_enable_filelog=no
++-fi
++-rm -f core conftest.err conftest.$ac_objext \
++- conftest$ac_exeext conftest.$ac_ext
++ LIBS=$ac_check_lib_save_LIBS
++-fi
+++
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_netsnmp_netsnmp_enable_filelog" >&5
++ $as_echo "$ac_cv_lib_netsnmp_netsnmp_enable_filelog" >&6; }
++ if test "x$ac_cv_lib_netsnmp_netsnmp_enable_filelog" = x""yes; then :