aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-10-20 00:02:22 +0800
committermezz <mezz@FreeBSD.org>2008-10-20 00:02:22 +0800
commit5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a (patch)
treea1c563e25b06037a5d8d71438415c092d1a56315 /graphics/cairo/Makefile
parentd3b569566cf678e9020a12465a5f1b7c3914df9b (diff)
downloadfreebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.tar.gz
freebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.tar.zst
freebsd-ports-gnome-5eaba666dda7bbd0a30f8c89aa0ff1d7a9ee488a.zip
Add XCB support with optional. Enable it by default, since future version of
x11-wm/awesome needs it. Bump the PORTREVISION. PR: ports/126993 Submitted by: bf <bf2006a@yahoo.com> Requested by: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 7a9eeb3730ad..ce601fe7a4b9 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cairo
PORTVERSION= 1.6.4
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH?= 1
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -42,7 +42,8 @@ USE_XORG+= xrender
PLIST_SUB+= X11=""
.endif
-OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
+OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off \
+ XCB "Enable XCB (X C-language Binding) Support" On
.include <bsd.port.pre.mk>
@@ -55,6 +56,16 @@ CONFIGURE_ARGS+= --disable-glitz
PLIST_SUB+= GLITZ="@comment "
.endif
+.ifdef(WITH_XCB)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:${PORTSDIR}/x11/xcb-util
+CONFIGURE_ARGS+= --enable-xcb
+PLIST_SUB+= XCB=""
+.else
+CONFIGURE_ARGS+= --disable-xcb
+PLIST_SUB+= XCB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/test/Makefile.in