aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cal3d
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-10-05 21:45:58 +0800
committertijl <tijl@FreeBSD.org>2014-10-05 21:45:58 +0800
commitf3d25b849a0b634d17f060019516fb088e7e7894 (patch)
treea6481bf825763e082169c4f29a3e0467a20a413d /graphics/cal3d
parent737c49f3250e375a1cec537707ea574778afd4f3 (diff)
downloadfreebsd-ports-gnome-f3d25b849a0b634d17f060019516fb088e7e7894.tar.gz
freebsd-ports-gnome-f3d25b849a0b634d17f060019516fb088e7e7894.tar.zst
freebsd-ports-gnome-f3d25b849a0b634d17f060019516fb088e7e7894.zip
Remove patches and patch Makefile.in instead of Makefile.am to avoid
USE_AUTOTOOLS
Diffstat (limited to 'graphics/cal3d')
-rw-r--r--graphics/cal3d/Makefile16
-rw-r--r--graphics/cal3d/files/patch-aclocal.m412
-rw-r--r--graphics/cal3d/files/patch-configure.in7
3 files changed, 2 insertions, 33 deletions
diff --git a/graphics/cal3d/Makefile b/graphics/cal3d/Makefile
index 3f710016b7c1..12436ea0667e 100644
--- a/graphics/cal3d/Makefile
+++ b/graphics/cal3d/Makefile
@@ -13,27 +13,15 @@ COMMENT= Skeletal based 3D character animation library written in C++
CONFLICTS= cal3d-devel-[0-9]*
-USES= pkgconfig libtool
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake autoheader
-AUTOMAKE_ARGS= --add-missing
+USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
-AUTOTOOLSFILES= aclocal.m4
-# AUTOMAKE_ARGS= --add-missing
post-patch:
- @${REINPLACE_CMD} \
- -e 's|^\(pkgconfigdir\ =\).*|\1 $$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e 's|<istream>|<iostream>|' \
${WRKSRC}/src/cal3d/buffersource.h \
${WRKSRC}/src/cal3d/loader.h \
${WRKSRC}/src/cal3d/streamsource.h
- @${REINPLACE_CMD} -e '/^all_libraries/d' ${WRKSRC}/src/cal3d/Makefile.am
- @${REINPLACE_CMD} -e 's| tests||' ${WRKSRC}/Makefile.am
-
-post-configure:
- @${FIND} ${WRKSRC} -name Makefile -print | \
- ${XARGS} ${REINPLACE_CMD} -e 's|MKDIR_P|mkdir_p|g'
+ @${REINPLACE_CMD} '/^SUBDIRS =/s/tests//' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/cal3d/files/patch-aclocal.m4 b/graphics/cal3d/files/patch-aclocal.m4
deleted file mode 100644
index 15e61076f5f8..000000000000
--- a/graphics/cal3d/files/patch-aclocal.m4
+++ /dev/null
@@ -1,12 +0,0 @@
---- aclocal.m4.orig 2006-06-29 11:04:20.000000000 -0500
-+++ aclocal.m4 2010-09-28 19:09:08.000000000 -0500
-@@ -6392,3 +6392,3 @@
- # generated from the m4 files accompanying Automake X.Y.
--AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="1.9"])
-+AC_DEFUN([AM_AUTOMAKE_VERSION], [am__api_version="%%AUTOMAKE_VERSION%%"])
-
-@@ -6399,3 +6399,3 @@
- AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
-- [AM_AUTOMAKE_VERSION([1.9.6])])
-+ [AM_AUTOMAKE_VERSION([%%AUTOMAKE_APIVER%%])])
-
diff --git a/graphics/cal3d/files/patch-configure.in b/graphics/cal3d/files/patch-configure.in
deleted file mode 100644
index e03668c22a78..000000000000
--- a/graphics/cal3d/files/patch-configure.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- configure.in.orig 2006-06-18 12:30:59.000000000 +0000
-+++ configure.in 2013-06-18 18:48:55.000000000 +0000
-@@ -68,3 +68,3 @@
-
--AC_OUTPUT(Makefile src/Makefile src/cal3d/Makefile docs/Makefile docs/api/Makefile docs/shared/Makefile tests/Makefile tests/run cal3d.pc src/cal3d_converter.1 fileformats.txt)
-+AC_OUTPUT(Makefile src/Makefile src/cal3d/Makefile docs/Makefile docs/api/Makefile docs/shared/Makefile cal3d.pc src/cal3d_converter.1 fileformats.txt)
-