aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cimg/files
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-10-21 04:54:08 +0800
committerthierry <thierry@FreeBSD.org>2004-10-21 04:54:08 +0800
commit5400166085499802d6a13ed56849ce68f1d1229f (patch)
tree94271d24ab8e5337571e75fb84388e342a4ba01d /graphics/cimg/files
parent94ac2e2e3aaea2994781fdc2759d0c2a4ca44ca9 (diff)
downloadfreebsd-ports-gnome-5400166085499802d6a13ed56849ce68f1d1229f.tar.gz
freebsd-ports-gnome-5400166085499802d6a13ed56849ce68f1d1229f.tar.zst
freebsd-ports-gnome-5400166085499802d6a13ed56849ce68f1d1229f.zip
Upgrade to CImg.1.0.7 version (pre-release).
Diffstat (limited to 'graphics/cimg/files')
-rw-r--r--graphics/cimg/files/patch-CImg.h54
-rw-r--r--graphics/cimg/files/patch-Makefile85
-rw-r--r--graphics/cimg/files/patch-examples::Makefile141
3 files changed, 26 insertions, 254 deletions
diff --git a/graphics/cimg/files/patch-CImg.h b/graphics/cimg/files/patch-CImg.h
deleted file mode 100644
index f83efccbf38e..000000000000
--- a/graphics/cimg/files/patch-CImg.h
+++ /dev/null
@@ -1,54 +0,0 @@
---- CImg.h.orig Mon Oct 11 21:46:09 2004
-+++ CImg.h Mon Oct 11 22:04:08 2004
-@@ -55,7 +55,7 @@
-
- // Autodetection of the current OS
- #ifndef cimg_OS
--#if defined(sun) || defined(__sun)
-+#if defined(sun) || defined(__sun)
- // Solaris
- #define cimg_OS 0
- #ifndef cimg_display_type
-@@ -82,6 +82,15 @@
- #ifndef cimg_display_type
- #define cimg_display_type 1
- #endif
-+#elif defined(__FreeBSD__)
-+// FreeBSD
-+#define cimg_OS 4
-+#ifndef cimg_display_type
-+#define cimg_display_type 1
-+#endif
-+#ifndef cimg_color_terminal
-+#define cimg_color_terminal
-+#endif
- #else
- // Other configurations
- #define cimg_OS -1
-@@ -1110,7 +1119,7 @@
- t_red,cimg_version,t_normal,__DATE__,__TIME__);
- std::fprintf(stderr," > Architecture : %s%-12s%s %s(cimg_OS=%d)\n%s",
- t_bold,
-- cimg_OS==0?"Solaris":(cimg_OS==1?"Linux":(cimg_OS==2?"Windows":(cimg_OS==3?"Mac OS X":"Unknown"))),
-+ cimg_OS==0?"Solaris":(cimg_OS==1?"Linux":(cimg_OS==2?"Windows":(cimg_OS==3?"Mac OS X":(cimg_OS==4?"FreeBSD":"Unknown")))),
- t_normal,t_purple,cimg_OS,t_normal);
- std::fprintf(stderr," > Display type : %s%-12s%s %s(cimg_display_type=%d)%s\n",
- t_bold,cimg_display_type==0?"No":(cimg_display_type==1?"X11":(cimg_display_type==2?"WindowsGDI":"Unknown")),t_normal,t_purple,cimg_display_type,t_normal);
-@@ -1542,7 +1551,7 @@
- uint width; //!< Width of the display window.
- uint height; //!< Height of the display window.
- uint normalize; //!< Pixel value normalization.
-- const uint attributes; //!< Attributes of the display window.
-+ uint attributes; //!< Attributes of the display window.
- volatile int mousex; //!< When (attributes&3)>=2, this variable corresponds to the mouse pointer X-coordinate into the display window.
- volatile int mousey; //!< When (attributes&3)>=2, this variable corresponds to the mouse pointer Y-coordinate into the display window.
- volatile uint button; //!< When (attributes&3)>=2, these variables corresponds to the mouse button clicked into the display window.
-@@ -6575,7 +6584,7 @@
- Here are the different environment variables used by the CImg Library :
-
- - \b \c cimg_OS : This variable defines the type of your current OS. It can be set to 0 (Solaris), 1 (Linux),
-- 2 (Windows), 3 (Mac OS X) or -1 (Other configuration).
-+ 2 (Windows), 3 (Mac OS X), 4 (FreeBSD) or -1 (Other configuration).
- It should be actually auto-detected by the CImg library. If this is not the case (cimg_OS=-1), then you
- will probably have to tune the environment variables described below.
- - \b \c cimg_display_type : This variable defines the type of display library that will be used to
diff --git a/graphics/cimg/files/patch-Makefile b/graphics/cimg/files/patch-Makefile
deleted file mode 100644
index ba77f4b95dde..000000000000
--- a/graphics/cimg/files/patch-Makefile
+++ /dev/null
@@ -1,85 +0,0 @@
---- Makefile.orig Fri Aug 6 17:35:44 2004
-+++ Makefile Mon Oct 11 22:42:11 2004
-@@ -1,41 +1,41 @@
--#--------------------------------------------------------------------------------------
--#
--# File : Makefile
--#
--# Description : Makefile to compile CImg for Linux and Solaris
--#
--# Author : David Tschumperlé
--#
--# Institution : ODYSSEE, INRIA Sophia Antipolis.
--#
--# Contact : David.Tschumperle@sophia.inria.fr
--#
--# Date : Project started november 1999.
--#
--# -----------------------------------------------------------------------------------
--
--# Set correct variables and paths
--CC = g++ -O4 -Wall-ansi -ffast-math
--X11PATH = /usr/X11R6
--X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
--
--# Compilation rules
--.cpp:
-- @echo "> Compiling '$*'"
-- @$(CC) -o $* $< $(CFLAGS) $(X11FLAGS) $(LDFLAGS)
--linux:
-- @echo -e "\n** Starting the compilation of the entire CImg package for Linux. Please wait...\n"
-- make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
--solaris:
-- @echo -e "\n** Starting the compilation of the entire CImg package for Solaris. Please wait...\n"
-- make "LDFLAGS=-lm -lpthread -R$(X11PATH)/lib -lnsl -lsocket" all
--doc:
-- @echo "> Create documentation (you need the 'doxygen' tool, see http://www.doxygen.org)."
-- @doxygen CImg.doxygen >/dev/null
--all: CImg_test
-- cd examples && make all
-- make doc
-- @echo -e "\n** All done successfully. You can launch 'CImg_test', or read documentation 'html/index.html'. **\n"
--clean:
-- cd examples && make clean
-- rm -rf documentation CImg_test cimg_new core *~ *.o *.exe
-+#--------------------------------------------------------------------------------------
-+#
-+# File : Makefile
-+#
-+# Description : Makefile to compile CImg for Linux and Solaris
-+#
-+# Author : David Tschumperlé
-+#
-+# Institution : ODYSSEE, INRIA Sophia Antipolis.
-+#
-+# Contact : David.Tschumperle@sophia.inria.fr
-+#
-+# Date : Project started november 1999.
-+#
-+# -----------------------------------------------------------------------------------
-+
-+# Set correct variables and paths
-+CC = $(CXX)
-+#X11PATH = /usr/X11R6
-+X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
-+
-+# Compilation rules
-+.cpp:
-+ @echo "> Compiling '$*'"
-+ $(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -ffast-math $(X11FLAGS) $(LDFLAGS)
-+linux:
-+ @echo -e "\n** Starting the compilation of the entire CImg package for Linux. Please wait...\n"
-+ make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
-+solaris:
-+ @echo -e "\n** Starting the compilation of the entire CImg package for Solaris. Please wait...\n"
-+ make "LDFLAGS=-lm -lpthread -R$(X11PATH)/lib -lnsl -lsocket" all
-+doc:
-+ @echo "> Create documentation (you need the 'doxygen' tool, see http://www.doxygen.org)."
-+ @doxygen CImg.doxygen >/dev/null
-+all: CImg_test
-+ cd examples && make all
-+ make doc
-+ @echo -e "\n** All done successfully. After install, you can launch 'CImg_test', or read documentation 'html/index.html'. **\n"
-+clean:
-+ cd examples && make clean
-+ rm -rf documentation CImg_test cimg_new core *~ *.o *.exe
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index d6ea6f6ad975..8f6363895d3f 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,117 +1,28 @@
---- examples/Makefile.orig Fri Aug 6 17:35:46 2004
-+++ examples/Makefile Mon Oct 11 22:43:13 2004
-@@ -1,57 +1,57 @@
--#--------------------------------------------------------------------------------------
--#
--# Makefile : Makefile for compiling CImg examples
--#
--# Author : David Tschumperlé
--#
--# Institution : ODYSSEE, INRIA Sophia Antipolis.
--#
--# Contact : David.Tschumperle@sophia.inria.fr
--#
--# Date : Project started november 1999.
--#
--# -----------------------------------------------------------------------------------
--
--# Set correct variables and paths
--CC = g++ -O4 -Wall -ansi -ffast-math
--X11PATH = /usr/X11R6
--X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
--
--# Compilation rules
--.cpp:
-- @echo "> Compiling '$*'"
-- @$(CC) -o $* $< $(CFLAGS) $(X11FLAGS) $(LDFLAGS)
--linux:
-- make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
--solaris:
-- make "LDFLAGS=-lm -lpthread -R$(X11PATH)/lib -lnsl -lsocket" all
--
--all: fade_images \
-- inpainter \
-- odykill \
-- pslider \
-- inrcast \
-- inrcrop \
-- optical_flow \
-- hough_transform \
-- render3d \
-- tutorial \
-- tetris \
-- pde_heatflow2D \
-- pde_TschumperleDeriche2D
--
--clean:
-- rm -f *.exe *~ \
-- fade_images \
-- inpainter \
-- odykill \
-- pslider \
-- inrcast \
-- inrcrop \
-- optical_flow \
-- hough_transform \
-- render3d \
-- tutorial \
-- tetris \
-- pde_heatflow2D \
-- pde_TschumperleDeriche2D
-+#--------------------------------------------------------------------------------------
-+#
-+# Makefile : Makefile for compiling CImg examples
-+#
-+# Author : David Tschumperlé
-+#
-+# Institution : ODYSSEE, INRIA Sophia Antipolis.
-+#
-+# Contact : David.Tschumperle@sophia.inria.fr
-+#
-+# Date : Project started november 1999.
-+#
-+# -----------------------------------------------------------------------------------
-+
-+# Set correct variables and paths
+--- examples/Makefile.orig Wed Oct 20 16:49:34 2004
++++ examples/Makefile Wed Oct 20 21:16:24 2004
+@@ -7,14 +7,14 @@
+ # -----------------------------------------------------------------------------------
+
+ # Set correct variables and paths
+-CC = g++ -O4 -Wall -ansi -ffast-math
+-X11PATH = /usr/X11R6
+CC = $(CXX)
+#X11PATH = /usr/X11R6
-+X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
-+
-+# Compilation rules
-+.cpp:
-+ @echo "> Compiling '$*'"
-+ $(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -ffast-math $(X11FLAGS) $(LDFLAGS)
-+linux:
-+ make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
-+solaris:
-+ make "LDFLAGS=-lm -lpthread -R$(X11PATH)/lib -lnsl -lsocket" all
-+
-+all: fade_images \
-+ inpainter \
-+ odykill \
-+ pslider \
-+ inrcast \
-+ inrcrop \
-+ optical_flow \
-+ hough_transform \
-+ render3d \
-+ tutorial \
-+ tetris \
-+ pde_heatflow2D \
-+ pde_TschumperleDeriche2D
-+
-+clean:
-+ rm -f *.exe *~ *.orig \
-+ fade_images \
-+ inpainter \
-+ odykill \
-+ pslider \
-+ inrcast \
-+ inrcrop \
-+ optical_flow \
-+ hough_transform \
-+ render3d \
-+ tutorial \
-+ tetris \
-+ pde_heatflow2D \
-+ pde_TschumperleDeriche2D
+ X11FLAGS = -I$(X11PATH)/include -L$(X11PATH)/lib -lX11
+
+ # Compilation rules
+ .cpp:
+ @echo -e "\n** Compiling '$*'\n"
+- @$(CC) -o $* $< $(CFLAGS) $(X11FLAGS) $(LDFLAGS)
++ @$(CC) -o $* $< $(CPPFLAGS) -Wall -ansi -ffast-math $(X11FLAGS) $(LDFLAGS)
+ linux:
+ make "LDFLAGS=-lm -lpthread -Wl,-rpath $(X11PATH)/lib" all
+ solaris:
+@@ -37,6 +37,7 @@
+
+ clean:
+ rm -f *.exe *~ \
++ Makefile.orig \
+ CImg_test \
+ fade_images \
+ inpainter \