aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cimg
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-04-21 05:12:51 +0800
committerthierry <thierry@FreeBSD.org>2014-04-21 05:12:51 +0800
commit789354b8bc0f218a4e381edecd75b646f3aa6551 (patch)
treef8be213fd7ea8547ec0257d3ff456c874c79aafe /graphics/cimg
parentce1146f261d6e24e662f2d738ce552d7cabe45c2 (diff)
downloadfreebsd-ports-gnome-789354b8bc0f218a4e381edecd75b646f3aa6551.tar.gz
freebsd-ports-gnome-789354b8bc0f218a4e381edecd75b646f3aa6551.tar.zst
freebsd-ports-gnome-789354b8bc0f218a4e381edecd75b646f3aa6551.zip
Upgrade to 1.5.8.
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile8
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile48
-rw-r--r--graphics/cimg/pkg-plist1
4 files changed, 23 insertions, 38 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 32fc25b8a56a..bdeb606f4881 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cimg
-PORTVERSION= 1.5.7
-PORTREVISION= 3
+PORTVERSION= 1.5.8
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -31,7 +30,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:C/_/-/}
BUILD_WRKSRC= ${WRKSRC}/examples
MAKE_ENV= X11PATH=${LOCALBASE} LOCALBASE=${LOCALBASE}
CPPFLAGS+= ${CFLAGS} ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS} -Wl,--verbose
+LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(NOPORTDOCS)
USES+= gmake
@@ -45,8 +44,9 @@ LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app \
libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libopencv_legacy.so:${PORTSDIR}/graphics/opencv \
+ libopencv_core.so:${PORTSDIR}/graphics/opencv-core\
libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13
-# libopencv_legacy.so:${PORTSDIR}/graphics/opencv
ALL_TARGET= Mlinux
. else
ALL_TARGET= dlinux
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index a259e7b705d8..9883b3397c88 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.5.7/CImg-1.5.7.zip) = db84666a829ce02ef7a6d56769a50818e856843c515c4cf1b95907cee807e50c
-SIZE (cimg-1.5.7/CImg-1.5.7.zip) = 11548216
+SHA256 (cimg-1.5.8/CImg-1.5.8.zip) = 8f67ab3193dd7827e8b11ec1cdb1c8415d726e642c609c1854c05a4ec11770c8
+SIZE (cimg-1.5.8/CImg-1.5.8.zip) = 11552959
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index a53da9af5c93..fe78c971d385 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,9 +1,9 @@
---- examples/Makefile.orig 2013-10-31 10:07:28.000000000 +0100
-+++ examples/Makefile 2013-11-02 22:49:54.000000000 +0100
+--- examples/Makefile.orig 2014-04-17 15:41:13.000000000 +0200
++++ examples/Makefile 2014-04-20 21:51:43.000000000 +0200
@@ -84,8 +84,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.5.7
+ CIMG_VERSION = 1.5.8
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = $(X11PATH)
@@ -27,23 +27,20 @@
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
-CIMG_OPT_CFLAGS = -O3 -fno-tree-pre
-+CIMG_OPT_CFLAGS = -fno-tree-pre
++CIMG_OPT_CFLAGS =
endif
# Flags to enable OpenMP support.
-@@ -136,8 +136,9 @@
+@@ -136,7 +136,7 @@
endif
# Flags to enable OpenCV support.
-CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I/usr/include/opencv
--CIMG_OPENCV_LDFLAGS = -lcv -lhighgui
-+# Disavle OpenCV in 1.5.7 due to failure
-+#CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I$(LOCALBASE)/include/opencv
-+#CIMG_OPENCV_LDFLAGS = -lopencv_legacy -lopencv_highgui
++CIMG_OPENCV_CFLAGS = -Dcimg_use_opencv -I$(LOCALBASE)/include/opencv
+ CIMG_OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui
+ #CIMG_OPENCV_LDFLAGS = -lcv -lhighgui #-> Use this for OpenCV < 2.2.0
- # Flags used to disable display capablities of CImg
- CIMG_NODISPLAY_CFLAGS = -Dcimg_display=0
-@@ -146,7 +147,7 @@
+@@ -147,7 +147,7 @@
# (X11 is used by CImg to handle display windows)
# !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
CIMG_X11_CFLAGS = -I$(X11PATH)/include
@@ -52,7 +49,7 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
-@@ -176,7 +177,7 @@
+@@ -177,7 +177,7 @@
# Flags to enable native support for TIFF image files, using the TIFF library.
# ( http://www.libtiff.org/ )
CIMG_TIFF_CFLAGS = -Dcimg_use_tiff
@@ -61,7 +58,7 @@
# Flags to enable native support for MINC2 image files, using the MINC2 library.
# ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
-@@ -185,7 +186,7 @@
+@@ -186,7 +186,7 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -70,7 +67,7 @@
CIMG_EXR_LDFLAGS = -lIlmImf -lHalf
# Flags to enable native support for various video files, using the FFMPEG library.
-@@ -200,8 +201,8 @@
+@@ -201,8 +201,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -81,7 +78,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -214,14 +215,17 @@
+@@ -215,14 +215,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -102,14 +99,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -359,26 +363,26 @@
- $(CIMG_XSHM_CFLAGS) \
- $(CIMG_XRANDR_CFLAGS) \
- $(CIMG_TIFF_CFLAGS) \
--$(CIMG_MINC2_CFLAGS) \
- $(CIMG_EXR_CFLAGS) \
- $(CIMG_PNG_CFLAGS) \
- $(CIMG_JPEG_CFLAGS) \
+@@ -366,6 +369,7 @@
$(CIMG_ZLIB_CFLAGS) \
$(CIMG_OPENCV_CFLAGS) \
$(CIMG_MAGICK_CFLAGS) \
@@ -117,17 +107,11 @@
$(CIMG_FFTW3_CFLAGS)" \
"CONF_LDFLAGS = \
$(CIMG_X11_LDFLAGS) \
- $(CIMG_XSHM_LDFLAGS) \
- $(CIMG_XRANDR_LDFLAGS) \
- $(CIMG_TIFF_LDFLAGS) \
--$(CIMG_MINC2_LDFLAGS) \
- $(CIMG_EXR_LDFLAGS) \
+@@ -376,6 +380,7 @@
$(CIMG_PNG_LDFLAGS) \
$(CIMG_JPEG_LDFLAGS) \
$(CIMG_ZLIB_LDFLAGS) \
++$(CIMG_LAPACK_LDFLAGS) \
$(CIMG_OPENCV_LDFLAGS) \
$(CIMG_MAGICK_LDFLAGS) \
-+$(CIMG_LAPACK_LDFLAGS) \
$(CIMG_FFTW3_LDFLAGS)" \
- "STRIP_EXE=true" \
- all $(CIMG_EXTRA_FILES)
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index 6b616a22e710..9dc3c1ad7d29 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -445,6 +445,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/screenshots.shtml
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CImg_demo.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CMakeLists.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/captcha.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curve_editor2d.cpp