aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cimg
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-04 08:09:47 +0800
committeradamw <adamw@FreeBSD.org>2014-07-04 08:09:47 +0800
commit8c1f5c8be901fc3a33720a12ff6eb036b5908767 (patch)
tree3645a10ed72391740d754f21302e9a7bd1e2f8ed /graphics/cimg
parente198670a20bdb15ca6c0680cc2882da2d1ab6db8 (diff)
downloadfreebsd-ports-gnome-8c1f5c8be901fc3a33720a12ff6eb036b5908767.tar.gz
freebsd-ports-gnome-8c1f5c8be901fc3a33720a12ff6eb036b5908767.tar.zst
freebsd-ports-gnome-8c1f5c8be901fc3a33720a12ff6eb036b5908767.zip
Remove NOPORTDOCS and NOPORTEXAMPLES.
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index a5b23df1456e..5657efb1e1e7 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -33,7 +33,11 @@ MAKE_ENV= X11PATH=${LOCALBASE} LOCALBASE=${LOCALBASE}
CPPFLAGS+= ${CFLAGS} ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
USES+= gmake
REINPLACE_ARGS= -i ""
LIB_DEPENDS+= libboard.so:${PORTSDIR}/graphics/libboard
@@ -83,7 +87,7 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
. if !defined(WITHOUT_LAPACK)
. if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
@@ -100,7 +104,7 @@ LAPACK_LIB= -L${LOCALBASE}/lib -llapack -lblas
.endif
pre-configure:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's|make|${MAKE_CMD}|' ${BUILD_WRKSRC}/Makefile
.else
${REINPLACE_CMD} -e 's|^OPTFLAGS|#OPTFLAGS|' ${BUILD_WRKSRC}/Makefile
@@ -121,13 +125,13 @@ pre-configure:
do-install:
${INSTALL_DATA} ${WRKSRC}/CImg.h ${STAGEDIR}${PREFIX}/include
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL_PROGRAM} ${PROGS:C|^|${BUILD_WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCBASE:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
@(cd ${STAGEDIR}${EXAMPLESDIR} && ${MAKE_CMD} clean)