aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/cimg
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-22 00:47:07 +0800
committerwg <wg@FreeBSD.org>2013-10-22 00:47:07 +0800
commitc0255b7276ef15cca1be26e8189c2a9a26535da7 (patch)
tree625a0d1c002e0d1fa46f87450bf1f68e11924404 /graphics/cimg
parent45ac7e07195f2841e9296dcede082d6c95277d93 (diff)
downloadfreebsd-ports-gnome-c0255b7276ef15cca1be26e8189c2a9a26535da7.tar.gz
freebsd-ports-gnome-c0255b7276ef15cca1be26e8189c2a9a26535da7.tar.zst
freebsd-ports-gnome-c0255b7276ef15cca1be26e8189c2a9a26535da7.zip
graphics/cimg: link against ffmpeg
- Link against ffmpeg - USES gmake Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile6
-rw-r--r--graphics/cimg/files/patch-examples::Makefile9
2 files changed, 4 insertions, 11 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 50431e97aa92..3031c88ab595 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cimg
PORTVERSION= 1.5.6
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -34,7 +34,7 @@ CPPFLAGS+= ${CFLAGS} ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(NOPORTDOCS)
-USE_GMAKE= yes
+USES= gmake
REINPLACE_ARGS= -i ""
LIB_DEPENDS+= board.0:${PORTSDIR}/graphics/libboard
@@ -61,7 +61,7 @@ WITHOUT_LAPACK= yes
RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
. endif
. if !defined(WITHOUT_FFMPEG)
-LIB_DEPENDS+= avformat1:${PORTSDIR}/multimedia/ffmpeg1
+LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
. endif
DOCBASE= README.txt
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 249830213cfd..d79f183fdc1d 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -51,7 +51,7 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
-@@ -185,13 +185,13 @@
+@@ -185,8 +185,8 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -61,13 +61,6 @@
# Flags to enable native support for various video files, using the FFMPEG library.
# ( http://www.ffmpeg.org/ )
--CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale -I/usr/include/ffmpeg
--CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
-+CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/$(LOCALBASE)/include/ffmpeg1/libavcodec -I/$(LOCALBASE)/include/ffmpeg1/libavformat -I/$(LOCALBASE)/include/ffmpeg1/libswscale -I/$(LOCALBASE)/include/ffmpeg1
-+CIMG_FFMPEG_LDFLAGS = -L$(LOCALBASE)/lib/ffmpeg1 -lavcodec1 -lavformat1 -lswscale1
-
- # Flags to enable native support for compressed .cimgz files, using the Zlib library.
- # ( http://www.zlib.net/ )
@@ -200,8 +200,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.