aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/clutter/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /graphics/clutter/Makefile
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'graphics/clutter/Makefile')
-rw-r--r--graphics/clutter/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index 8681562a5ff5..05b2660dad90 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: clutter
-# Date created: 2008-12-25
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/clutter/Makefile,v 1.34 2010/09/24 16:35:42 kwm Exp $
-#
PORTNAME= clutter
PORTVERSION= 1.4.0
@@ -16,15 +12,16 @@ MASTER_SITES= GNOME \
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
-LIB_DEPENDS= json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+LIB_DEPENDS= json-glib-1.0:${PORTSDIR}/devel/json-glib
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GMAKE= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_GNOME= gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
+USE_PKGCONFIG= build
USE_GL= gl
USE_XORG= glproto x11 xfixes xdamage xcomposite xi
USE_LDCONFIG= yes
@@ -33,4 +30,13 @@ CONFIGURE_ARGS= --with-x --enable-conformance=no
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_CONST_RETURN|const|g' \
+ ${WRKSRC}/clutter/cally/*.c \
+ ${WRKSRC}/clutter/*.[ch] \
+ ${WRKSRC}/clutter/glx/*.c \
+ ${WRKSRC}/clutter/x11/*.h \
+ ${WRKSRC}/clutter/cogl/cogl/*.h \
+ ${WRKSRC}/clutter/json/*.c
+
.include <bsd.port.mk>