aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/clutter
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerKoop Mast <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /graphics/clutter
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadfreebsd-ports-gnome-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
freebsd-ports-gnome-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.zst
freebsd-ports-gnome-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'graphics/clutter')
-rw-r--r--graphics/clutter/Makefile8
-rw-r--r--graphics/clutter/distinfo6
-rw-r--r--graphics/clutter/pkg-plist44
3 files changed, 47 insertions, 11 deletions
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index a1e6ddb9835a..1a548efce036 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -6,18 +6,14 @@
#
PORTNAME= clutter
-PORTVERSION= 1.0.10
-PORTREVISION= 2
+PORTVERSION= 1.2.6
CATEGORIES= graphics
MASTER_SITES= GNOME \
- http://www.clutter-project.org/sources/${PORTNAME}/1.0/
+ http://www.clutter-project.org/sources/${PORTNAME}/${PORTVERSION:R}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
-BUILD_DEPENDS= ${LOCALBASE}/share/gir-1.0/Pango-1.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-pango
-RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/Pango-1.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-pango
-
USE_GMAKE= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
diff --git a/graphics/clutter/distinfo b/graphics/clutter/distinfo
index eecdb949c4a0..0728fe3e54ef 100644
--- a/graphics/clutter/distinfo
+++ b/graphics/clutter/distinfo
@@ -1,3 +1,3 @@
-MD5 (clutter-1.0.10.tar.bz2) = bf48e85291cba33f3f149f4eefe759f0
-SHA256 (clutter-1.0.10.tar.bz2) = 6fb98dc4d16a3a98be734cf0a6cc4f8d8179800603c3e41011c414eeaf1f456b
-SIZE (clutter-1.0.10.tar.bz2) = 2052074
+MD5 (clutter-1.2.6.tar.bz2) = eba5af33e966d9c9b0caab7d9e019f0d
+SHA256 (clutter-1.2.6.tar.bz2) = aafb7ee0c7132d42338e8041077fbb1a8be321c59b32218a5b3418305b815d0d
+SIZE (clutter-1.2.6.tar.bz2) = 2372773
diff --git a/graphics/clutter/pkg-plist b/graphics/clutter/pkg-plist
index 5312850e8120..1fc504a35936 100644
--- a/graphics/clutter/pkg-plist
+++ b/graphics/clutter/pkg-plist
@@ -2,6 +2,7 @@ include/clutter-1.0/clutter/clutter-actor.h
include/clutter-1.0/clutter/clutter-alpha.h
include/clutter-1.0/clutter/clutter-animatable.h
include/clutter-1.0/clutter/clutter-animation.h
+include/clutter-1.0/clutter/clutter-animator.h
include/clutter-1.0/clutter/clutter-backend.h
include/clutter-1.0/clutter/clutter-behaviour-depth.h
include/clutter-1.0/clutter/clutter-behaviour-ellipse.h
@@ -10,22 +11,31 @@ include/clutter-1.0/clutter/clutter-behaviour-path.h
include/clutter-1.0/clutter/clutter-behaviour-rotate.h
include/clutter-1.0/clutter/clutter-behaviour-scale.h
include/clutter-1.0/clutter/clutter-behaviour.h
+include/clutter-1.0/clutter/clutter-bin-layout.h
include/clutter-1.0/clutter/clutter-binding-pool.h
+include/clutter-1.0/clutter/clutter-box-layout.h
+include/clutter-1.0/clutter/clutter-box.h
include/clutter-1.0/clutter/clutter-cairo-texture.h
include/clutter-1.0/clutter/clutter-child-meta.h
include/clutter-1.0/clutter/clutter-clone.h
include/clutter-1.0/clutter/clutter-color.h
include/clutter-1.0/clutter/clutter-container.h
include/clutter-1.0/clutter/clutter-deprecated.h
+include/clutter-1.0/clutter/clutter-device-manager.h
include/clutter-1.0/clutter/clutter-enum-types.h
include/clutter-1.0/clutter/clutter-event.h
include/clutter-1.0/clutter/clutter-feature.h
+include/clutter-1.0/clutter/clutter-fixed-layout.h
include/clutter-1.0/clutter/clutter-fixed.h
+include/clutter-1.0/clutter/clutter-flow-layout.h
include/clutter-1.0/clutter/clutter-frame-source.h
include/clutter-1.0/clutter/clutter-group.h
+include/clutter-1.0/clutter/clutter-input-device.h
include/clutter-1.0/clutter/clutter-interval.h
include/clutter-1.0/clutter/clutter-json.h
include/clutter-1.0/clutter/clutter-keysyms.h
+include/clutter-1.0/clutter/clutter-layout-manager.h
+include/clutter-1.0/clutter/clutter-layout-meta.h
include/clutter-1.0/clutter/clutter-list-model.h
include/clutter-1.0/clutter/clutter-main.h
include/clutter-1.0/clutter/clutter-media.h
@@ -38,6 +48,7 @@ include/clutter-1.0/clutter/clutter-scriptable.h
include/clutter-1.0/clutter/clutter-shader-types.h
include/clutter-1.0/clutter/clutter-shader.h
include/clutter-1.0/clutter/clutter-stage-manager.h
+include/clutter-1.0/clutter/clutter-stage-window.h
include/clutter-1.0/clutter/clutter-stage.h
include/clutter-1.0/clutter/clutter-text.h
include/clutter-1.0/clutter/clutter-texture.h
@@ -59,9 +70,10 @@ include/clutter-1.0/clutter/x11/clutter-x11-enum-types.h
include/clutter-1.0/clutter/x11/clutter-x11-texture-pixmap.h
include/clutter-1.0/clutter/x11/clutter-x11.h
include/clutter-1.0/cogl/cogl-bitmap.h
+include/clutter-1.0/cogl/cogl-buffer.h
include/clutter-1.0/cogl/cogl-color.h
include/clutter-1.0/cogl/cogl-debug.h
-include/clutter-1.0/cogl/cogl-defines-gl.h
+include/clutter-1.0/cogl/cogl-defines.h
include/clutter-1.0/cogl/cogl-deprecated.h
include/clutter-1.0/cogl/cogl-enum-types.h
include/clutter-1.0/cogl/cogl-fixed.h
@@ -70,6 +82,8 @@ include/clutter-1.0/cogl/cogl-matrix.h
include/clutter-1.0/cogl/cogl-offscreen.h
include/clutter-1.0/cogl/cogl-pango.h
include/clutter-1.0/cogl/cogl-path.h
+include/clutter-1.0/cogl/cogl-pixel-buffer.h
+include/clutter-1.0/cogl/cogl-primitives.h
include/clutter-1.0/cogl/cogl-shader.h
include/clutter-1.0/cogl/cogl-texture.h
include/clutter-1.0/cogl/cogl-types.h
@@ -90,6 +104,7 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ClutterActor.html
%%DOCSDIR%%/ClutterAlpha.html
%%DOCSDIR%%/ClutterAnimatable.html
+%%DOCSDIR%%/ClutterAnimator.html
%%DOCSDIR%%/ClutterBehaviour.html
%%DOCSDIR%%/ClutterBehaviourDepth.html
%%DOCSDIR%%/ClutterBehaviourEllipse.html
@@ -97,11 +112,20 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ClutterBehaviourPath.html
%%DOCSDIR%%/ClutterBehaviourRotate.html
%%DOCSDIR%%/ClutterBehaviourScale.html
+%%DOCSDIR%%/ClutterBinLayout.html
+%%DOCSDIR%%/ClutterBox.html
+%%DOCSDIR%%/ClutterBoxLayout.html
%%DOCSDIR%%/ClutterCairoTexture.html
%%DOCSDIR%%/ClutterChildMeta.html
%%DOCSDIR%%/ClutterClone.html
%%DOCSDIR%%/ClutterContainer.html
+%%DOCSDIR%%/ClutterDeviceManager.html
+%%DOCSDIR%%/ClutterFixedLayout.html
+%%DOCSDIR%%/ClutterFlowLayout.html
%%DOCSDIR%%/ClutterGroup.html
+%%DOCSDIR%%/ClutterInputDevice.html
+%%DOCSDIR%%/ClutterLayoutManager.html
+%%DOCSDIR%%/ClutterLayoutMeta.html
%%DOCSDIR%%/ClutterListModel.html
%%DOCSDIR%%/ClutterMedia.html
%%DOCSDIR%%/ClutterModel.html
@@ -111,14 +135,16 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ClutterScore.html
%%DOCSDIR%%/ClutterScript.html
%%DOCSDIR%%/ClutterScriptable.html
-%%DOCSDIR%%/ClutterShader.html
%%DOCSDIR%%/ClutterStage.html
%%DOCSDIR%%/ClutterText.html
%%DOCSDIR%%/ClutterTexture.html
%%DOCSDIR%%/ClutterTimeline.html
%%DOCSDIR%%/actor-box.png
%%DOCSDIR%%/additionaldocs.html
+%%DOCSDIR%%/animator-key-frames.png
%%DOCSDIR%%/annotation-glossary.html
+%%DOCSDIR%%/bin-layout.png
+%%DOCSDIR%%/box-layout.png
%%DOCSDIR%%/building-clutter.html
%%DOCSDIR%%/ch01.html
%%DOCSDIR%%/ch02.html
@@ -129,15 +155,19 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ch07.html
%%DOCSDIR%%/ch08.html
%%DOCSDIR%%/ch09.html
+%%DOCSDIR%%/ch10.html
%%DOCSDIR%%/clutter-ClutterBackend.html
%%DOCSDIR%%/clutter-Colors.html
%%DOCSDIR%%/clutter-EGL-Specific-Support.html
%%DOCSDIR%%/clutter-EGLX-Specific-Support.html
%%DOCSDIR%%/clutter-Events.html
+%%DOCSDIR%%/clutter-Features.html
%%DOCSDIR%%/clutter-GLX-Specific-Support.html
%%DOCSDIR%%/clutter-General.html
%%DOCSDIR%%/clutter-Implicit-Animations.html
%%DOCSDIR%%/clutter-Key-Bindings.html
+%%DOCSDIR%%/clutter-Shaders.html
+%%DOCSDIR%%/clutter-Stage-Manager.html
%%DOCSDIR%%/clutter-Unit-conversion.html
%%DOCSDIR%%/clutter-Utilities.html
%%DOCSDIR%%/clutter-Value-intervals.html
@@ -164,6 +194,8 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/creating-your-own-behaviours.html
%%DOCSDIR%%/easing-modes.png
%%DOCSDIR%%/event-flow.png
+%%DOCSDIR%%/flow-layout-horizontal.png
+%%DOCSDIR%%/flow-layout-vertical.png
%%DOCSDIR%%/go01.html
%%DOCSDIR%%/home.png
%%DOCSDIR%%/index.html
@@ -176,6 +208,7 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ix05.html
%%DOCSDIR%%/ix06.html
%%DOCSDIR%%/ix07.html
+%%DOCSDIR%%/ix08.html
%%DOCSDIR%%/left.png
%%DOCSDIR%%/license.html
%%DOCSDIR%%/migrating-ClutterEffect.html
@@ -189,7 +222,10 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/up.png
%%DOCSDIR%%/using-cairo.html
share/doc/cogl/ch01.html
+share/doc/cogl/ch02.html
share/doc/cogl/cogl-Blend-Strings.html
+share/doc/cogl/cogl-Buffers.html
+share/doc/cogl/cogl-Clipping.html
share/doc/cogl/cogl-Color-Type.html
share/doc/cogl/cogl-Fixed-Point-API.html
share/doc/cogl/cogl-General-API.html
@@ -206,6 +242,10 @@ share/doc/cogl/home.png
share/doc/cogl/index.html
share/doc/cogl/index.sgml
share/doc/cogl/ix01.html
+share/doc/cogl/ix02.html
+share/doc/cogl/ix03.html
+share/doc/cogl/ix04.html
+share/doc/cogl/ix05.html
share/doc/cogl/left.png
share/doc/cogl/license.html
share/doc/cogl/right.png