aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/comical
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-07 06:27:51 +0800
committerpav <pav@FreeBSD.org>2005-06-07 06:27:51 +0800
commitdcaf540fc621ceb3222f80b918f796a5c37aa866 (patch)
tree64dfe765b99eeecc8a1260fdfd450090ed7bb4ff /graphics/comical
parentd3b6a52016991466907e2af097a71071f9ed849a (diff)
downloadfreebsd-ports-gnome-dcaf540fc621ceb3222f80b918f796a5c37aa866.tar.gz
freebsd-ports-gnome-dcaf540fc621ceb3222f80b918f796a5c37aa866.tar.zst
freebsd-ports-gnome-dcaf540fc621ceb3222f80b918f796a5c37aa866.zip
A Sequential Image Viewer for viewing scanned comic book archives
PR: ports/81973 Submitted by: John McAree <john@mcaree.org>
Diffstat (limited to 'graphics/comical')
-rw-r--r--graphics/comical/Makefile34
-rw-r--r--graphics/comical/distinfo2
-rw-r--r--graphics/comical/pkg-descr8
-rw-r--r--graphics/comical/pkg-plist1
4 files changed, 45 insertions, 0 deletions
diff --git a/graphics/comical/Makefile b/graphics/comical/Makefile
new file mode 100644
index 000000000000..1e51c5c53140
--- /dev/null
+++ b/graphics/comical/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: comical
+# Date created: 6 June 2005
+# Whom: John McAree <john@mcaree.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= comical
+PORTVERSION= 0.4.1
+CATEGORIES= games
+MASTER_SITES= http://www.mcaree.org/Comical/ \
+ http://www.sketchyorigins.com/Comical/
+
+MAINTAINER= john@mcaree.org
+COMMENT= A sequential image viewer
+
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "does not compile - not 64-bit clean"
+.endif
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile with gcc-2.95"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/comical/distinfo b/graphics/comical/distinfo
new file mode 100644
index 000000000000..b6da3474ced3
--- /dev/null
+++ b/graphics/comical/distinfo
@@ -0,0 +1,2 @@
+MD5 (comical-0.4.1.tar.gz) = 50e0f3a8ad252470461efe74a6ca6060
+SIZE (comical-0.4.1.tar.gz) = 404828
diff --git a/graphics/comical/pkg-descr b/graphics/comical/pkg-descr
new file mode 100644
index 000000000000..1d86fe1c3a72
--- /dev/null
+++ b/graphics/comical/pkg-descr
@@ -0,0 +1,8 @@
+Comical is a sequential image viewer. It supports viewing images from archives
+(bzip, zip and rar format), as well as fullscreen viewing. Image formats
+supported are JPEG, PNG, GIF, and TIFF.
+
+WWW: http://mlf.sketchyorigins.com/
+
+- John
+john@mcaree.org
diff --git a/graphics/comical/pkg-plist b/graphics/comical/pkg-plist
new file mode 100644
index 000000000000..006c1533af96
--- /dev/null
+++ b/graphics/comical/pkg-plist
@@ -0,0 +1 @@
+bin/comical