aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/darktable
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-11-04 17:23:41 +0800
committerdanfe <danfe@FreeBSD.org>2011-11-04 17:23:41 +0800
commit26ae163171dd4de45832e7c37d22ca19c9a56770 (patch)
treed66bb2d46fdf780461ae17519d7f1deb2e430e02 /graphics/darktable
parentff51dbbdd30e10f5395cbc5becfa72ed78f760ce (diff)
downloadfreebsd-ports-gnome-26ae163171dd4de45832e7c37d22ca19c9a56770.tar.gz
freebsd-ports-gnome-26ae163171dd4de45832e7c37d22ca19c9a56770.tar.zst
freebsd-ports-gnome-26ae163171dd4de45832e7c37d22ca19c9a56770.zip
Allow to build without rawspeed backend (use libraw instead).
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 10af7ea15c42..bf328cd4b306 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -32,6 +32,7 @@ MAN1= ${PORTNAME}.1
OPTIONS= GCONF "Enable GConf backend" off \
GPHOTO "Enable camera support via libgphoto2" on \
FLICKR "Enable Flickr support via flickcurl" off \
+ RAWSPEED "Compile with rawspeed backend" on \
SLIDESHOW "Build OpenGL/SDL slideshow viewer" off \
KWALLET "Enable KWallet support (requires dbus-glib)" off \
GKEYRING "Enable GNOME Keyring support" off \
@@ -68,6 +69,10 @@ PLIST_FILES+= lib/darktable/plugins/imageio/storage/libflickr.so
CMAKE_ARGS+= -DUSE_FLICKR:BOOL=OFF
.endif
+.if !defined(WITH_RAWSPEED)
+CMAKE_ARGS+= -DDONT_USE_RAWSPEED:BOOL=ON
+.endif
+
.if defined(WITH_SLIDESHOW)
USE_GL= gl
USE_SDL= sdl
@@ -111,6 +116,9 @@ post-patch:
${WRKSRC}/doc/CMakeLists.txt
post-install:
+.if !defined(WITH_RAWSPEED)
+ @${REINPLACE_CMD} -e '/rawspeed/d' ${TMPPLIST}
+.endif
.if !defined(WITH_NLS)
@${REINPLACE_CMD} -e '/LC_MESSAGES/d' ${TMPPLIST}
.endif