aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/darktable
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-01-30 17:31:34 +0800
committerdanfe <danfe@FreeBSD.org>2013-01-30 17:31:34 +0800
commit890c5ce9ecb716ba5115dde8b48255183b6df4bb (patch)
tree8e7f7a3975836cc9b99cfae30f94ec710f6e16c5 /graphics/darktable
parent4269279317defdf2e3f0f853e47e8472ba98c2d2 (diff)
downloadfreebsd-ports-gnome-890c5ce9ecb716ba5115dde8b48255183b6df4bb.tar.gz
freebsd-ports-gnome-890c5ce9ecb716ba5115dde8b48255183b6df4bb.tar.zst
freebsd-ports-gnome-890c5ce9ecb716ba5115dde8b48255183b6df4bb.zip
- Update to version 1.1.2
- Rename GLIBJSON option to FACEBOOK PR: ports/175225 Submitted by: dumbbell
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/Makefile22
-rw-r--r--graphics/darktable/distinfo4
-rw-r--r--graphics/darktable/pkg-plist4
3 files changed, 11 insertions, 19 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 08b0e9418edb..ff9cc1e6e973 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= darktable
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.2
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Virtual lighttable and darkroom for photographers
@@ -33,11 +32,11 @@ INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GPHOTO GEO FLICKR GLIBJSON KWALLET GNOMEKEYRING RAWSPEED \
+OPTIONS_DEFINE= GPHOTO GEO FLICKR FACEBOOK KWALLET GNOMEKEYRING RAWSPEED \
SLIDESHOW NLS GCC46
GEO_DESC= Build geotagging parts
-GLIBJSON_DESC= GlibJson library support
+FACEBOOK_DESC= Support images export to Facebook
RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
GCC46_DESC= Build with GCC 4.6+ (better OpenMP support)
@@ -58,6 +57,9 @@ CMAKE_ARGS+= -DUSE_CAMERA_SUPPORT:BOOL=OFF
.if ${PORT_OPTIONS:MGEO}
LIB_DEPENDS+= soup-2.4:${PORTSDIR}/devel/libsoup
+PLIST_FILES+= lib/darktable/plugins/lighttable/liblocation.so \
+ lib/darktable/plugins/lighttable/libmap_settings.so \
+ lib/darktable/views/libmap.so
.else
CMAKE_ARGS+= -DUSE_GEO:BOOL=OFF
.endif
@@ -69,8 +71,9 @@ PLIST_FILES+= lib/darktable/plugins/imageio/storage/libflickr.so
CMAKE_ARGS+= -DUSE_FLICKR:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MGLIBJSON}
+.if ${PORT_OPTIONS:MFACEBOOK}
LIB_DEPENDS+= json-glib-1.0:${PORTSDIR}/devel/json-glib
+PLIST_FILES+= lib/darktable/plugins/imageio/storage/libfacebook.so
.else
CMAKE_ARGS+= -DUSE_GLIBJSON:BOOL=OFF
.endif
@@ -118,7 +121,6 @@ LDFLAGS+= -lstdc++
.endif
post-patch:
- @${RM} ${WRKSRC}/data/js/.DS_Store
@${REINPLACE_CMD} -e 's,const gint,gint,' \
${WRKSRC}/src/external/osm-gps-map/src/osm-gps-map-image.*
# Do not install useless (to end-user) documentation; adjust manpages path
@@ -128,12 +130,6 @@ post-patch:
# are used for release builds as well
@${REINPLACE_CMD} -e '/-O3/s,^,#, ; /-msse2/s, -g,,' \
${WRKSRC}/src/CMakeLists.txt
-# Add some missing newlines at the EOF to unbreak the build
- @${ECHO_CMD} >> ${WRKSRC}/src/common/srgb_tone_curve_values.h
- @${ECHO_CMD} >> ${WRKSRC}/src/common/gpx.c
- @${ECHO_CMD} >> ${WRKSRC}/src/gui/drag_and_drop.h
- @${ECHO_CMD} >> ${WRKSRC}/src/gui/gtkentry.c
- @${ECHO_CMD} >> ${WRKSRC}/src/views/map.c
post-install:
.if ! ${PORT_OPTIONS:MRAWSPEED}
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
index 9f91b28aee2e..231166d0d440 100644
--- a/graphics/darktable/distinfo
+++ b/graphics/darktable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (darktable-1.1.tar.gz) = 8f2401422ab3e0bb038b3fedf411aaf69994d679674757ee7886b6146b9fdd4f
-SIZE (darktable-1.1.tar.gz) = 3423644
+SHA256 (darktable-1.1.2.tar.gz) = 225ebf1bd2ca4cf06aa609f2eda55cb0894ae69bdf4db25fd97b2503c28e1765
+SIZE (darktable-1.1.2.tar.gz) = 3432009
diff --git a/graphics/darktable/pkg-plist b/graphics/darktable/pkg-plist
index 1f195e079cba..ce4758c41a73 100644
--- a/graphics/darktable/pkg-plist
+++ b/graphics/darktable/pkg-plist
@@ -102,7 +102,6 @@ lib/darktable/plugins/imageio/format/libppm.so
lib/darktable/plugins/imageio/format/libtiff.so
lib/darktable/plugins/imageio/storage/libdisk.so
lib/darktable/plugins/imageio/storage/libemail.so
-lib/darktable/plugins/imageio/storage/libfacebook.so
lib/darktable/plugins/imageio/storage/libgallery.so
lib/darktable/plugins/imageio/storage/liblatex.so
lib/darktable/plugins/imageio/storage/libpicasa.so
@@ -176,8 +175,6 @@ lib/darktable/plugins/lighttable/libimage.so
lib/darktable/plugins/lighttable/libimport.so
lib/darktable/plugins/lighttable/libkeywords.so
lib/darktable/plugins/lighttable/liblighttable_mode.so
-lib/darktable/plugins/lighttable/liblocation.so
-lib/darktable/plugins/lighttable/libmap_settings.so
lib/darktable/plugins/lighttable/libmetadata.so
lib/darktable/plugins/lighttable/libmetadata_view.so
lib/darktable/plugins/lighttable/libmodule_toolbox.so
@@ -195,7 +192,6 @@ lib/darktable/plugins/lighttable/libview_toolbox.so
lib/darktable/plugins/lighttable/libviewswitcher.so
lib/darktable/views/libdarkroom.so
lib/darktable/views/liblighttable.so
-lib/darktable/views/libmap.so
share/applications/darktable.desktop
share/icons/hicolor/16x16/apps/darktable.png
share/icons/hicolor/22x22/apps/darktable.png