aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/devil
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /graphics/devil
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'graphics/devil')
-rw-r--r--graphics/devil/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 85d0521a6a7f..b85b769040b5 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -33,14 +33,13 @@ USE_GNOME= pkgconfig
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4 -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force-missing
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-ILU \
--disable-allegro --disable-directx8 --disable-directx9
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>