aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/divx4linux4/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-04-23 06:28:49 +0800
committerlioux <lioux@FreeBSD.org>2002-04-23 06:28:49 +0800
commita2e502468e05b495f606fd575be95d367a7ea408 (patch)
tree9756e76fab8972528be3e38717190615c77686b3 /graphics/divx4linux4/Makefile
parent52345e4b33f2e3f2e6bac8904a17f442fbe0c776 (diff)
downloadfreebsd-ports-gnome-a2e502468e05b495f606fd575be95d367a7ea408.tar.gz
freebsd-ports-gnome-a2e502468e05b495f606fd575be95d367a7ea408.tar.zst
freebsd-ports-gnome-a2e502468e05b495f606fd575be95d367a7ea408.zip
o After repo copy from divx4linux: this port will hold previous
DiVX version 4.0 - add NO_LATEST_LINK - install under divx4 prefixes Repo copy by: joe Approved by: kris (repo copy)
Diffstat (limited to 'graphics/divx4linux4/Makefile')
-rw-r--r--graphics/divx4linux4/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/graphics/divx4linux4/Makefile b/graphics/divx4linux4/Makefile
index 0191ca145146..a46272b5f5f7 100644
--- a/graphics/divx4linux4/Makefile
+++ b/graphics/divx4linux4/Makefile
@@ -20,10 +20,13 @@ ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX= yes
WRKSRC= ${WRKDIR}/${DISTNAME:C/_.+$//}
NO_BUILD= yes
+NO_LATEST_LINK= yes
PLIST_SUB= PKGNAME="${PKGNAME}"
RELEASE_DATE= 20011010_4.02
+PKGDEINSTALL= ${PKGINSTALL}
+
post-patch:
.for ext in h linux txt
@${PERL} -pi -e "s/ //" ${WRKSRC}/*.${ext}
@@ -37,10 +40,14 @@ do-install:
.endfor
.endif
# Header file installation
- @${MKDIR} ${PREFIX}/usr/include/divx
- @${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/usr/include/divx
-# Library installation
- @${INSTALL_DATA} ${WRKSRC}/*.so ${PREFIX}/usr/lib
+ @${MKDIR} ${PREFIX}/usr/include/divx4
+ @${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/usr/include/divx4
+ @${MKDIR} ${PREFIX}/usr/lib/divx4
+ @${INSTALL_DATA} ${WRKSRC}/*.so ${PREFIX}/usr/lib/divx4
@${LINUXBASE}/sbin/ldconfig
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.mk>