aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dri
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-11 05:04:44 +0800
committerKoop Mast <kwm@FreeBSD.org>2015-10-11 05:04:44 +0800
commitf28b16021bc7c3ebba3a0097921144535f4ea126 (patch)
tree147ef8eb94fb77af071ff52ef1205ad29e6db0aa /graphics/dri
parent2af73058295ea1e5f1493b9bb162ddd9eea9ec6c (diff)
downloadfreebsd-ports-gnome-f28b16021bc7c3ebba3a0097921144535f4ea126.tar.gz
freebsd-ports-gnome-f28b16021bc7c3ebba3a0097921144535f4ea126.tar.zst
freebsd-ports-gnome-f28b16021bc7c3ebba3a0097921144535f4ea126.zip
Update Mesa to 10.6.9.
* Unbreak build on powerpc and other !x86 archs by moving the --with-dri-drivers logic from dri/Makefile to the libGL/Makefile.common file. So the settings are applied to all mesa ports, this was missed in the 10.6.6 update. [1] * Don't try to enable OpenCL support on anything other then i386 and amd64. [1] * Move the texture-float and vdpau logic to Makefile.common even if the latter isn't supported yet. Keep OPTIONS_DEFINE/DEFAULT in dri/Makefile since they need to defined before bsd.port.options.mk is included, and they only affect the dri modules. * Sed on 11 and 10 supports \< and \> however sed on 9.x and dragonfly do not, replace the sed keywords with some magic to get the intended results. [2] Submitted by: marino@ [2] Reported and tested by: arved@ (on ppc32)[1]
Diffstat (limited to 'graphics/dri')
-rw-r--r--graphics/dri/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 72effc769f20..b8d4cc0f93da 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -25,56 +25,12 @@ PKGHELP= ${.CURDIR}/pkg-help
.include <bsd.port.options.mk>
-ALL_DRI_DRIVERS=I915 I965 R200 RADEON SWRAST
-
.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
#src/mesa/libmesagallium.la
#MESA_BUILD_WRKSRC= src/util src/gallium
#MESA_INSTALL_WRKSRC= src/gallium
-PLIST_SUB+= VERSION=${MESADISTVERSION}
-
-.if ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == ia64
-DRI_DRIVERS= ${ALL_DRI_DRIVERS}
-.endif
-
-.if ${PORT_OPTIONS:MTEXTURE}
-CONFIGURE_ARGS+=--enable-texture-float
-.endif
-
-.if 0 #${PORT_OPTIONS:MVDPAU}
-.if ${PORT_OPTIONS:MGALLIUM} == ""
-IGNORE= VDPAU option requires GALLIUM support to be enabled
-.endif
-CONFIGURE_ARGS+=--enable-vdpau
-LIB_DEPENDS+= libvdpau.so:${PORTSDIR}/multimedia/libvdpau
-PLIST_SUB+= VDPAU=""
-.else
-CONFIGURE_ARGS+=--disable-vdpau
-PLIST_SUB+= VDPAU="@comment "
-.endif
-
-.if ${ARCH} == powerpc || ${ARCH} == powerpc64
-DRI_DRIVERS= RADEON SWRAST
-.endif
-.if ${ARCH} == sparc64 || ${ARCH} == armv6
-DRI_DRIVERS= SWRAST
-.endif
-
-# empty for unsupported arches
-DRI_DRIVERS+=
-
-.for _d in ${ALL_DRI_DRIVERS}
-. if ${DRI_DRIVERS:M${_d}}
-PLIST_SUB+= ${_d}_DRIVER=""
-. else
-PLIST_SUB+= ${_d}_DRIVER="@comment "
-. endif
-.endfor
-
-CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:tl}"
-
.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
post-install: