aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/drm-kmod/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-14 02:36:04 +0800
committermiwi <miwi@FreeBSD.org>2007-03-14 02:36:04 +0800
commit63cb3fd1ae3c6fe0db2dadcdec2f9fbfd1c01813 (patch)
treea8392c717bbcdc0dcad11855ccdabece0f0e1318 /graphics/drm-kmod/Makefile
parent23f9531c95fbe5eab5bb0feb4907681289720e0e (diff)
downloadfreebsd-ports-gnome-63cb3fd1ae3c6fe0db2dadcdec2f9fbfd1c01813.tar.gz
freebsd-ports-gnome-63cb3fd1ae3c6fe0db2dadcdec2f9fbfd1c01813.tar.zst
freebsd-ports-gnome-63cb3fd1ae3c6fe0db2dadcdec2f9fbfd1c01813.zip
2007-03-01 www/ruby-webunit: has deprecated dependencies
2007-03-07 emulators/grustibus: Project was abandoned 6 years ago and expects an old version of xmame (0.37b4), please use other frontends instead (like gxmame) 2007-03-10 graphics/drm-kmod: Broken on all supported versions of FreeBSD
Diffstat (limited to 'graphics/drm-kmod/Makefile')
-rw-r--r--graphics/drm-kmod/Makefile64
1 files changed, 0 insertions, 64 deletions
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
deleted file mode 100644
index b8227df3387f..000000000000
--- a/graphics/drm-kmod/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# Ports collection makefile for: drm-kmod
-# Date created: 6 October 2001
-# Whom: Eric Anholt <eanholt@gladstone.uoregon.edu>
-#
-# $FreeBSD$
-#
-
-PORTNAME= drm-kmod
-PORTVERSION= 0.9.6
-CATEGORIES= graphics x11
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= anholt
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A FreeBSD kernel modules for 3d acceleration with the DRI
-
-DEPRECATED= Broken on all supported versions of FreeBSD
-EXPIRATION_DATE=2007-03-10
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PKGMESSAGE= ${WRKSRC}/.MESSAGE
-
-.include <bsd.port.pre.mk>
-
-ONLY_FOR_ARCHS= i386
-.if ${OSVERSION} < 400006
-BROKEN= "FreeBSD before 4.1 is not supported"
-.elif ${OSVERSION} > 500000
-IGNORE= "FreeBSD 5.0 has DRM supplied by the kernel"
-.endif
-
-.if defined(WITH_SMP)
-CFLAGS+= -DSMP -DAPIC_IO
-.endif
-
-pre-extract:
-.if !defined(WITH_SMP)
- @${ECHO_MSG} "If you are using modules on an SMP system, use "make -DWITH_SMP" to get SMP locking"
- @${ECHO_MSG}
-.endif
- @${ECHO_MSG} "If you don't want linux compatibility, use make -DDRM_NOLINUX"
- @${ECHO_MSG}
-
-pre-patch:
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/drm.sh
-
-pre-install:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > \
- ${PKGMESSAGE}
-
-do-install:
- ${MKDIR} ${PREFIX}/lib/drm
- ${INSTALL_PROGRAM} ${WRKSRC}/tdfx/tdfx.ko ${PREFIX}/lib/drm/
- ${INSTALL_PROGRAM} ${WRKSRC}/mga/mga.ko ${PREFIX}/lib/drm/
- ${INSTALL_PROGRAM} ${WRKSRC}/r128/r128.ko ${PREFIX}/lib/drm/
- ${INSTALL_PROGRAM} ${WRKSRC}/radeon/radeon.ko ${PREFIX}/lib/drm/
- ${INSTALL_PROGRAM} ${WRKSRC}/gamma/gamma.ko ${PREFIX}/lib/drm/
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/drm.sh ${PREFIX}/etc/rc.d/drm.sh.sample
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>