aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-09-01 06:33:40 +0800
committersat <sat@FreeBSD.org>2007-09-01 06:33:40 +0800
commit09fc324ae4b00a9a752d0c484dfbf442926f517e (patch)
treeddb4f3fb7f92811f88ebe8680ff0d2be0513b77a /graphics/exact-image
parentd6b19b9f44096714e3a6cf179a263e9d2e4b3b9d (diff)
downloadfreebsd-ports-gnome-09fc324ae4b00a9a752d0c484dfbf442926f517e.tar.gz
freebsd-ports-gnome-09fc324ae4b00a9a752d0c484dfbf442926f517e.tar.zst
freebsd-ports-gnome-09fc324ae4b00a9a752d0c484dfbf442926f517e.zip
- Remove a few bashisms from configure to fix build
Reported by: pointyhat via kris
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 8e9bd4c2f41a..718a63f47e6d 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -40,8 +40,8 @@ post-extract:
@${RM} -rf ${WRKSRC}/agg-2.4/
post-patch:
- @${REINPLACE_CMD} -e '1s|/.*|/bin/sh|;s|libpng|libpng12|'\
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '1s|/.*|/bin/sh|;s|libpng|libpng12|;\
+ /parse_options/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^Q =/d;s|$$[(]COMPILE.cc[)]|${CXX} $${CPPFLAGS} -c|;\
s|$$[(]CXX[)]|${CXX}|;s|$$[(]COMPILE.c[)]|${CC} $${CPPFLAGS} -c|'\
${WRKSRC}/build/bottom.make
@@ -49,8 +49,8 @@ post-patch:
/mtune=/d;/call cc-option/d;' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/CFLAGS=/s|".*"|"${CFLAGS} -I${LOCALBASE}/include"|;\
/LIBS=/s|".*"|"-L${LOCALBASE}/lib -lX11"|' ${WRKSRC}/config/pkgcheck-x11.c
- @${REINPLACE_CMD} -e 's|$$prg|$$prg -I${LOCALBASE}/include|'\
- ${WRKSRC}/config/functions
+ @${REINPLACE_CMD} -e 's|$$prg|$$prg -I${LOCALBASE}/include|;\
+ /^var_remove/,/^}/d;/^parse_options/,/^}/d' ${WRKSRC}/config/functions
post-configure:
@${REINPLACE_CMD} -e '/EVASGL/s|1|0|' ${WRKSRC}/config.h