aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/freeglut
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /graphics/freeglut
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'graphics/freeglut')
-rw-r--r--graphics/freeglut/Makefile9
-rw-r--r--graphics/freeglut/distinfo4
-rw-r--r--graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c18
-rw-r--r--graphics/freeglut/pkg-message9
4 files changed, 17 insertions, 23 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index 9cf3c9f18cdc..08ab4bf17c92 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -1,7 +1,8 @@
+# Created by: thierry@pompo.net
# $FreeBSD$
PORTNAME= freeglut
-PORTVERSION= 2.8.0
+PORTVERSION= 2.8.1
CATEGORIES= graphics
MASTER_SITES= SF
@@ -27,6 +28,8 @@ DOCS= download.html freeglut.html freeglut_logo.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
+.include <bsd.port.options.mk>
+
pre-configure:
.for fract in Fractals/fractals.c Fractals_random/fractals_random.c
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
@@ -38,14 +41,14 @@ post-build:
${WRKSRC}/progs/demos/CallbackMaker/.libs/callbackmaker
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat ${EXAMPLESDIR}
.for prog in ${BINS}
diff --git a/graphics/freeglut/distinfo b/graphics/freeglut/distinfo
index 81ae29d16744..a0bf5031d1c0 100644
--- a/graphics/freeglut/distinfo
+++ b/graphics/freeglut/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freeglut-2.8.0.tar.gz) = 197293ff886abe613bc9eb4a762d9161b0c9e64b3e8e613ed7c5e353974fba05
-SIZE (freeglut-2.8.0.tar.gz) = 979459
+SHA256 (freeglut-2.8.1.tar.gz) = dde46626a62a1cd9cf48a11951cdd592e7067c345cffe193a149dfd47aef999a
+SIZE (freeglut-2.8.1.tar.gz) = 1005343
diff --git a/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c b/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c
deleted file mode 100644
index 8f12afa8b524..000000000000
--- a/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- progs/demos/smooth_opengl3/smooth_opengl3.c.orig 2012-01-04 14:38:43.000000000 +0100
-+++ progs/demos/smooth_opengl3/smooth_opengl3.c 2012-01-04 14:39:10.000000000 +0100
-@@ -98,6 +98,7 @@
- #define APIENTRY
- #endif
-
-+#ifndef GL_VERSION_1_5
- typedef void (APIENTRY *PFNGLGENBUFFERSPROC) (GLsizei n, GLuint *buffers);
- typedef void (APIENTRY *PFNGLBINDBUFFERPROC) (GLenum target, GLuint buffer);
- typedef void (APIENTRY *PFNGLBUFFERDATAPROC) (GLenum target, ourGLsizeiptr size, const GLvoid *data, GLenum usage);
-@@ -117,6 +118,7 @@
- typedef void (APIENTRY *PFNGLENABLEVERTEXATTRIBARRAYPROC) (GLuint index);
- typedef GLint (APIENTRY *PFNGLGETUNIFORMLOCATIONPROC) (GLuint program, const ourGLchar *name);
- typedef void (APIENTRY *PFNGLUNIFORMMATRIX4FVPROC) (GLint location, GLsizei count, GLboolean transpose, const GLfloat *value);
-+#endif
-
- PFNGLGENBUFFERSPROC gl_GenBuffers;
- PFNGLBINDBUFFERPROC gl_BindBuffer;
diff --git a/graphics/freeglut/pkg-message b/graphics/freeglut/pkg-message
new file mode 100644
index 000000000000..f41059efbc28
--- /dev/null
+++ b/graphics/freeglut/pkg-message
@@ -0,0 +1,9 @@
+Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
+(yet). To workaround this a small patch adds one include file and comments out
+content of one function (only leaves return NULL).
+
+This might cause side effects. Joysticks do not work, and there might be ports
+that do not compile or applications that crash because of this.
+
+Do not hesitate to contact x11@FreeBSD.org if there are any issues and side
+effects because of this.