aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/frei0r
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-09-26 02:18:26 +0800
committermakc <makc@FreeBSD.org>2010-09-26 02:18:26 +0800
commit3469b4f80f78f29f273417bd21b9eff17e963df4 (patch)
tree7c0104870ec088af8d2a231154cca6a1e44ec2ee /graphics/frei0r
parent1a82a761e390dc7d85b37618872fbc233050cf9f (diff)
downloadfreebsd-ports-gnome-3469b4f80f78f29f273417bd21b9eff17e963df4.tar.gz
freebsd-ports-gnome-3469b4f80f78f29f273417bd21b9eff17e963df4.tar.zst
freebsd-ports-gnome-3469b4f80f78f29f273417bd21b9eff17e963df4.zip
- Update graphics/frei0r to version 1.2
Makefile changes: - Add LICENSE - Update MASTER_SITES - Use gnomehack for proper pc file installation - Hack documentation installation to make it optional, it needed patched to install in the correct location anyways - Disable CPU optimizations by default PR: ports/150871 Submitted by: Jason E. Hale (maintainer)
Diffstat (limited to 'graphics/frei0r')
-rw-r--r--graphics/frei0r/Makefile45
-rw-r--r--graphics/frei0r/distinfo6
-rw-r--r--graphics/frei0r/pkg-plist91
3 files changed, 133 insertions, 9 deletions
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
index 4b11ff4062c0..bbd77530ad3e 100644
--- a/graphics/frei0r/Makefile
+++ b/graphics/frei0r/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= frei0r
-PORTVERSION= 1.1.22
-PORTREVISION= 4
+PORTVERSION= 1.2
DISTVERSIONPREFIX= plugins-
CATEGORIES= graphics
-MASTER_SITES= http://propirate.net/${PORTNAME}/ \
+MASTER_SITES= http://piksel.no/${PORTNAME}/ \
+ ftp://ftp.dyne.org/${PORTNAME}/releases/ \
http://distfiles.macports.org/${PORTNAME}-plugins/
MAINTAINER= bsdkaffee@gmail.com
@@ -20,13 +20,50 @@ LIB_DEPENDS= cv.2:${PORTSDIR}/graphics/opencv \
gavl.1:${PORTSDIR}/multimedia/gavl
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
+USE_GNOME= gnomehack pkgconfig
MAKE_JOBS_SAFE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PORTDOCS= AUTHORS ChangeLog README TODO
+
+OPTIONS= APIDOC "Install full documentation (requires doxygen)" off \
+ MMX "Enable MMX CPU instructions" off
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
USE_GCC= 4.2+
.endif
+.if defined(WITH_APIDOC)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+PLIST_SUB+= APIDOC=""
+.else
+PLIST_SUB+= APIDOC="@comment "
+.endif
+
+.if !defined(WITH_MMX)
+CONFIGURE_ARGS+=--disable-cpuflags
+.endif
+
+post-patch:
+.if !defined(WITH_APIDOC)
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s| doc||' ${WRKSRC}/Makefile.in
+.endif
+ @${REINPLACE_CMD} -e 's|^docsdir.*|docsdir = ${DOCSDIR}|' \
+ -e '/^install-data-am/s| install-docsDATA||' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^htmldocsdir.*|htmldocsdir = ${DOCSDIR}|' \
+ ${WRKSRC}/doc/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/frei0r/distinfo b/graphics/frei0r/distinfo
index 7965efef5ea8..9e6be550e98e 100644
--- a/graphics/frei0r/distinfo
+++ b/graphics/frei0r/distinfo
@@ -1,3 +1,3 @@
-MD5 (frei0r-plugins-1.1.22.tar.gz) = 8123893c67fc5ce01ddcb09853d47ed4
-SHA256 (frei0r-plugins-1.1.22.tar.gz) = 436e933c079bdf8b3d2d2b2fcc9a601c82ba68f34af6f0716ba837041a149da0
-SIZE (frei0r-plugins-1.1.22.tar.gz) = 570186
+MD5 (frei0r-plugins-1.2.tar.gz) = 7af2a36c33af2cd3dbd28e3ac79a3645
+SHA256 (frei0r-plugins-1.2.tar.gz) = d8bc193d486c35138dfb4ab4a00f9f34725bfabc2a03f0bb54f04df2c65d692a
+SIZE (frei0r-plugins-1.2.tar.gz) = 1019079
diff --git a/graphics/frei0r/pkg-plist b/graphics/frei0r/pkg-plist
index 7deefb592253..4673b82b6bfa 100644
--- a/graphics/frei0r/pkg-plist
+++ b/graphics/frei0r/pkg-plist
@@ -5,31 +5,43 @@ lib/frei0r-1/G.so
lib/frei0r-1/R.so
lib/frei0r-1/RGB.so
lib/frei0r-1/addition.so
+lib/frei0r-1/alpha0ps.so
lib/frei0r-1/alphaatop.so
+lib/frei0r-1/alphagrad.so
lib/frei0r-1/alphain.so
lib/frei0r-1/alphainjection.so
lib/frei0r-1/alphaout.so
lib/frei0r-1/alphaover.so
+lib/frei0r-1/alphaspot.so
lib/frei0r-1/alphaxor.so
+lib/frei0r-1/balanc0r.so
+lib/frei0r-1/baltan.so
lib/frei0r-1/blend.so
+lib/frei0r-1/bluescreen0r.so
lib/frei0r-1/brightness.so
lib/frei0r-1/burn.so
lib/frei0r-1/bw0r.so
+lib/frei0r-1/c0rners.so
lib/frei0r-1/cartoon.so
lib/frei0r-1/cluster.so
lib/frei0r-1/color_only.so
+lib/frei0r-1/coloradj_RGB.so
lib/frei0r-1/colordistance.so
lib/frei0r-1/composition.so
lib/frei0r-1/contrast0r.so
+lib/frei0r-1/curves.so
+lib/frei0r-1/d90stairsteppingfix.so
lib/frei0r-1/darken.so
+lib/frei0r-1/defish0r.so
lib/frei0r-1/delay0r.so
+lib/frei0r-1/delaygrab.so
lib/frei0r-1/difference.so
lib/frei0r-1/distort0r.so
lib/frei0r-1/divide.so
lib/frei0r-1/dodge.so
lib/frei0r-1/edgeglow.so
lib/frei0r-1/equaliz0r.so
-lib/frei0r-1/facedetect.so
+lib/frei0r-1/facebl0r.so
lib/frei0r-1/flippo.so
lib/frei0r-1/gamma.so
lib/frei0r-1/glow.so
@@ -42,34 +54,109 @@ lib/frei0r-1/invert0r.so
lib/frei0r-1/ising0r.so
lib/frei0r-1/lenscorrection.so
lib/frei0r-1/letterb0xed.so
+lib/frei0r-1/levels.so
lib/frei0r-1/lighten.so
lib/frei0r-1/lissajous0r.so
lib/frei0r-1/luminance.so
lib/frei0r-1/mask0mate.so
lib/frei0r-1/multiply.so
+lib/frei0r-1/nervous.so
lib/frei0r-1/nois0r.so
lib/frei0r-1/nosync0r.so
lib/frei0r-1/onecol0r.so
lib/frei0r-1/overlay.so
+lib/frei0r-1/partik0l.so
lib/frei0r-1/perspective.so
lib/frei0r-1/pixeliz0r.so
+lib/frei0r-1/plasma.so
+lib/frei0r-1/pr0be.so
+lib/frei0r-1/pr0file.so
+lib/frei0r-1/primaries.so
lib/frei0r-1/rgbparade.so
lib/frei0r-1/saturat0r.so
lib/frei0r-1/saturation.so
lib/frei0r-1/scale0tilt.so
lib/frei0r-1/scanline0r.so
lib/frei0r-1/screen.so
+lib/frei0r-1/select0r.so
lib/frei0r-1/sobel.so
lib/frei0r-1/softlight.so
+lib/frei0r-1/sopsat.so
lib/frei0r-1/squareblur.so
lib/frei0r-1/subtract.so
lib/frei0r-1/tehroxx0r.so
+lib/frei0r-1/three_point_balance.so
+lib/frei0r-1/threelay0r.so
lib/frei0r-1/threshold0r.so
+lib/frei0r-1/tint0r.so
lib/frei0r-1/transparency.so
lib/frei0r-1/twolay0r.so
lib/frei0r-1/uvmap.so
lib/frei0r-1/value.so
lib/frei0r-1/vectorscope.so
-lib/frei0r-1/water.so
+lib/frei0r-1/vertigo.so
lib/frei0r-1/xfade0r.so
+libdata/pkgconfig/frei0r.pc
+%%APIDOC%%%%DOCSDIR%%/html/annotated.html
+%%APIDOC%%%%DOCSDIR%%/html/bc_s.png
+%%APIDOC%%%%DOCSDIR%%/html/classes.html
+%%APIDOC%%%%DOCSDIR%%/html/closed.png
+%%APIDOC%%%%DOCSDIR%%/html/dir_8172e6efa965a0ce46c3309e91d1b84c.html
+%%APIDOC%%%%DOCSDIR%%/html/dir_8172e6efa965a0ce46c3309e91d1b84c_dep.map
+%%APIDOC%%%%DOCSDIR%%/html/dir_8172e6efa965a0ce46c3309e91d1b84c_dep.md5
+%%APIDOC%%%%DOCSDIR%%/html/dir_8172e6efa965a0ce46c3309e91d1b84c_dep.png
+%%APIDOC%%%%DOCSDIR%%/html/dirs.html
+%%APIDOC%%%%DOCSDIR%%/html/doxygen.css
+%%APIDOC%%%%DOCSDIR%%/html/doxygen.png
+%%APIDOC%%%%DOCSDIR%%/html/files.html
+%%APIDOC%%%%DOCSDIR%%/html/frei0r_8h.html
+%%APIDOC%%%%DOCSDIR%%/html/frei0r_8h__incl.map
+%%APIDOC%%%%DOCSDIR%%/html/frei0r_8h__incl.md5
+%%APIDOC%%%%DOCSDIR%%/html/frei0r_8h__incl.png
+%%APIDOC%%%%DOCSDIR%%/html/frei0r_8h_source.html
+%%APIDOC%%%%DOCSDIR%%/html/ftv2blank.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2doc.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2folderclosed.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2folderopen.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2lastnode.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2link.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2mlastnode.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2mnode.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2node.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2plastnode.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2pnode.png
+%%APIDOC%%%%DOCSDIR%%/html/ftv2vertline.png
+%%APIDOC%%%%DOCSDIR%%/html/functions.html
+%%APIDOC%%%%DOCSDIR%%/html/functions_vars.html
+%%APIDOC%%%%DOCSDIR%%/html/globals.html
+%%APIDOC%%%%DOCSDIR%%/html/globals_defs.html
+%%APIDOC%%%%DOCSDIR%%/html/globals_func.html
+%%APIDOC%%%%DOCSDIR%%/html/globals_type.html
+%%APIDOC%%%%DOCSDIR%%/html/graph_legend.html
+%%APIDOC%%%%DOCSDIR%%/html/graph_legend.md5
+%%APIDOC%%%%DOCSDIR%%/html/graph_legend.png
+%%APIDOC%%%%DOCSDIR%%/html/group___c_o_l_o_r___m_o_d_e_l.html
+%%APIDOC%%%%DOCSDIR%%/html/group___p_a_r_a_m___t_y_p_e.html
+%%APIDOC%%%%DOCSDIR%%/html/group___p_l_u_g_i_n___t_y_p_e.html
+%%APIDOC%%%%DOCSDIR%%/html/group__concurrency.html
+%%APIDOC%%%%DOCSDIR%%/html/group__icons.html
+%%APIDOC%%%%DOCSDIR%%/html/group__pluglocations.html
+%%APIDOC%%%%DOCSDIR%%/html/index.html
+%%APIDOC%%%%DOCSDIR%%/html/main.html
+%%APIDOC%%%%DOCSDIR%%/html/modules.html
+%%APIDOC%%%%DOCSDIR%%/html/nav_f.png
+%%APIDOC%%%%DOCSDIR%%/html/nav_h.png
+%%APIDOC%%%%DOCSDIR%%/html/open.png
+%%APIDOC%%%%DOCSDIR%%/html/structf0r__param__color.html
+%%APIDOC%%%%DOCSDIR%%/html/structf0r__param__info.html
+%%APIDOC%%%%DOCSDIR%%/html/structf0r__param__position.html
+%%APIDOC%%%%DOCSDIR%%/html/structf0r__plugin__info.html
+%%APIDOC%%%%DOCSDIR%%/html/tab_a.png
+%%APIDOC%%%%DOCSDIR%%/html/tab_b.png
+%%APIDOC%%%%DOCSDIR%%/html/tab_h.png
+%%APIDOC%%%%DOCSDIR%%/html/tab_s.png
+%%APIDOC%%%%DOCSDIR%%/html/tabs.css
+%%APIDOC%%%%DOCSDIR%%/html/tree.html
+%%APIDOC%%@dirrm %%DOCSDIR%%/html
+%%APIDOC%%@dirrmtry %%DOCSDIR%%
@dirrm lib/frei0r-1