aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gbm
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
committerkwm <kwm@FreeBSD.org>2014-10-17 17:53:13 +0800
commitd6afb37e19f66eed665826275fba54cca09a8c89 (patch)
tree10eadf882ac174da154c3fda250d8872d4fa1acc /graphics/gbm
parent4bc9e1fc7d12f2e377422acc4d926720bde09698 (diff)
downloadfreebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.gz
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.tar.zst
freebsd-ports-gnome-d6afb37e19f66eed665826275fba54cca09a8c89.zip
Update Mesa ports to new default of 9.1.7 and more recent version to 10.3.0.
The port will switch to the newer version if hw context is available in the i915kms driver. - Get ride of WITH_NEW_XORG. - Use @comment in plist to ignore unwanted files in the stagedir, instead of trying to remove them in post-install. - Bump portrevision of 9.1.7 due to dependency changes. - Drop :keepla from USES=libtool. - Drop @dirrm[try] from plists - Give dri propper options, with pkg-help for additional information. - Make separate plist for dri for the different versions, the combined plist was headache inducing. - Add "workaround" patches to allow clang to build the dri port on i386 [1]. USE_GCC is now only needed for 8.x. - Add gbm port and USE_GL switch for it. PR: 192286 [1] Submitted by: Carlos Jacobo Puga Medina [1] Approved by: portmgr (bapt@) In collaberation with: dumbbell@ Obtained from: xorg-dev
Diffstat (limited to 'graphics/gbm')
-rw-r--r--graphics/gbm/Makefile41
-rw-r--r--graphics/gbm/pkg-descr3
-rw-r--r--graphics/gbm/pkg-plist5
3 files changed, 49 insertions, 0 deletions
diff --git a/graphics/gbm/Makefile b/graphics/gbm/Makefile
new file mode 100644
index 000000000000..c2c08e15fa97
--- /dev/null
+++ b/graphics/gbm/Makefile
@@ -0,0 +1,41 @@
+# Created by: kwm@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= gbm
+PORTVERSION= ${MESAVERSION}
+PORTREVISION= ${GBM_REVISION}
+CATEGORIES= graphics
+
+COMMENT= gbm library
+
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libglapi.so:${PORTSDIR}/graphics/libglapi
+
+USE_XORG= x11 xau xcb xdmcp
+
+# stuff not needed by gbm but configure wants it
+USE_XORG+= glproto dri2proto xext xdamage xfixes presentproto \
+ xshmfence
+
+BUILD_WRKSRC= ${WRKSRC}/src/gbm
+INSTALL_WRKSRC= ${WRKSRC}/src/gbm
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
+
+.if defined(WITH_NEW_MESA)
+GBM_REVISION= 0
+.else
+GBM_REVISION= 0
+.endif
+
+pre-build:
+.if defined(WITH_NEW_MESA)
+ @cd ${WRKSRC}/src/mapi/ && ${MAKE_CMD} ${_MAKE_JOBS}
+.else
+ @cd ${WRKSRC}/src/mapi/shared-glapi && ${MAKE_CMD} ${_MAKE_JOBS}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gbm/pkg-descr b/graphics/gbm/pkg-descr
new file mode 100644
index 000000000000..f0ed995240bf
--- /dev/null
+++ b/graphics/gbm/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the EGL utility library.
+
+WWW: http://www.freedesktop.org/Software/xorg
diff --git a/graphics/gbm/pkg-plist b/graphics/gbm/pkg-plist
new file mode 100644
index 000000000000..891e4aeed89b
--- /dev/null
+++ b/graphics/gbm/pkg-plist
@@ -0,0 +1,5 @@
+include/gbm.h
+lib/libgbm.so
+lib/libgbm.so.1
+lib/libgbm.so.1.0.0
+libdata/pkgconfig/gbm.pc