aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gd
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-06-09 22:25:41 +0800
committerJan Beich <jbeich@FreeBSD.org>2015-06-09 22:25:41 +0800
commitf2fc9d6de460a59d2ca4633a80086dc32e24c086 (patch)
tree2ac32e924ca63b881b3775b37ea4a9ca3a11cc2c /graphics/gd
parent6828ea7d03181d2c9cef8349278476494f34aeaa (diff)
downloadfreebsd-ports-gnome-f2fc9d6de460a59d2ca4633a80086dc32e24c086.tar.gz
freebsd-ports-gnome-f2fc9d6de460a59d2ca4633a80086dc32e24c086.tar.zst
freebsd-ports-gnome-f2fc9d6de460a59d2ca4633a80086dc32e24c086.zip
multimedia/libvpx: update to 1.4.0
ABI isn't compatible, so bump PORTREVISION in consumers. Changes: https://chromium.googlesource.com/webm/libvpx/+/v1.4.0 Differential Revision: https://reviews.freebsd.org/D2570 Exp-run by: antoine Approved by: ashish, multimedia (kwm) Approved by: maintainer timeout (ale, dinoex; 2 weeks)
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/gd/files/patch-webpimg.c29
2 files changed, 30 insertions, 1 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index dc958f05f4b1..6f212d1833f5 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgd
PORTVERSION= 2.1.0
-PORTREVISION?= 5
+PORTREVISION?= 6
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= https://bitbucket.org/libgd/gd-libgd/downloads/ \
diff --git a/graphics/gd/files/patch-webpimg.c b/graphics/gd/files/patch-webpimg.c
new file mode 100644
index 000000000000..2b62d09f95e3
--- /dev/null
+++ b/graphics/gd/files/patch-webpimg.c
@@ -0,0 +1,29 @@
+Adjust to libvpx 1.4.0 until the code is removed.
+
+https://chromium.googlesource.com/webm/libvpx/+/9cdaa3d%5E!/
+https://bitbucket.org/libgd/gd-libgd/commits/824a3aa
+
+--- src/webpimg.c.orig 2013-06-25 09:58:23 UTC
++++ src/webpimg.c
+@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8*
+ codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
+ codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
+
+- vpx_img_wrap(&img, IMG_FMT_I420,
++ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
+ y_width, y_height, 16, (uint8*)(Y));
+- img.planes[PLANE_Y] = (uint8*)(Y);
+- img.planes[PLANE_U] = (uint8*)(U);
+- img.planes[PLANE_V] = (uint8*)(V);
+- img.stride[PLANE_Y] = y_stride;
+- img.stride[PLANE_U] = uv_stride;
+- img.stride[PLANE_V] = uv_stride;
++ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
++ img.planes[VPX_PLANE_U] = (uint8*)(U);
++ img.planes[VPX_PLANE_V] = (uint8*)(V);
++ img.stride[VPX_PLANE_Y] = y_stride;
++ img.stride[VPX_PLANE_U] = uv_stride;
++ img.stride[VPX_PLANE_V] = uv_stride;
+
+ res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
+